aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael G. Martins <rafael@rafaelmartins.eng.br>2010-07-21 18:24:45 -0300
committerRafael G. Martins <rafael@rafaelmartins.eng.br>2010-07-21 18:24:45 -0300
commit212f4cef7dc33fc9099633dca75ae3b852e6288f (patch)
tree523dbddca85d37dfb5a6a0ee0708c1e47a7f0e13
parentadded the search of packages (diff)
downloadg-octave-212f4cef7dc33fc9099633dca75ae3b852e6288f.tar.gz
g-octave-212f4cef7dc33fc9099633dca75ae3b852e6288f.tar.bz2
g-octave-212f4cef7dc33fc9099633dca75ae3b852e6288f.zip
removed the implicit mask of live versions from the g_octave.ebuild module
-rw-r--r--g_octave/ebuild.py8
1 files changed, 3 insertions, 5 deletions
diff --git a/g_octave/ebuild.py b/g_octave/ebuild.py
index b7aee0d..82a4f60 100644
--- a/g_octave/ebuild.py
+++ b/g_octave/ebuild.py
@@ -45,8 +45,9 @@ re_keywords = re.compile(r'(~)?(alpha|amd64|hppa|ppc64|ppc|sparc|x86)')
class Ebuild:
- def __init__(self, pkg_atom, force=False, conf=None, pkg_manager=None):
+ def __init__(self, pkg_atom, scm=False, force=False, conf=None, pkg_manager=None):
+ self.__scm = scm
self.__force = force
self.__conf = conf
self.__pkg_manager = pkg_manager
@@ -57,7 +58,6 @@ class Ebuild:
self._config = conf
self.__dbtree = DescriptionTree(conf = self._config)
- self.svn_version = False
atom = re_pkg_atom.match(pkg_atom)
if atom == None:
@@ -66,10 +66,8 @@ class Ebuild:
else:
self.pkgname = atom.group(1)
self.version = atom.group(2)
- if has_svn and self.version == '9999':
- self.svn_version = True
- if self.svn_version:
+ if self.__scm:
category = self.__dbtree.categories.get(self.pkgname, None)
if category is not None:
self.__desc = SvnDescription(category, self.pkgname)