aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael G. Martins <rafael@rafaelmartins.eng.br>2010-08-02 06:42:32 -0300
committerRafael G. Martins <rafael@rafaelmartins.eng.br>2010-08-02 06:42:32 -0300
commitbcb8d441537fbd7dc6a2a399b2ee292e36afade1 (patch)
tree3709c8cca9d65f3f99b91c59641c1dc9b4e7757e
parenthardcoding the ebuild year. leave this dinamic can broke some tests (diff)
downloadg-octave-bcb8d441537fbd7dc6a2a399b2ee292e36afade1.tar.gz
g-octave-bcb8d441537fbd7dc6a2a399b2ee292e36afade1.tar.bz2
g-octave-bcb8d441537fbd7dc6a2a399b2ee292e36afade1.zip
updated ebuilds
-rw-r--r--ebuilds/g-octave-0.3.ebuild (renamed from ebuilds/g-octave-0.2.1.ebuild)10
-rw-r--r--ebuilds/g-octave-9999.ebuild36
2 files changed, 21 insertions, 25 deletions
diff --git a/ebuilds/g-octave-0.2.1.ebuild b/ebuilds/g-octave-0.3.ebuild
index 428497b..8ba64fe 100644
--- a/ebuilds/g-octave-0.2.1.ebuild
+++ b/ebuilds/g-octave-0.3.ebuild
@@ -13,10 +13,10 @@ INFO_REV="1"
DESCRIPTION="A tool that generates and installs ebuilds for Octave-Forge"
HOMEPAGE="http://g-octave.rafaelmartins.eng.br/"
-SRC_URI="http://g-octave.rafaelmartins.eng.br/distfiles/releases/${P}.tar.gz
- http://g-octave.rafaelmartins.eng.br/distfiles/db/octave-forge-${MY_PV}.db.tar.gz
- http://g-octave.rafaelmartins.eng.br/distfiles/db/info-${MY_PV}-${INFO_REV}.json"
- #http://g-octave.rafaelmartins.eng.br/distfiles/db/patches-${MY_PV}-${PATCHES_REV}.tar.gz"
+SRC_URI="http://soc.dev.gentoo.org/~rafaelmartins/g-octave/releases/${P}.tar.gz
+ http://soc.dev.gentoo.org/~rafaelmartins/g-octave/db/octave-forge-${MY_PV}.db.tar.gz
+ http://soc.dev.gentoo.org/~rafaelmartins/g-octave/db/info-${MY_PV}-${INFO_REV}.json"
+ #http://soc.dev.gentoo.org/~rafaelmartins/g-octave/db/patches-${MY_PV}-${PATCHES_REV}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
@@ -62,6 +62,8 @@ pkg_postinst() {
elog 'edit your configuration file, clean your db directory and run:'
elog " emerge --config =${PF}"
elog
+ elog 'Please install the package manager that you want to use before run g-octave'
+ elog
}
pkg_config() {
diff --git a/ebuilds/g-octave-9999.ebuild b/ebuilds/g-octave-9999.ebuild
index ebab60f..17c3993 100644
--- a/ebuilds/g-octave-9999.ebuild
+++ b/ebuilds/g-octave-9999.ebuild
@@ -4,37 +4,27 @@
EAPI="2"
-inherit distutils mercurial
+SUPPORT_PYTHON_ABIS="1"
+PYTHON_DEPEND="*:2.6"
+
+inherit distutils git
DESCRIPTION="A tool that generates and installs ebuilds for Octave-Forge"
-HOMEPAGE="http://g-octave.rafaelmartins.eng.br/"
-EHG_REPO_URI="http://g-octave.rafaelmartins.eng.br/hg/"
+HOMEPAGE="http://www.g-octave.org/"
+EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/g-octave.git"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="svn test"
+IUSE="test"
-CDEPEND="( >=dev-lang/python-2.6 <dev-lang/python-3 )"
-DEPEND="${CDEPEND}
- >=dev-python/docutils-0.6"
-RDEPEND="${CDEPEND}
- svn? ( dev-python/pysvn )
- || ( >=sys-apps/portage-2.1.7[-python3] <sys-apps/portage-2.1.7 )"
+DEPEND=">=dev-python/docutils-0.6"
+RDEPEND="sys-apps/portage"
-S="${WORKDIR}/hg"
+S="${WORKDIR}/${PN}"
PYTHON_MODNAME="g_octave"
-src_prepare() {
- distutils_src_prepare
- if ! use svn; then
- rm -rf g_octave/svn/ || die 'failed to remove the Subversion stuff.'
- sed -i -e '/g_octave.svn/d' -e '/pysvn/d' setup.py \
- || die 'failed to remove the SVN stuff from setup.py'
- fi
-}
-
src_install() {
distutils_src_install
dohtml ${PN}.html
@@ -42,5 +32,9 @@ src_install() {
}
src_test() {
- PYTHONPATH=. scripts/run_tests.py || die "test failed."
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" \
+ scripts/run_tests.py || die 'test failed.'
+ }
+ python_execute_function testing
}