summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2022-08-16 05:11:34 +0300
committerAzamat H. Hackimov <azamat.hackimov@gmail.com>2022-08-16 05:11:34 +0300
commitb59746c409ff7ea4ec44d6abec9cdde3ef169cfb (patch)
tree56408e7f8869689fa7cda06c15a4dea4863523dc
parentgames-rpg/arx-libertatis: add 1.2.1, drop 1.1.2_p2-r1 (diff)
downloadgamerlay-b59746c409ff7ea4ec44d6abec9cdde3ef169cfb.tar.gz
gamerlay-b59746c409ff7ea4ec44d6abec9cdde3ef169cfb.tar.bz2
gamerlay-b59746c409ff7ea4ec44d6abec9cdde3ef169cfb.zip
games-sports/stuntrally{,-tracks}: update packages
Migrate to cmake.eclass Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com>
-rw-r--r--games-sports/stuntrally-tracks/stuntrally-tracks-2.6.ebuild8
-rw-r--r--games-sports/stuntrally-tracks/stuntrally-tracks-9999.ebuild31
-rw-r--r--games-sports/stuntrally/stuntrally-2.6.ebuild25
-rw-r--r--games-sports/stuntrally/stuntrally-9999.ebuild63
4 files changed, 11 insertions, 116 deletions
diff --git a/games-sports/stuntrally-tracks/stuntrally-tracks-2.6.ebuild b/games-sports/stuntrally-tracks/stuntrally-tracks-2.6.ebuild
index fe2ff9d..690d5f2 100644
--- a/games-sports/stuntrally-tracks/stuntrally-tracks-2.6.ebuild
+++ b/games-sports/stuntrally-tracks/stuntrally-tracks-2.6.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
-inherit cmake-utils
+inherit cmake
DESCRIPTION="A set of tracks for ${CATEGORY}/${P//-tracks}"
HOMEPAGE="http://stuntrally.tuxfamily.org/"
@@ -21,9 +21,9 @@ src_configure() {
local mycmakeargs+=(
-DSHARE_INSTALL="/usr/share/stuntrally"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
}
diff --git a/games-sports/stuntrally-tracks/stuntrally-tracks-9999.ebuild b/games-sports/stuntrally-tracks/stuntrally-tracks-9999.ebuild
deleted file mode 100644
index 60248df..0000000
--- a/games-sports/stuntrally-tracks/stuntrally-tracks-9999.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils git-r3
-
-DESCRIPTION="A set of tracks for ${CATEGORY}/${P//-tracks}"
-HOMEPAGE="https://stuntrally.tuxfamily.org/"
-
-SLOT="0"
-LICENSE="GPL-3"
-IUSE=""
-
-SRC_URI=""
-KEYWORDS=""
-EGIT_REPO_URI="https://github.com/stuntrally/tracks"
-EGIT_PROJECT="${PN}"
-# Shallowing, since we don't want to fetch few GB of history
-#EGIT_OPTIONS="--depth 1"
-
-src_configure() {
- local mycmakeargs+=(
- -DSHARE_INSTALL="/usr/share/stuntrally"
- )
- cmake-utils_src_configure
-}
-
-src_install() {
- cmake-utils_src_install
-}
diff --git a/games-sports/stuntrally/stuntrally-2.6.ebuild b/games-sports/stuntrally/stuntrally-2.6.ebuild
index 73b57fb..b5fcc82 100644
--- a/games-sports/stuntrally/stuntrally-2.6.ebuild
+++ b/games-sports/stuntrally/stuntrally-2.6.ebuild
@@ -1,11 +1,9 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
-[[ ${PV} = 9999* ]] && GIT="git-r3"
-
-inherit cmake-utils ${GIT}
+inherit cmake
DESCRIPTION="Rally game focused on closed rally tracks with possible stunt elements."
HOMEPAGE="http://stuntrally.tuxfamily.org/"
@@ -13,16 +11,8 @@ HOMEPAGE="http://stuntrally.tuxfamily.org/"
SLOT="0"
LICENSE="GPL-3"
IUSE="dedicated +game editor"
-
-if [[ ${PV} = 9999* ]]; then
- SRC_URI=""
- KEYWORDS=""
- EGIT_REPO_URI="https://github.com/stuntrally/stuntrally"
- LIVE_PDEPEND="=${CATEGORY}/${PN}-tracks-${PV}"
-else
- KEYWORDS="~amd64 ~x86"
- SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tgz"
-fi
+KEYWORDS="~amd64 ~x86"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tgz"
DEPEND="
game? (
@@ -32,11 +22,10 @@ DEPEND="
media-libs/libvorbis
media-libs/libogg
media-libs/openal
- sci-physics/bullet[bullet3,extras]
+ sci-physics/bullet[extras]
)
dev-libs/boost
net-libs/enet:1.3
- virtual/libstdc++
"
RDEPEND="${DEPEND}
~games-sports/stuntrally-tracks-${PV}
@@ -59,9 +48,9 @@ src_configure() {
-DBUILD_SHARED_LIBS=OFF
-DSHARE_INSTALL="share/stuntrally"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
}
diff --git a/games-sports/stuntrally/stuntrally-9999.ebuild b/games-sports/stuntrally/stuntrally-9999.ebuild
deleted file mode 100644
index bbf601b..0000000
--- a/games-sports/stuntrally/stuntrally-9999.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-[[ ${PV} = 9999* ]] && GIT="git-r3"
-
-inherit ${GIT} cmake-utils
-
-DESCRIPTION="Rally game focused on closed rally tracks with possible stunt elements."
-HOMEPAGE="http://stuntrally.tuxfamily.org/"
-
-SLOT="0"
-LICENSE="GPL-3"
-IUSE="dedicated +game editor"
-
-if [[ ${PV} = 9999* ]]; then
- SRC_URI=""
- KEYWORDS=""
- EGIT_REPO_URI="https://github.com/stuntrally/stuntrally"
-# ^ dead
-# EGIT_REPO_URI="https://github.com/akien-mga/stuntrally"
-# EGIT_BRANCH="ogre-1.11"
-# ^ TODO (ogre-1.11 is hardmasked for now)
- LIVE_PDEPEND="~${CATEGORY}/${PN}-tracks-${PV}"
-else
- KEYWORDS="~amd64 ~x86"
- SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tgz"
-fi
-
-DEPEND="
- game? (
- dev-games/ogre[cg,boost,ois,freeimage,opengl,zip,-double-precision]
- dev-games/mygui[ogre,plugins]
- media-libs/libsdl2[haptic]
- media-libs/libvorbis
- media-libs/libogg
- media-libs/openal
- sci-physics/bullet[bullet3,extras]
- )
- dev-libs/boost
- net-libs/enet:1.3
- virtual/libstdc++
-"
-RDEPEND="${DEPEND}
- ~games-sports/stuntrally-tracks-${PV}
-"
-PDEPEND="${LIVE_PDEPEND}"
-
-REQUIRED_USE="editor? ( game )"
-
-DOCS=(Readme.txt)
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_MASTER_SERVER=$(usex dedicated)
- -DBUILD_GAME=$(usex game)
- -DBUILD_EDITOR=$(usex editor)
- -DBUILD_SHARED_LIBS=OFF
- -DSHARE_INSTALL="share/stuntrally"
- )
- cmake-utils_src_configure
-}