aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to '13.2.0/gentoo/81_all_match.pd-Use-splits-in-makefile-and-make-configurabl.patch')
-rw-r--r--13.2.0/gentoo/81_all_match.pd-Use-splits-in-makefile-and-make-configurabl.patch28
1 files changed, 14 insertions, 14 deletions
diff --git a/13.2.0/gentoo/81_all_match.pd-Use-splits-in-makefile-and-make-configurabl.patch b/13.2.0/gentoo/81_all_match.pd-Use-splits-in-makefile-and-make-configurabl.patch
index 4a8bc46..8834897 100644
--- a/13.2.0/gentoo/81_all_match.pd-Use-splits-in-makefile-and-make-configurabl.patch
+++ b/13.2.0/gentoo/81_all_match.pd-Use-splits-in-makefile-and-make-configurabl.patch
@@ -1,9 +1,9 @@
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=109927#c21
-From 3da0a672baeb52c5f7b736b47b2cc5f79ada86de Mon Sep 17 00:00:00 2001
+From 7ad6dc24f067e3ecf608143274c36b1eec51ba93 Mon Sep 17 00:00:00 2001
From: Tamar Christina <tamar.christina@arm.com>
Date: Fri, 5 May 2023 13:42:17 +0100
-Subject: [PATCH 6/6] match.pd: Use splits in makefile and make configurable.
+Subject: [PATCH 07/14] match.pd: Use splits in makefile and make configurable.
This updates the build system to split up match.pd files into chunks of 10.
This also introduces a new flag --with-matchpd-partitions which can be used to
@@ -31,7 +31,7 @@ gcc/ChangeLog:
3 files changed, 89 insertions(+), 22 deletions(-)
diff --git a/gcc/Makefile.in b/gcc/Makefile.in
-index f5f189916c1..8e22857ed57 100644
+index 406856acde1c..f0c34d00ecbc 100644
--- a/gcc/Makefile.in
+++ b/gcc/Makefile.in
@@ -214,6 +214,14 @@ rtl-ssa-warn = $(STRICT_WARN)
@@ -153,7 +153,7 @@ index f5f189916c1..8e22857ed57 100644
case-cfn-macros.h \
cfn-operators.pd omp-device-properties.h
diff --git a/gcc/configure b/gcc/configure
-index c7b26d1927d..843fd5449dd 100755
+index dec2eca1a453..2c124f1b0337 100755
--- a/gcc/configure
+++ b/gcc/configure
@@ -838,6 +838,7 @@ enable_gcov
@@ -172,7 +172,7 @@ index c7b26d1927d..843fd5449dd 100755
enable___cxa_atexit
enable_decimal_float
enable_fixed_point
-@@ -1826,6 +1828,9 @@ Optional Packages:
+@@ -1832,6 +1834,9 @@ Optional Packages:
--with-stack-clash-protection-guard-size=size
Set the default stack clash protection guard size
for specific targets as a power of two in bytes.
@@ -182,7 +182,7 @@ index c7b26d1927d..843fd5449dd 100755
--with-dwarf2 force the default debug format to be DWARF 2 (or
later)
--with-specs=SPECS add SPECS to driver command-line processing
-@@ -7889,6 +7894,26 @@ cat >>confdefs.h <<_ACEOF
+@@ -7895,6 +7900,26 @@ cat >>confdefs.h <<_ACEOF
_ACEOF
@@ -209,26 +209,26 @@ index c7b26d1927d..843fd5449dd 100755
# Enable __cxa_atexit for C++.
# Check whether --enable-__cxa_atexit was given.
if test "${enable___cxa_atexit+set}" = set; then :
-@@ -19825,7 +19850,7 @@ else
+@@ -19848,7 +19873,7 @@ else
lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
lt_status=$lt_dlunknown
cat > conftest.$ac_ext <<_LT_EOF
--#line 19828 "configure"
-+#line 19853 "configure"
+-#line 19851 "configure"
++#line 19876 "configure"
#include "confdefs.h"
#if HAVE_DLFCN_H
-@@ -19931,7 +19956,7 @@ else
+@@ -19954,7 +19979,7 @@ else
lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
lt_status=$lt_dlunknown
cat > conftest.$ac_ext <<_LT_EOF
--#line 19934 "configure"
-+#line 19959 "configure"
+-#line 19957 "configure"
++#line 19982 "configure"
#include "confdefs.h"
#if HAVE_DLFCN_H
diff --git a/gcc/configure.ac b/gcc/configure.ac
-index 09082e8ccae..de5e3aef2c8 100644
+index c0d067ec2716..526ce0665a3e 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
@@ -921,6 +921,21 @@ fi
@@ -254,5 +254,5 @@ index 09082e8ccae..de5e3aef2c8 100644
AC_ARG_ENABLE(__cxa_atexit,
[AS_HELP_STRING([--enable-__cxa_atexit], [enable __cxa_atexit for C++])],
--
-2.40.1
+2.43.0