aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-09-09 02:16:42 +0200
committerThomas Deutschmann <whissi@gentoo.org>2021-09-09 02:59:03 +0200
commit153a877d333d3b85920267535aef950056c92192 (patch)
tree49f00909f104fac428d1b69f4215bae7c55ab7b9 /patches
parentinitrd.scripts: don't skip top level devices with partitions (diff)
downloadgenkernel-153a877d333d3b85920267535aef950056c92192.tar.gz
genkernel-153a877d333d3b85920267535aef950056c92192.tar.bz2
genkernel-153a877d333d3b85920267535aef950056c92192.zip
Refactor (compressed) kernel module handling
To support a specific module compression algorithm, two things are needed: Used depmod utility on host system building the kernel must support chosen module compression algorithm to generate proper modules.dep file or genkernel would be unable to read module dependencies when copying modules to initramfs. At runtime, used modprobe utility must be able to handle chosen module compression algorithm or modules would be unloadable. To address the first requirement, genkernel will now check if used kmod utility on host system supports chosen module compression algorithm. To address the runtime requirement, this commit will switch from BusyBox's modutils implementation to kmod because BusyBox does not support ZSTD compression (yet). Bug: https://bugs.gentoo.org/809344 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'patches')
-rw-r--r--patches/kmod/29/kmod-29-static.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/patches/kmod/29/kmod-29-static.patch b/patches/kmod/29/kmod-29-static.patch
new file mode 100644
index 00000000..c29ab7f5
--- /dev/null
+++ b/patches/kmod/29/kmod-29-static.patch
@@ -0,0 +1,12 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -155,6 +155,8 @@ tools_kmod_SOURCES += \
+ tools/remove.c
+ endif
+
++tools_kmod_LDFLAGS = -all-static
++
+ tools_kmod_LDADD = \
+ shared/libshared.la \
+ libkmod/libkmod-internal.la
+