aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'hal-0.5.11-patches/0018-added-check-for-ConsoleKit-v0.3.1-to-configure.patch')
-rw-r--r--hal-0.5.11-patches/0018-added-check-for-ConsoleKit-v0.3.1-to-configure.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/hal-0.5.11-patches/0018-added-check-for-ConsoleKit-v0.3.1-to-configure.patch b/hal-0.5.11-patches/0018-added-check-for-ConsoleKit-v0.3.1-to-configure.patch
new file mode 100644
index 00000000..a79543b3
--- /dev/null
+++ b/hal-0.5.11-patches/0018-added-check-for-ConsoleKit-v0.3.1-to-configure.patch
@@ -0,0 +1,39 @@
+From 34b08efe694cd7c4125dc0254df89dd7ac3c5e77 Mon Sep 17 00:00:00 2001
+From: Danny Kukawka <danny.kukawka@web.de>
+Date: Mon, 25 Aug 2008 12:58:43 +0200
+Subject: [PATCH 18/48] added check for ConsoleKit >= v0.3.1 to configure
+
+Added check for ConsoleKit >= v0.3.1 to configure to be able
+to differ between the versions due to API breakage.
+---
+ configure.in | 14 ++++++++++++++
+ 1 files changed, 14 insertions(+), 0 deletions(-)
+
+diff --git a/configure.in b/configure.in
+index faa910b..112fc33 100644
+--- a/configure.in
++++ b/configure.in
+@@ -486,6 +486,20 @@ if test "x$enable_console_kit" != "xno"; then
+ AM_CONDITIONAL(HAVE_CONKIT, true)
+ AC_DEFINE(HAVE_CONKIT, [], [Set if we use ConsoleKit])
+ msg_conkit=yes
++ # yes this is ugly, but there is no other way to get the version of CK
++ AC_MSG_CHECKING([if ConsoleKit version 0.3.0 or newer])
++ if $PKG_CONFIG --atleast-version=0.3.0 ck-connector; then
++ AC_MSG_RESULT([yes])
++ AC_DEFINE(HAVE_CK_0_3, 1, [Define to 1 if ConsoleKit is v0.3.0 or newer])
++ else
++ if $PKG_CONFIG --max-version=0.2.10 ck-connector; then
++ AC_MSG_RESULT([no])
++ else
++ #assume we have the latest version
++ AC_MSG_WARN([Couldn't detect ConsoleKit version, install the devel package, assume for now you use >= 0.3.0])
++ AC_DEFINE(HAVE_CK_0_3, 1, [Define to 1 if ConsoleKit is v0.3.0 or newer])
++ fi
++ fi
+ fi
+
+ AC_PATH_PROG(GPERF, [gperf], [no])
+--
+1.6.1.2
+