aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.github/workflows/ci.yml2
-rw-r--r--meson.build8
2 files changed, 3 insertions, 7 deletions
diff --git a/.github/workflows/ci.yml b/.github/workflows/ci.yml
index bcb2d59..803dfde 100644
--- a/.github/workflows/ci.yml
+++ b/.github/workflows/ci.yml
@@ -33,7 +33,7 @@ jobs:
python -m site
python -m pip install --upgrade pip
# setuptools needed for 3.12+ because of https://github.com/mesonbuild/meson/issues/7702.
- python -m pip install meson ninja setuptools
+ python -m pip install meson ninja setuptools pytest
- name: Install portage
run: |
mkdir portage
diff --git a/meson.build b/meson.build
index c771738..c3e83c5 100644
--- a/meson.build
+++ b/meson.build
@@ -39,12 +39,8 @@ endif
subdir('bin')
subdir('pym')
-test(
- 'python-unittest',
- py,
- args : ['-m', 'unittest', 'discover', meson.current_source_dir() / 'pym'],
- timeout : 0
-)
+pytest = find_program('pytest')
+test('pytest', pytest, args : ['-v', meson.current_source_dir() / 'pym'])
if get_option('code-only')
subdir_done()