summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/hal-info/hal-info-20071212.ebuild')
-rw-r--r--app-misc/hal-info/hal-info-20071212.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-misc/hal-info/hal-info-20071212.ebuild b/app-misc/hal-info/hal-info-20071212.ebuild
new file mode 100644
index 0000000..2d97fa1
--- /dev/null
+++ b/app-misc/hal-info/hal-info-20071212.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/hal-info/hal-info-20070618.ebuild,v 1.11 2007/08/28 19:38:43 jer Exp $
+
+inherit eutils
+
+DESCRIPTION="The fdi scripts that HAL uses"
+HOMEPAGE="http://hal.freedesktop.org/"
+SRC_URI="http://hal.freedesktop.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=sys-apps/hal-0.5.10"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+
+ epatch "${FILESDIR}/01_dell_cdrom_nopoll.patch"
+ #epatch "${FILESDIR}/02_hardware_brightness_fixups.patch"
+ #epatch "${FILESDIR}/03_feiya_memory_bar.patch"
+}
+
+src_compile() {
+ econf || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed."
+}