summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/glib/glib-2.9999.ebuild')
-rw-r--r--dev-libs/glib/glib-2.9999.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/dev-libs/glib/glib-2.9999.ebuild b/dev-libs/glib/glib-2.9999.ebuild
index 44c70d4..de3e87d 100644
--- a/dev-libs/glib/glib-2.9999.ebuild
+++ b/dev-libs/glib/glib-2.9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.20.2.ebuild,v 1.2 2009/05/18 21:37:06 eva Exp $
EAPI="2"
-inherit libtool eutils flag-o-matic gnome2-live
+inherit gnome.org libtool eutils flag-o-matic gnome2-live
DESCRIPTION="The GLib library of C routines"
HOMEPAGE="http://www.gtk.org/"
@@ -15,8 +15,7 @@ SLOT="2"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
IUSE="debug doc fam hardened selinux xattr"
-RDEPEND="virtual/libc
- virtual/libiconv
+RDEPEND="virtual/libiconv
xattr? ( sys-apps/attr )
fam? ( virtual/fam )"
DEPEND="${RDEPEND}
@@ -84,10 +83,13 @@ src_install() {
# Do not install charset.alias even if generated, leave it to libiconv
rm -f "${D}/usr/lib/charset.alias"
- dodoc AUTHORS ChangeLog* NEWS* README || die "dodoc failed"
+ dodoc AUTHORS ChangeLog* NEWS* || die "dodoc failed"
}
src_test() {
unset DBUS_SESSION_BUS_ADDRESS
+ export XDG_CONFIG_DIRS=/etc/xdg
+ export XDG_DATA_DIRS=/usr/local/share:/usr/share
+ export XDG_DATA_HOME="${T}"
emake check || die "tests failed"
}