summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/vte/vte-0.14.0.ebuild')
-rw-r--r--x11-libs/vte/vte-0.14.0.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/x11-libs/vte/vte-0.14.0.ebuild b/x11-libs/vte/vte-0.14.0.ebuild
new file mode 100644
index 0000000..6184a1b
--- /dev/null
+++ b/x11-libs/vte/vte-0.14.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/vte-0.14.0.ebuild,v 1.1 2006/09/07 04:15:07 dang Exp $
+
+inherit eutils gnome2 autotools
+
+DESCRIPTION="Xft powered terminal widget"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug doc python opengl"
+
+RDEPEND=">=dev-libs/glib-2.9
+ >=x11-libs/gtk+-2.6
+ >=x11-libs/pango-1.1
+ >=media-libs/freetype-2.0.2
+ media-libs/fontconfig
+ sys-libs/ncurses
+ python? (
+ >=dev-python/pygtk-2.4
+ >=dev-lang/python-2.2
+ )
+ opengl? (
+ virtual/opengl
+ virtual/glu
+ )
+ || ( x11-libs/libX11 virtual/x11 )
+ virtual/xft"
+
+DEPEND="${RDEPEND}
+ doc? ( >=dev-util/gtk-doc-1.0 )
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.9
+ sys-devel/gettext"
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README"
+
+pkg_setup() {
+ G2CONF="$(use_enable debug debugging) $(use_enable python) \
+ $(use_with opengl glX) --with-xft2 --with-pangox"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # Don't have a cursor blinking timeout when blinking is disabled or when the window does not have focus.
+ # That is, don't poll when we don't need to.
+ epatch "${FILESDIR}/vte-cursor-blink.patch"
+
+ epatch ${FILESDIR}/${PN}-0.13.2-no-lazy-bindings.patch
+
+ cd ${S}/gnome-pty-helper
+ eautomake
+}