summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-libs/cogl/Manifest3
-rw-r--r--media-libs/cogl/cogl-1.7.0.ebuild69
-rw-r--r--media-libs/cogl/cogl-9999.ebuild69
-rw-r--r--profiles/package.mask1
4 files changed, 142 insertions, 0 deletions
diff --git a/media-libs/cogl/Manifest b/media-libs/cogl/Manifest
new file mode 100644
index 00000000..53dbfe47
--- /dev/null
+++ b/media-libs/cogl/Manifest
@@ -0,0 +1,3 @@
+DIST cogl-1.7.0.tar.xz 1911024 RMD160 a471d40cee36b8902a3aead7f73efd97bf9ac211 SHA1 9f6d4aa4d75e1503100fbc3116d31a59ff6dd9bb SHA256 d4bc74a1639ab6c377f04b0964f90b061407f9b97ba87ec16675347cd7c3f67d
+EBUILD cogl-1.7.0.ebuild 1682 RMD160 d8f9de732131179be669445c2aad21961f7b28c0 SHA1 b85b5803ebd8cc33b8a50f8b1821719571f69118 SHA256 eb49d4fb9169bdfcdb4d88a3283ee48f38178462c5141392ce940c127181fc6f
+EBUILD cogl-9999.ebuild 1682 RMD160 d8f9de732131179be669445c2aad21961f7b28c0 SHA1 b85b5803ebd8cc33b8a50f8b1821719571f69118 SHA256 eb49d4fb9169bdfcdb4d88a3283ee48f38178462c5141392ce940c127181fc6f
diff --git a/media-libs/cogl/cogl-1.7.0.ebuild b/media-libs/cogl/cogl-1.7.0.ebuild
new file mode 100644
index 00000000..f98cfb72
--- /dev/null
+++ b/media-libs/cogl/cogl-1.7.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="4"
+CLUTTER_LA_PUNT="yes"
+
+# Inherit gnome2 after clutter to download sources from gnome.org
+# since clutter-project.org doesn't provide .xz tarballs
+inherit clutter gnome2
+if [[ ${PV} = 9999 ]]; then
+ inherit gnome2-live
+fi
+
+DESCRIPTION="A library for using 3D graphics hardware to draw pretty pictures"
+HOMEPAGE="http://www.clutter-project.org/"
+
+LICENSE="LGPL-2.1"
+SLOT="1.0"
+IUSE="doc examples +introspection +pango"
+if [[ ${PV} = 9999 ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64 ~x86"
+fi
+
+# XXX: need uprof for optional profiling support
+COMMON_DEPEND=">=dev-libs/glib-2.26.0:2
+ x11-libs/cairo
+ >=x11-libs/gdk-pixbuf-2:2
+ x11-libs/libdrm
+ x11-libs/libX11
+ >=x11-libs/libXcomposite-0.4
+ x11-libs/libXdamage
+ x11-libs/libXext
+ >=x11-libs/libXfixes-3
+ virtual/opengl
+
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
+ pango? ( >=x11-libs/pango-1.20.0[introspection?] )"
+# before clutter-1.7, cogl was part of clutter
+RDEPEND="${COMMON_DEPEND}
+ !!<media-libs/clutter-1.7"
+DEPEND="${COMMON_DEPEND}
+ dev-util/pkgconfig
+ sys-devel/gettext
+ doc? ( app-text/docbook-xml-dtd:4.1.2
+ >=dev-util/gtk-doc-1.13 )"
+
+pkg_setup() {
+ DOCS="NEWS README"
+ EXAMPLES="examples/*.c"
+ # XXX: think about gles, quartz, wayland
+ # --with-pic needed due to https://bugzilla.gnome.org/show_bug.cgi?id=653615
+ G2CONF="${G2CONF}
+ --with-pic=both
+ --disable-profile
+ --disable-maintainer-flags
+ --enable-cairo
+ --enable-gdk-pixbuf
+ --enable-gl
+ --enable-glx
+ $(use_enable introspection)
+ $(use_enable pango cogl-pango)"
+}
+
+src_install() {
+ clutter_src_install
+}
diff --git a/media-libs/cogl/cogl-9999.ebuild b/media-libs/cogl/cogl-9999.ebuild
new file mode 100644
index 00000000..f98cfb72
--- /dev/null
+++ b/media-libs/cogl/cogl-9999.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="4"
+CLUTTER_LA_PUNT="yes"
+
+# Inherit gnome2 after clutter to download sources from gnome.org
+# since clutter-project.org doesn't provide .xz tarballs
+inherit clutter gnome2
+if [[ ${PV} = 9999 ]]; then
+ inherit gnome2-live
+fi
+
+DESCRIPTION="A library for using 3D graphics hardware to draw pretty pictures"
+HOMEPAGE="http://www.clutter-project.org/"
+
+LICENSE="LGPL-2.1"
+SLOT="1.0"
+IUSE="doc examples +introspection +pango"
+if [[ ${PV} = 9999 ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64 ~x86"
+fi
+
+# XXX: need uprof for optional profiling support
+COMMON_DEPEND=">=dev-libs/glib-2.26.0:2
+ x11-libs/cairo
+ >=x11-libs/gdk-pixbuf-2:2
+ x11-libs/libdrm
+ x11-libs/libX11
+ >=x11-libs/libXcomposite-0.4
+ x11-libs/libXdamage
+ x11-libs/libXext
+ >=x11-libs/libXfixes-3
+ virtual/opengl
+
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
+ pango? ( >=x11-libs/pango-1.20.0[introspection?] )"
+# before clutter-1.7, cogl was part of clutter
+RDEPEND="${COMMON_DEPEND}
+ !!<media-libs/clutter-1.7"
+DEPEND="${COMMON_DEPEND}
+ dev-util/pkgconfig
+ sys-devel/gettext
+ doc? ( app-text/docbook-xml-dtd:4.1.2
+ >=dev-util/gtk-doc-1.13 )"
+
+pkg_setup() {
+ DOCS="NEWS README"
+ EXAMPLES="examples/*.c"
+ # XXX: think about gles, quartz, wayland
+ # --with-pic needed due to https://bugzilla.gnome.org/show_bug.cgi?id=653615
+ G2CONF="${G2CONF}
+ --with-pic=both
+ --disable-profile
+ --disable-maintainer-flags
+ --enable-cairo
+ --enable-gdk-pixbuf
+ --enable-gl
+ --enable-glx
+ $(use_enable introspection)
+ $(use_enable pango cogl-pango)"
+}
+
+src_install() {
+ clutter_src_install
+}
diff --git a/profiles/package.mask b/profiles/package.mask
index 30c1f3c1..f47fb3f5 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -11,6 +11,7 @@
# Warning: these are not supported in any way whatsoever
=dev-libs/glib-2.29*
=dev-libs/gobject-introspection-1*
+=media-libs/cogl-1.7*
=x11-libs/gtk+-3.1*
=x11-libs/pango-1.29*