summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/baobab/baobab-9999.ebuild')
-rw-r--r--sys-apps/baobab/baobab-9999.ebuild61
1 files changed, 0 insertions, 61 deletions
diff --git a/sys-apps/baobab/baobab-9999.ebuild b/sys-apps/baobab/baobab-9999.ebuild
deleted file mode 100644
index c4b7af88..00000000
--- a/sys-apps/baobab/baobab-9999.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit gnome2
-if [[ ${PV} = 9999 ]]; then
- VALA_MIN_API_VERSION="0.38"
- VALA_USE_DEPEND="vapigen"
- inherit gnome2-live vala
-fi
-
-DESCRIPTION="Disk usage browser for GNOME"
-HOMEPAGE="https://wiki.gnome.org/Apps/Baobab"
-
-LICENSE="GPL-2+ FDL-1.1+"
-SLOT="0"
-IUSE=""
-if [[ ${PV} = 9999 ]]; then
- KEYWORDS=""
-else
- KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
-fi
-
-COMMON_DEPEND="
- >=dev-libs/glib-2.40:2[dbus]
- >=x11-libs/gtk+-3.19.1:3
-"
-RDEPEND="${COMMON_DEPEND}
- gnome-base/gsettings-desktop-schemas
- x11-themes/adwaita-icon-theme
- !<gnome-extra/gnome-utils-3.4
-"
-# ${PN} was part of gnome-utils before 3.4
-DEPEND="${COMMON_DEPEND}
- app-text/yelp-tools
- dev-libs/appstream-glib
- dev-libs/libxml2:2
- >=sys-devel/gettext-0.19.8
- virtual/pkgconfig
-"
-
-if [[ ${PV} = 9999 ]]; then
- DEPEND="${DEPEND}
- $(vala_depend)"
-fi
-
-src_prepare() {
- if [[ ${PV} = 9999 ]]; then
- vala_src_prepare
- fi
-}
-
-src_configure() {
- local myconf=""
- if [[ ${PV} != 9999 ]]; then
- myconf="${myconf}
- VALAC=$(type -P true)
- VAPIGEN=$(type -P true)"
- fi
- gnome2_src_configure ${myconf}
-}