summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2008-08-13 08:42:53 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2008-08-13 08:42:53 +0000
commiteb9340cb8c87d49f47e53367821341e3878ab31c (patch)
tree6fe8bd834df1e5e0994c264cd9dcc006adfda3c9 /gnustep-apps
parentWhat do you know, it works! (diff)
downloadgnustep-eb9340cb8c87d49f47e53367821341e3878ab31c.tar.gz
gnustep-eb9340cb8c87d49f47e53367821341e3878ab31c.tar.bz2
gnustep-eb9340cb8c87d49f47e53367821341e3878ab31c.zip
Bump sogo to new RC (not tested)
svn path=/overlay/; revision=373
Diffstat (limited to 'gnustep-apps')
-rw-r--r--gnustep-apps/sogo/Manifest2
-rw-r--r--gnustep-apps/sogo/sogo-1.0_rc7.ebuild113
2 files changed, 115 insertions, 0 deletions
diff --git a/gnustep-apps/sogo/Manifest b/gnustep-apps/sogo/Manifest
index 44fc4b5..0bafdce 100644
--- a/gnustep-apps/sogo/Manifest
+++ b/gnustep-apps/sogo/Manifest
@@ -1,4 +1,6 @@
AUX sogo-foundation_include.patch 296 RMD160 c12185f556ccb3e3c922a9ffe7f1c4f72337aea6 SHA1 3eaabf94cbce392e81a81b74f55b2256712ce168 SHA256 5d230c040c5919acf29c4ddc45306dc38344048eae0fce0580140880a6c6537f
AUX sogo.initd 472 RMD160 eb2ff469c8ad9795c2ff7f7b53f95d3c7e5a1303 SHA1 67e9a508b08cb2205ddff4044b35f378dc4c8e07 SHA256 eaa3a6c0e2729291ecf6fd1492fc7d33a0494bd920e63a78e1e1997c9314e31f
DIST SOGo-1.0rc6.1.tar.gz 1304442 RMD160 07cbec5672670ff6355687565470bb4265ba7d36 SHA1 81954756dc641c1d9fee23be312f150dea7a5661 SHA256 80477c1949965fbc30a3d01f72b6aa701d7e1b9e8739d529f39c80edcb56a4e6
+DIST SOGo-1.0rc7.tar.gz 1343834 RMD160 072817988a6061907b424974590f2906a7631583 SHA1 b8ca18de33a958f3c1f78df554d3fe268a2dec86 SHA256 fa47406e410571ff842e0137caf90bb863a07c122b967759fd85665e2a0a3722
EBUILD sogo-1.0_rc6.ebuild 2821 RMD160 d25b408ec4bfd7b5df7a82f467095bf95f1decb6 SHA1 5ad089af3fc8ca3b9a8741629361eee24260b69b SHA256 00c31e5bd13d27da59c6e89f8a5ac0ab9c56a60c18faf3ee4ccfd63c015c22c6
+EBUILD sogo-1.0_rc7.ebuild 2819 RMD160 7569ac90ca0df003ec4dc53cea27cee5e8438119 SHA1 5b61c7549cf79d2ccc702a289ec987f6facc720d SHA256 69cc2c666d6bac8904120a04cee02119ccb8f40eb29c1b298c2faaa7aa6131d0
diff --git a/gnustep-apps/sogo/sogo-1.0_rc7.ebuild b/gnustep-apps/sogo/sogo-1.0_rc7.ebuild
new file mode 100644
index 0000000..d63ce57
--- /dev/null
+++ b/gnustep-apps/sogo/sogo-1.0_rc7.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit depend.apache gnustep-base
+
+MY_PN="SOGo"
+MY_PV="${PV/_/}"
+
+DESCRIPTION="groupware server built around OpenGroupware.org and the SOPE application server"
+HOMEPAGE="http://sogo.opengroupware.org/"
+SRC_URI="http://www.inverse.ca/downloads/${MY_PN}/Sources/${MY_PN}-${MY_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="gnustep-libs/sope"
+RDEPEND="${DEPEND}
+ dev-db/postgresql"
+need_apache2
+
+S=${WORKDIR}/${MY_PN}
+
+pkg_setup() {
+ gnustep-base_pkg_setup
+
+ if ! built_with_use gnustep-libs/sope postgres; then
+ eerror "SOGo needs gnustep-libs/sope with USE=postgres enabled"
+ die "gnustep-libs/sope compiled without USE=postgres"
+ fi
+}
+
+
+src_unpack() {
+ gnustep-base_src_unpack
+
+ # Fix for missing include
+ epatch "${FILESDIR}"/${PN}-foundation_include.patch
+}
+
+
+src_compile() {
+ # Do not use standard src_compile, as ./configure is not standard
+ egnustep_env
+ ./configure
+ egnustep_make
+}
+
+src_install() {
+ gnustep-base_src_install
+
+ # Apache configuration file
+ dodir "${APACHE_MODULES_CONFDIR}"
+ cat <<EOF >"${D}/${APACHE_MODULES_CONFDIR}"/47_sogo.conf
+<IfDefine SOPE>
+LoadModule ngobjweb_module modules/mod_ngobjweb.so
+
+Alias /sogo.woa/WebServerResources/ \
+ ${GNUSTEP_SYSTEM_LIBRARY}/SOGo-0.9/WebServerResources/
+Alias /SOGo.woa/WebServerResources/ \
+ ${GNUSTEP_SYSTEM_LIBRARY}/SOGo-0.9/WebServerResources/
+
+AliasMatch /SOGo/so/ControlPanel/Products/(.*)/Resources/(.*) \
+ ${GNUSTEP_SYSTEM_LIBRARY}/SOGo-0.9/\$1.SOGo/Resources/\$2
+
+<LocationMatch "^/SOGo*">
+ AddDefaultCharset UTF-8
+ SetHandler ngobjweb-adaptor
+ SetAppPort 20000
+ Allow from 127.0.0.1
+</LocationMatch>
+
+<LocationMatch "^/SOGo/so/ControlPanel/Products/.*UI/Resources/.*png">
+ SetHandler default-handler
+</LocationMatch>
+
+<LocationMatch "^/SOGo/so/ControlPanel/Products/.*UI/Resources/.*gif">
+ SetHandler default-handler
+</LocationMatch>
+
+<LocationMatch "^/SOGo/so/ControlPanel/Products/.*UI/Resources/.*css">
+ SetHandler default-handler
+</LocationMatch>
+
+<LocationMatch "^/SOGo/so/ControlPanel/Products/.*UI/Resources/.*js">
+ SetHandler default-handler
+</LocationMatch>
+
+</IfDefine>
+EOF
+
+ # Init script
+ newinitd "${FILESDIR}"/sogo.initd sogo \
+ || die "Init script installation failed"
+}
+
+pkg_preinst() {
+ enewuser sogo -1 /bin/bash /var/lib/sogo
+}
+
+pkg_postinst() {
+ gnustep-base_pkg_postinst
+
+ elog "Do not forget to enable the sope module in /etc/apache2/httpd.conf"
+ elog "Now follow the steps from the SOGo documentation:"
+ elog "http://www.inverse.ca/contributions/sogo/documentation.html#c803"
+ elog "The default port configured for sogo is 20000 (from 47_sogo.conf)"
+ elog "The sogo user home directory is /var/lib/sogo"
+ elog ""
+ elog "Then you can start/stop sogo with /etc/init.d/sogo"
+}