aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPriit Laes <plaes@plaes.org>2010-07-03 10:49:28 +0300
committerPriit Laes <plaes@plaes.org>2010-07-04 08:17:09 +0300
commit98781186e9cbef49df6cca0adbc0e827324fc03c (patch)
tree5b423c74adf03fa6aaf7ca4dbd32c93a0a99f359 /setup.py
parentRemove now obsolete schema description document (diff)
downloadgsoc2010-grumpy-98781186e9cbef49df6cca0adbc0e827324fc03c.tar.gz
gsoc2010-grumpy-98781186e9cbef49df6cca0adbc0e827324fc03c.tar.bz2
gsoc2010-grumpy-98781186e9cbef49df6cca0adbc0e827324fc03c.zip
Added setup.py
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py40
1 files changed, 40 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..802d015
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,40 @@
+"""
+Project Grumpy
+--------------
+
+Project Grumpy is a an application and a set of utilities aimed to improve
+life for Gentoo developers.
+
+"""
+from setuptools import setup
+
+setup(
+ name='Grumpy',
+ version='0.0',
+ url='http://git.overlays.gentoo.org/gitweb/?p=proj/grumpy.git;a=summary',
+ license='BSD',
+ author='Priit Laes',
+ author_email='plaes@plaes.org',
+ description='Set of QA helpers for Gentoo Developers',
+ long_description=__doc__,
+ packages=['grumpy'],
+ zip_safe=False,
+ platforms='any',
+ install_requires=[
+ 'pkgcore',
+ 'snakeoil',
+ 'SQLAlchemy >= 0.6',
+ ],
+ classifiers=[
+ 'Development Status :: 1 - Planning',
+ 'Environment :: Other Environment',
+ 'Environment :: Web Environment',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: BSD License',
+ 'Operating System :: OS Independent',
+ 'Programming Language :: Python',
+ 'Topic :: Software Development :: Quality Assurance',
+ 'Topic :: Utilities'
+ ]
+)
+