aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris PeBenito <pebenito@ieee.org>2020-03-19 13:48:34 -0400
committerJason Zaman <perfinion@gentoo.org>2020-08-09 19:58:43 -0700
commit0933d5d1e48ef2e836a65159afd791231bebe2cd (patch)
treee394b9d9d8efd21ea8e76cdbd6237b9214864f4b /Makefile
parentuserdomain: add watch perms (diff)
downloadhardened-refpolicy-0933d5d1e48ef2e836a65159afd791231bebe2cd.tar.gz
hardened-refpolicy-0933d5d1e48ef2e836a65159afd791231bebe2cd.tar.bz2
hardened-refpolicy-0933d5d1e48ef2e836a65159afd791231bebe2cd.zip
Makefile: Warn if policy.xml xmllint check does not run.
Signed-off-by: Chris PeBenito <pebenito@ieee.org> Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 3f586465..2c18cbeb 100644
--- a/Makefile
+++ b/Makefile
@@ -444,6 +444,8 @@ $(polxml): $(layerxml) $(tunxml) $(boolxml) $(gentooxml)
$(verbose) echo '</policy>' >> $@
$(verbose) if test -x $(XMLLINT) && test -f $(xmldtd); then \
$(XMLLINT) --noout --path $(dir $(xmldtd)) --dtdvalid $(xmldtd) $@ ;\
+ else \
+ echo "$@ XML validation not run. Please install the xmllint tool." ;\
fi
xml: $(polxml)