aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris PeBenito <pebenito@ieee.org>2020-04-01 15:00:02 -0400
committerJason Zaman <perfinion@gentoo.org>2020-08-09 19:58:43 -0700
commit5f7c8f7dd9922442ef5062cd6a0a899b127016a1 (patch)
tree5fdd5cb8ace2c351cfabaa324901da88492934cf /Makefile
parentcorecommands, init, lvm, systemd: Module version bump. (diff)
downloadhardened-refpolicy-5f7c8f7dd9922442ef5062cd6a0a899b127016a1.tar.gz
hardened-refpolicy-5f7c8f7dd9922442ef5062cd6a0a899b127016a1.tar.bz2
hardened-refpolicy-5f7c8f7dd9922442ef5062cd6a0a899b127016a1.zip
Makefile: Remove shell brace expansion in ctags target.
This doesn't work on dash, the default shell on Debian. Closes #110 Signed-off-by: Chris PeBenito <pebenito@ieee.org> Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 2c18cbeb..e4d79b6c 100644
--- a/Makefile
+++ b/Makefile
@@ -575,7 +575,7 @@ install-src:
#
# Generate tags file
#
-tags: $(tags)
+ctags: $(tags)
$(tags):
@($(CTAGS) --version | grep -q Exuberant) || (echo ERROR: Need exuberant-ctags to function!; exit 1)
@LC_ALL=C $(CTAGS) -f $(tags) --langdef=te --langmap=te:..te.if.spt \
@@ -585,7 +585,8 @@ $(tags):
--regex-te='/^[ \t]*define\(`(\w+)/\1/d,define/' \
--regex-te='/^[ \t]*interface\(`(\w+)/\1/i,interface/' \
--regex-te='/^[ \t]*template\(`(\w+)/\1/i,template/' \
- --regex-te='/^[ \t]*bool[ \t]+(\w+)/\1/b,bool/' policy/modules/*/*.{if,te} policy/support/*.spt
+ --regex-te='/^[ \t]*bool[ \t]+(\w+)/\1/b,bool/' \
+ policy/modules/*/*.if policy/modules/*/*.te policy/support/*.spt
########################################
#