summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEudyptula <eitan@mosenkis.net>2009-08-13 18:54:15 -0400
committerEudyptula <eitan@mosenkis.net>2009-08-13 18:54:15 -0400
commit9e9db3358d449b2aec9b7c0b6828d8d1ea01f4d0 (patch)
treebb1d39bab42da73f165b5d9a41a6226b9aa59365
parentWrote a script for automatically keeping cache files (stage3, install ISO, et... (diff)
downloadingenue-9e9db3358d449b2aec9b7c0b6828d8d1ea01f4d0.tar.gz
ingenue-9e9db3358d449b2aec9b7c0b6828d8d1ea01f4d0.tar.bz2
ingenue-9e9db3358d449b2aec9b7c0b6828d8d1ea01f4d0.zip
Added ebuild; added ntpd to init deps; builds show [failed] in frontend when they've failed
-rw-r--r--ingenue-9999.ebuild44
-rwxr-xr-xinit_script2
-rw-r--r--shared/classes/build.php2
-rw-r--r--todo2
4 files changed, 47 insertions, 3 deletions
diff --git a/ingenue-9999.ebuild b/ingenue-9999.ebuild
new file mode 100644
index 0000000..1fd3187
--- /dev/null
+++ b/ingenue-9999.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit git
+
+DESCRIPTION="Web-based linux image builder"
+HOMEPAGE=""
+SRC_URI=""
+EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/ingenue"
+WEBAPP_OPTIONAL="yes"
+
+EAPI="2"
+LICENSE=""
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=dev-lang/php-5.2.2[pdo,hash,pcntl,pcre,cli,mysql,apache2,curl,ctype,reflection,posix,ftp]
+ virtual/mysql
+ sys-apps/sed
+ >=sys-fs/squashfs-tools-4
+ sys-fs/mtd-utils
+ net-misc/ntp"
+
+src_unpack() {
+ git_src_unpack
+}
+
+src_compile() {
+ cd lib
+ emake
+}
+
+src_install() {
+ insinto /usr/share/ingenue
+ doins -r shared frontend backend cache work completed
+ exeinto /usr/share/ingenue
+ doexe *.php
+ exeinto /usr/share/ingenue/lib
+ doexe lib/bkisofs-cli
+ newinitd init_script ingenue
+}
diff --git a/init_script b/init_script
index 486c0d8..8069ef2 100755
--- a/init_script
+++ b/init_script
@@ -3,7 +3,7 @@
INGENUE_PATH="/home/eitan/soc/git"
depend() {
- need mysql
+ need mysql ntpd
}
start() {
diff --git a/shared/classes/build.php b/shared/classes/build.php
index 3c65f9b..45d8f07 100644
--- a/shared/classes/build.php
+++ b/shared/classes/build.php
@@ -77,6 +77,8 @@ class sql_build extends conf_build_common {
$format='D j M Y G:i:s T';
$perms=$this->visibility == 'public' || owner_or_admin($this->id);
$html='<div class="build"><span class="name">'.(isset($this->name) && strlen($this->name)?htmlentities($this->name):'Unnamed Build').'</span> ';
+ if ($this->failed == 'true')
+ $html.='<span class="status failed">[failed]</span> ';
$links=array();
switch ($this->status) {
case 'queued':
diff --git a/todo b/todo
index 9d17f1e..4a5b770 100644
--- a/todo
+++ b/todo
@@ -1,4 +1,3 @@
-Write a live git ebuild
Add a profiles management page/backend utility
Add cleanup functions to the frontend and backend (tasks dir in backend containing scripts that can be launched through frontend)
*** Move bundler selection out of gentoo module ***
@@ -19,5 +18,4 @@ Offer SCP upload?
Ask someone to add the necessary USE flags to php on tinderbox
Add rollback to backend so it can resume after a partial task
Offer option in frontend to submit a failed build for resume
-Change builds->display() to handle `failed` column
Find out what on earth is wrong with error reporting in the frontend