aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2021-06-30 11:34:19 +0200
committerFlorian Schmaus <flow@gentoo.org>2021-06-30 11:35:20 +0200
commit761e1e9fb3a5ff5d6b8105a36032383b9ef20c51 (patch)
tree5c698ea642f4c6c556d600250b747573f9a34525
parentdev-java/uuid: treeclean (diff)
downloadjava-761e1e9fb3a5ff5d6b8105a36032383b9ef20c51.tar.gz
java-761e1e9fb3a5ff5d6b8105a36032383b9ef20c51.tar.bz2
java-761e1e9fb3a5ff5d6b8105a36032383b9ef20c51.zip
dev-java/liquidlnf: treeclean
Reason: failed sourcing ebuild: java-pkg-2: EAPI 0 not supported, (java-pkg-2.eclass, line 17: called die) Bug: https://bugs.gentoo.org/759889 Signed-off-by: Florian Schmaus <flow@gentoo.org>
-rw-r--r--dev-java/liquidlnf/Manifest1
-rw-r--r--dev-java/liquidlnf/files/0.2.9/patch-to-rm-bootclasspath.patch60
-rw-r--r--dev-java/liquidlnf/liquidlnf-0.2.9.ebuild42
-rw-r--r--dev-java/liquidlnf/metadata.xml8
4 files changed, 0 insertions, 111 deletions
diff --git a/dev-java/liquidlnf/Manifest b/dev-java/liquidlnf/Manifest
deleted file mode 100644
index 2e4b1009..00000000
--- a/dev-java/liquidlnf/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST liquidlnf-0.2.9-src.tar.bz2 626671 SHA256 c09dcc4eaa0575b938da737b24f786ca44cc30151ee39ead2184c4f6c8578433
diff --git a/dev-java/liquidlnf/files/0.2.9/patch-to-rm-bootclasspath.patch b/dev-java/liquidlnf/files/0.2.9/patch-to-rm-bootclasspath.patch
deleted file mode 100644
index 69d2ff8b..00000000
--- a/dev-java/liquidlnf/files/0.2.9/patch-to-rm-bootclasspath.patch
+++ /dev/null
@@ -1,60 +0,0 @@
-diff -Naur liquidlnf/build.xml liquidlnf-new/build.xml
---- liquidlnf/build.xml 2006-09-12 16:34:50.000000000 +1200
-+++ liquidlnf-new/build.xml 2006-09-26 07:51:58.000000000 +1200
-@@ -16,6 +16,7 @@
- <property name="project.bin.test" value="bin/test"/>
- <property name="project.bin" value="dist/bin"/>
- <property name="project.lib" value="./lib"/>
-+ <property name="project.test" value="false" />
-
- <target name="run-check" depends="compile-test">
- <java classname="test.Check" fork="true">
-@@ -57,14 +58,14 @@
- </target>
-
- <target depends="compile" name="compile-test">
-- <javac classpath="${project.lib}/laf-plugin.jar" bootclasspath="${compile.bootclasspath}" debug="true" deprecation="false" target="${compile.target}" source="${compile.source}" description="Project compilation." destdir="${project.classes}" srcdir="${project.test}"/>
-+ <javac classpath="${project.lib}/laf-plugin.jar" debug="true" deprecation="false" description="Project compilation." destdir="${project.classes}" srcdir="${project.test}"/>
- <copy todir="${project.classes}">
- <fileset dir="${project.test}" excludes="**/*.java,**/*.form,**/.nbattrs"/>
- </copy>
- </target>
-
- <target depends="init" name="compile">
-- <javac classpath="${project.lib}/laf-plugin.jar" bootclasspath="${compile.bootclasspath}" debug="${compile.debug}" deprecation="false" target="${compile.target}" source="${compile.source}" description="Project compilation." destdir="${project.classes}" srcdir="${project.src}" />
-+ <javac classpath="${project.lib}/laf-plugin.jar" debug="${compile.debug}" deprecation="false" description="Project compilation." destdir="${project.classes}" srcdir="${project.src}" />
- <copy todir="${project.classes}">
- <fileset dir="${project.src}" excludes="**/*.java,**/*.form,**/.nbattrs"/>
- </copy>
-@@ -72,7 +73,7 @@
-
- <target depends="init,compile" description="Make jar file" name="jar">
- <mkdir dir="${project.dist}"/>
-- <unjar src="${project.lib}/laf-plugin.jar" dest="${project.classes}/"/>
-+ <!--<unjar src="${project.lib}/laf-plugin.jar" dest="${project.classes}/"/>-->
- <jar basedir="${project.classes}" compress="true" jarfile="${project.dist}/${jar.name}">
- <exclude name="**/*.java"/>
- <exclude name="**/*.form"/>
-@@ -92,18 +93,18 @@
- </jar>
- </target>
-
-- <target depends="jar" description="Install jar file" name="install">
-+ <!--<target depends="jar" description="Install jar file" name="install">
- <copy file="${project.dist}/${jar.name}" todir="${java.home}/lib/ext"/>
-- </target>
-+ </target>-->
-
-- <target depends="install" description="Colour test" name="colour">
-+ <!--<target depends="install" description="Colour test" name="colour">
- <java classname="com.birosoft.liquid.util.Colors" fork="yes">
- <classpath>
- <pathelement path="${project.classes}"/>
- <pathelement path="${basedir}"/>
- </classpath>
- </java>
-- </target>
-+ </target>-->
-
- <target depends="clean" description="Create src.jar file" name="src.dist">
- <tar basedir="." tarfile="${project.name}-${project.version}-src.tar">
diff --git a/dev-java/liquidlnf/liquidlnf-0.2.9.ebuild b/dev-java/liquidlnf/liquidlnf-0.2.9.ebuild
deleted file mode 100644
index 61cded84..00000000
--- a/dev-java/liquidlnf/liquidlnf-0.2.9.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-inherit java-pkg-2 java-ant-2
-
-DESCRIPTION="Provides a look and feel based on the Mosfet Liquid KDE 3.x theme"
-HOMEPAGE="https://liquidlnf.dev.java.net/"
-SRC_URI="https://liquidlnf.dev.java.net/files/documents/3605/40518/${P}-src.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="source doc"
-
-CDEPEND="dev-java/laf-plugin"
-DEPEND=">=virtual/jdk-1.4
- dev-java/ant-core
- ${CDEPEND}"
-RDEPEND=">=virtual/jre-1.4
- ${CDEPEND}"
-
-S="${WORKDIR}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/${PV}/patch-to-rm-bootclasspath.patch"
- rm lib/*.jar
- cd lib
- java-pkg_jarfrom laf-plugin
-}
-
-src_compile() {
- eant
-}
-
-src_install() {
- java-pkg_dojar dist/bin/liquidlnf.jar
- use source && java-pkg_dosrc src/*
- use doc && java-pkg_dohtml -r www/*
-}
diff --git a/dev-java/liquidlnf/metadata.xml b/dev-java/liquidlnf/metadata.xml
deleted file mode 100644
index 2444066a..00000000
--- a/dev-java/liquidlnf/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
- <email>java@gentoo.org</email>
- <name>Java</name>
-</maintainer>
-</pkgmetadata>