summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-08-23 22:36:38 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-08-23 22:36:38 +0200
commit9bf8c7332a50c503dfb2a60d8d89033b98c4f93e (patch)
treeb2786bb5cd09da7cd9d50cb749843846fab7367b /dev-vcs
parentdev-util/qgit: pkgmove to dev-vcs/qgit (diff)
downloadkde-sunset-9bf8c7332a50c503dfb2a60d8d89033b98c4f93e.tar.gz
kde-sunset-9bf8c7332a50c503dfb2a60d8d89033b98c4f93e.tar.bz2
kde-sunset-9bf8c7332a50c503dfb2a60d8d89033b98c4f93e.zip
dev-vcs/qgit: Import 2.9 from before slot 4 removal
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/qgit/Manifest1
-rw-r--r--dev-vcs/qgit/qgit-2.9.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-vcs/qgit/Manifest b/dev-vcs/qgit/Manifest
index 56794d10..deed8032 100644
--- a/dev-vcs/qgit/Manifest
+++ b/dev-vcs/qgit/Manifest
@@ -1 +1,2 @@
DIST qgit-1.5.8.tar.bz2 209730 BLAKE2B 0b854044f799f017a2e8a2d823eacecc44044a388a04a49013a8a309ba1c5f45d638bf87e3104a70bc25cc8200a68008f1f0952ea42c0e54d8a427d1d8d47b9a SHA512 3d915f7b27d271b99c7ea1186b919330f7782a20647d9e9e1ca1a2893169f2195a0208a9233aa9abd5e15c5bb1f68fd2448a48c68680c79b7517273cd022ffa8
+DIST qgit-2.9.tar.gz 263875 BLAKE2B 8ec1235c760f2473a0700e7033ab99f3e72f019dee47761b86999a7de173132cf6592e9f5652b68285cd126adc4efffb5688944f34be2686683727354ab041c5 SHA512 2c91e02d0a7ea1e4620882520c77b47ff9b28fb9c9f9d178bf98b3e728e600e8d86a9e6e4cd60c33dbe63ced3636934fb7cdd6b0d5fa58182873675e3f97cc33
diff --git a/dev-vcs/qgit/qgit-2.9.ebuild b/dev-vcs/qgit/qgit-2.9.ebuild
new file mode 100644
index 00000000..344adcaa
--- /dev/null
+++ b/dev-vcs/qgit/qgit-2.9.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils qt4-r2
+
+DESCRIPTION="Qt4 GUI for git repositories"
+HOMEPAGE="https://github.com/tibirna/qgit"
+SRC_URI="https://github.com/tibirna/${PN}/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE=""
+
+DEPEND="dev-qt/qtgui:4"
+RDEPEND="${DEPEND}
+ >=dev-vcs/git-1.6
+"
+
+S="${WORKDIR}"/${PN}-${P}
+
+src_install() {
+ newbin bin/qgit qgit4
+ newicon src/resources/qgit.png qgit4.png
+ make_desktop_entry qgit4 QGit qgit4
+ dodoc README
+}