summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/qoauth/qoauth-1.0.1.ebuild')
-rw-r--r--dev-libs/qoauth/qoauth-1.0.1.ebuild72
1 files changed, 0 insertions, 72 deletions
diff --git a/dev-libs/qoauth/qoauth-1.0.1.ebuild b/dev-libs/qoauth/qoauth-1.0.1.ebuild
deleted file mode 100644
index abbe36a2..00000000
--- a/dev-libs/qoauth/qoauth-1.0.1.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-inherit qt4-r2
-
-DESCRIPTION="Qt-based library for OAuth support"
-HOMEPAGE="https://github.com/ayoy/qoauth/wiki"
-SRC_URI="http://files.ayoy.net/qoauth/release/${PV}/src/${P}-src.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 ~ppc ~ppc64 x86"
-IUSE="debug doc static-libs test"
-
-RESTRICT+=" !test? ( test )"
-
-COMMON_DEPEND="
- app-crypt/qca:2-qt4[debug?]
-"
-DEPEND="${COMMON_DEPEND}
- doc? ( app-doc/doxygen )
- test? ( dev-qt/qttest:4 )
-"
-RDEPEND="${COMMON_DEPEND}
- app-crypt/qca:2-qt4[ssl]
-"
-
-S=${WORKDIR}/${P}-src
-
-DOCS="README CHANGELOG"
-PATCHES=(
- # disable functional tests that require network connection
- # and rely on 3rd party external server (bug #341267)
- "${FILESDIR}/${P}-disable-ft.patch"
-)
-
-src_prepare() {
- qt4-r2_src_prepare
-
- if ! use test; then
- sed -i -e '/SUBDIRS/s/tests//' ${PN}.pro || die "sed failed"
- fi
-
- sed -i -e '/^ *docs \\$/d' \
- -e '/^ *build_all \\$/d' \
- -e 's/^\#\(!macx\)/\1/' \
- src/src.pro || die "sed failed"
-
- sed -i -e "s/\(.*\)lib$/\1$(get_libdir)/" src/pcfile.sh || die "sed failed"
-}
-
-src_compile() {
- default
- if use static-libs; then
- emake -C src static
- fi
-}
-
-src_install() {
- qt4-r2_src_install
-
- if use static-libs; then
- dolib.a "${S}"/lib/lib${PN}.a
- fi
-
- if use doc; then
- doxygen "${S}"/Doxyfile || die "failed to generate documentation"
- dohtml "${S}"/doc/html/*
- fi
-}