aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-07-02 20:06:36 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-07-02 23:37:43 +0200
commit581a350a4178c528476e15e0cdebe0a24a148a54 (patch)
treecc765f90dfbdd35bb583f0c998be13a463a5376c /dev-libs
parentapp-office/merkuro: 24.05.2 version bump (diff)
downloadkde-581a350a4178c528476e15e0cdebe0a24a148a54.tar.gz
kde-581a350a4178c528476e15e0cdebe0a24a148a54.tar.bz2
kde-581a350a4178c528476e15e0cdebe0a24a148a54.zip
dev-libs/kopeninghours: 24.05.2 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/kopeninghours/Manifest1
-rw-r--r--dev-libs/kopeninghours/kopeninghours-24.05.2.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-libs/kopeninghours/Manifest b/dev-libs/kopeninghours/Manifest
new file mode 100644
index 0000000000..dc504edcf0
--- /dev/null
+++ b/dev-libs/kopeninghours/Manifest
@@ -0,0 +1 @@
+DIST kopeninghours-24.05.2.tar.xz 74584 BLAKE2B 54ec52b2f59f714794f35d2e4b131beeb931b4a9d248afbcc49b0d0708c98c91501e782433cd4bcffd61b81a4d0bfd551b216c4886f8ec72cf79321840b7b5d2 SHA512 72f2276d9e48836dda32320695ab35e333336c8204d8bc84f8c777a81ebf5ff0a4a83e87375b5af9458ab46755a2456a54451fd2f50cfe4ff3d7d4067d30297a
diff --git a/dev-libs/kopeninghours/kopeninghours-24.05.2.ebuild b/dev-libs/kopeninghours/kopeninghours-24.05.2.ebuild
new file mode 100644
index 0000000000..4e0fba0806
--- /dev/null
+++ b/dev-libs/kopeninghours/kopeninghours-24.05.2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="true"
+ECM_TEST="true"
+PVCUT=$(ver_cut 1-3)
+KFMIN=6.3.0
+QTMIN=6.6.2
+PYTHON_COMPAT=( python3_{10..12} )
+inherit ecm gear.kde.org python-single-r1
+
+DESCRIPTION="Library for parsing and evaluating OSM opening hours expressions"
+HOMEPAGE="https://api.kde.org/kopeninghours/html/index.html
+https://invent.kde.org/libraries/kopeninghours"
+
+LICENSE="LGPL-2+"
+SLOT="6"
+KEYWORDS="~amd64 ~arm64"
+IUSE="python"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="
+ >=dev-libs/kpublictransport-${PVCUT}:6
+ >=dev-qt/qtdeclarative-${QTMIN}:6
+ >=kde-frameworks/kholidays-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ sys-libs/zlib
+ python? (
+ $(python_gen_cond_dep '
+ >=dev-libs/boost-1.70:=[python,${PYTHON_USEDEP}]
+ ')
+ )
+"
+RDEPEND="${DEPEND}
+ ${PYTHON_DEPS}
+"
+BDEPEND="
+ app-alternatives/lex
+ app-alternatives/yacc
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-22.04.0-boostpython.patch )
+
+pkg_setup() {
+ ecm_pkg_setup
+ python_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBOOSTPYTHON_VERSION_MAJOR_MINOR=${EPYTHON}
+ $(cmake_use_find_package python Boost)
+ )
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+ python_optimize
+}