aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-05-13 23:37:13 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-05-14 01:11:30 +0200
commit7931c4e44fce0078eea87440021ca12d97d55420 (patch)
treec267eec6ca474d23b1b5cf126395bafb800514c7 /www-client
parentkde-apps/konqueror: 24.04.90 version bump (diff)
downloadkde-7931c4e44fce0078eea87440021ca12d97d55420.tar.gz
kde-7931c4e44fce0078eea87440021ca12d97d55420.tar.bz2
kde-7931c4e44fce0078eea87440021ca12d97d55420.zip
www-client/falkon: 24.04.90 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/falkon/Manifest1
-rw-r--r--www-client/falkon/falkon-24.04.90.ebuild83
2 files changed, 84 insertions, 0 deletions
diff --git a/www-client/falkon/Manifest b/www-client/falkon/Manifest
new file mode 100644
index 0000000000..7880e7f95d
--- /dev/null
+++ b/www-client/falkon/Manifest
@@ -0,0 +1 @@
+DIST falkon-24.04.90.tar.xz 2584412 BLAKE2B 120f1fbb4bf290059939d9a37a11c5001754535acf3245379264c5581d1307fa1e6073112e4efb27646c1e3072d953c1d84b5776acaa391821961cb48bf769d5 SHA512 cc1b9c8d24458e97add2421ab306553b36ba3307adc141e449436196920ba155aca40de71129fa7f1f610b2a25012acf96830ebd4732c78189d4ad4690687b9a
diff --git a/www-client/falkon/falkon-24.04.90.ebuild b/www-client/falkon/falkon-24.04.90.ebuild
new file mode 100644
index 0000000000..34faabc2be
--- /dev/null
+++ b/www-client/falkon/falkon-24.04.90.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="true"
+KFMIN=6.0.0
+QTMIN=6.6.2
+PYTHON_COMPAT=( python3_{10..12} )
+inherit ecm gear.kde.org python-single-r1
+
+DESCRIPTION="Cross-platform web browser using QtWebEngine"
+HOMEPAGE="https://www.falkon.org/ https://apps.kde.org/falkon/"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="dbus kde python +X"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+RESTRICT="test" # bug 653046
+
+COMMON_DEPEND="
+ dev-libs/openssl:0=
+ >=dev-qt/qt5compat-${QTMIN}:6
+ >=dev-qt/qtbase-${QTMIN}:6[dbus?,gui,network,sql,sqlite,ssl,widgets]
+ >=dev-qt/qtdeclarative-${QTMIN}:6[widgets]
+ >=dev-qt/qtwebchannel-${QTMIN}:6
+ >=dev-qt/qtwebengine-${QTMIN}:6=[widgets]
+ >=kde-frameworks/karchive-${KFMIN}:6
+ virtual/libintl
+ kde? (
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/kcrash-${KFMIN}:6
+ >=kde-frameworks/kio-${KFMIN}:6
+ >=kde-frameworks/kjobwidgets-${KFMIN}:6
+ >=kde-frameworks/kwallet-${KFMIN}:6
+ >=kde-frameworks/purpose-${KFMIN}:6
+ )
+ python? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep "
+ >=dev-python/pyside6-${QTMIN}[designer,gui,webengine,widgets,\${PYTHON_USEDEP}] \
+ >=dev-python/shiboken6-${QTMIN}[\${PYTHON_USEDEP}]
+ ")
+ )
+ X? (
+ x11-libs/libxcb:=
+ x11-libs/xcb-util
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-qt/qtbase-${QTMIN}:6[concurrent]
+"
+if [[ ${KDE_BUILD_TYPE} != live ]]; then
+ DEPEND+=" >=kde-frameworks/ki18n-${KFMIN}:6"
+fi
+RDEPEND="${COMMON_DEPEND}
+ >=dev-qt/qtsvg-${QTMIN}:6
+"
+BDEPEND=">=dev-qt/qttools-${QTMIN}:6[linguist]"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+ ecm_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_KEYRING=OFF
+ -DDISABLE_DBUS=$(usex !dbus)
+ $(cmake_use_find_package kde KF6Wallet)
+ $(cmake_use_find_package kde KF6KIO)
+ -DBUILD_PYTHON_SUPPORT=$(usex python)
+ -DNO_X11=$(usex !X)
+ )
+ use python && mycmakeargs+=(
+ -DPYTHON_CONFIG_SUFFIX="-${EPYTHON}" # shiboken_helpers.cmake quirk
+ -DPython3_INCLUDE_DIR=$(python_get_includedir)
+ -DPython3_LIBRARY=$(python_get_library_path)
+ )
+ ecm_src_configure
+}