aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMu Qiao <qiaomuf@gentoo.org>2011-05-26 20:18:30 +0800
committerMu Qiao <qiaomuf@gentoo.org>2011-05-27 22:38:07 +0800
commit545417a9c8286a81642a3750df4af7cd977a3be0 (patch)
tree5e98d4d4c9bce9dae4fcadeee8019f94d08189e3 /Makefile.am
parentCore: adjust interpreter to support unset (diff)
downloadlibbash-545417a9c8286a81642a3750df4af7cd977a3be0.tar.gz
libbash-545417a9c8286a81642a3750df4af7cd977a3be0.tar.bz2
libbash-545417a9c8286a81642a3750df4af7cd977a3be0.zip
Builtin: support unset built-in
We do not support unsetting array indexes currently. In addition, read-only functions can be unset for now. Note that if no options are supplied, or the -v option is given, each name refers to a shell variable(This behavior is supported by bash 3.2, bash-4.1 tries to unset function if the name doesn't match a variable).
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 3b72d46..ebe12ee 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -189,6 +189,8 @@ libcppbash_la_SOURCES = src/common.h \
src/builtins/let_builtin.cpp \
src/builtins/inherit_builtin.h \
src/builtins/inherit_builtin.cpp \
+ src/builtins/unset_builtin.h \
+ src/builtins/unset_builtin.cpp \
src/builtins/builtin_exceptions.h \
$(GENERATED_PARSER_C) \
$(GENERATED_PARSER_H) \