aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNathan Eloe <powerofazure@gmail.com>2010-08-09 09:12:16 -0500
committerNathan Eloe <powerofazure@gmail.com>2010-08-13 11:21:46 -0500
commit7513401d3c255348f3115ae3bdcb6c3d66bd8893 (patch)
tree9911d7acba137612f8f38cfdfdb805000010aec4 /configure.ac
parentCleanup of bashast.g (diff)
downloadlibbash-7513401d3c255348f3115ae3bdcb6c3d66bd8893.tar.gz
libbash-7513401d3c255348f3115ae3bdcb6c3d66bd8893.tar.bz2
libbash-7513401d3c255348f3115ae3bdcb6c3d66bd8893.zip
Migration to automake build system
Migrates to an automake based build system instead of Makefile.in. To generate the grammar, after running autoreconf, run "make grammar.run". Please run automake --add-missing to generate missing files.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 748a56b..4abab19 100644
--- a/configure.ac
+++ b/configure.ac
@@ -17,8 +17,10 @@
##############################################
AC_INIT([libbash], [0.1],[powerofazure@gmail.com])
+AM_INIT_AUTOMAKE
AC_PREREQ([2.65])
AC_PROG_CXX
+AC_PROG_RANLIB
AC_PATH_PROG([JAVA],[java],"no")
if test "$JAVA" = "no"; then
AC_MSG_ERROR([No java executable found])