summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVadim A. Misbakh-Soloviov <git@mva.name>2018-09-20 12:38:06 +0700
committerVadim A. Misbakh-Soloviov <git@mva.name>2018-09-20 12:38:06 +0700
commita83f3e7a1ef69e1393bed1c109269542db9e5401 (patch)
tree01fc8e3ea1df2669ca2831d2703fef989cdc8b51
parentserpent: added (diff)
downloadlua-a83f3e7a1ef69e1393bed1c109269542db9e5401.tar.gz
lua-a83f3e7a1ef69e1393bed1c109269542db9e5401.tar.bz2
lua-a83f3e7a1ef69e1393bed1c109269542db9e5401.zip
tdlua: added
-rw-r--r--dev-lua/tdlua/metadata.xml14
-rw-r--r--dev-lua/tdlua/tdlua-9999.ebuild39
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-lua/tdlua/metadata.xml b/dev-lua/tdlua/metadata.xml
new file mode 100644
index 0000000..c1baef2
--- /dev/null
+++ b/dev-lua/tdlua/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>williamh@gentoo.org</email>
+ <name>William Hubbs</name>
+ </maintainer>
+ <longdescription lang="en">
+ lightweight, native, lazy evaluating multithreading library for Lua-5.1 or 5.2.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">LuaLanes/lanes</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-lua/tdlua/tdlua-9999.ebuild b/dev-lua/tdlua/tdlua-9999.ebuild
new file mode 100644
index 0000000..0e2765e
--- /dev/null
+++ b/dev-lua/tdlua/tdlua-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+LUA_COMPAT="lua52 lua53 luajit2"
+
+VCS="git"
+GITHUB_A="giuseppeM99"
+
+inherit cmake-utils lua
+
+DESCRIPTION="A basic interface between tdlib and lua"
+HOMEPAGE="https://github.com/giuseppeM99/tdlua"
+
+LICENSE="GPL-3.0"
+SLOT="0"
+KEYWORDS=""
+IUSE="doc examples"
+
+DOCS=(README.md)
+EXAMPLES=(examples/.)
+
+RDEPEND="
+ dev-libs/openssl:0
+ media-libs/opus:0
+ net-libs/tdlib:0
+"
+
+each_lua_configure() {
+ mycmakeargs=(
+ -DLUA_INCLUDE_DIR=$(lua_get_incdir)
+ )
+ cmake-utils_src_configure
+}
+
+each_lua_install() {
+ dolua "${PN}".so
+}