summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVadim A. Misbakh-Soloviov <git@mva.name>2016-07-26 03:14:16 +0700
committerVadim A. Misbakh-Soloviov <git@mva.name>2016-07-26 03:14:16 +0700
commitc61a2cae7a933277fbf63a5909931f53106616ea (patch)
tree1679b1dd3e64e80ef7dd77a4fec6e124c4bcac8c
parentdev-lua/*: move to EAPI=6 + renewed lua.eclass (diff)
downloadlua-c61a2cae7a933277fbf63a5909931f53106616ea.tar.gz
lua-c61a2cae7a933277fbf63a5909931f53106616ea.tar.bz2
lua-c61a2cae7a933277fbf63a5909931f53106616ea.zip
net-im/*: bumps
-rw-r--r--eclass/lua.eclass33
-rw-r--r--net-im/clix/clix-9999.ebuild6
-rw-r--r--net-im/prosody-modules/metadata.xml28
-rw-r--r--net-im/prosody-modules/prosody-modules-9999.ebuild49
-rw-r--r--net-im/prosody/files/prosody.initd2
-rw-r--r--net-im/prosody/prosody-0.9.8.ebuild131
-rw-r--r--net-im/prosody/prosody-9999.ebuild8
7 files changed, 71 insertions, 186 deletions
diff --git a/eclass/lua.eclass b/eclass/lua.eclass
index 7bfc398..cdf75d3 100644
--- a/eclass/lua.eclass
+++ b/eclass/lua.eclass
@@ -295,22 +295,30 @@ lua_add_bdepend() {
# @DESCRIPTION:
# Gets an array of lua use targets enabled by the user
lua_get_use_implementations() {
- local i implementation
+ local i=() implementation
for implementation in ${LUA_COMPAT}; do
- use lua_targets_${implementation} && i+=" ${implementation}"
+ if [[ -z "${LUA_IGNORE_TARGET_DUPLICATION}" ]] && [ "${implementation}" = "lua51" ] && in_iuse lua_targets_luajit2 && use lua_targets_luajit2; then
+ ewarn "LuaJIT using same LMOD/CMOD install paths as lua51."
+ ewarn "Lua target 'lua51' was skipped to avoid useless double compilation and file overwrites."
+ ewarn "If you definitelly want to compile lua51 target for nothing (i.e. you're maintainer),"
+ ewarn "then set LUA_IGNORE_TARGET_DUPLICATION variable to any value in make.conf or package.env"
+ continue
+ else
+ use lua_targets_${implementation} && i+=("${implementation}")
+ fi
done
- echo $i
+ echo ${i[@]}
}
# @FUNCTION: lua_get_use_targets
# @DESCRIPTION:
# Gets an array of lua use targets that the ebuild sets
lua_get_use_targets() {
- local t implementation
+ local t=() implementation
for implementation in ${LUA_COMPAT}; do
- t+=" lua_targets_${implementation}"
+ t+=("lua_targets_${implementation}")
done
- echo $t
+ echo ${t[@]}
}
# @FUNCTION: lua_implementations_depend
@@ -390,16 +398,14 @@ _lua_invoke_environment() {
_lua_each_implementation() {
local invoked=no
- for _lua_implementation in ${LUA_COMPAT}; do
- # only proceed if it's requested
- use lua_targets_${_lua_implementation} || continue
-
+ for _lua_implementation in $(lua_get_use_implementations); do
LUA=$(lua_implementation_command ${_lua_implementation})
TARGET=${_lua_implementation};
lua_impl=$(basename ${LUA})
invoked=yes
if [[ -n "$1" ]]; then
+ _lua_setFLAGS
_lua_invoke_environment ${_lua_implementation} "$@"
fi
@@ -448,7 +454,6 @@ lua_src_unpack() {
# hack for VCS-eclasses (darcs, for example) which defaults unpack dir to WD/P instead of S
if [[ "${PV}" = *9999* ]] && [[ -d "${WORKDIR}/${P}" ]] && [[ ! -d "${WORKDIR}/all/${P}" ]] ; then
- die "darcs-patching :: git test"
mv "${WORKDIR}/${P}" "${WORKDIR}/all/${P}"
fi
@@ -662,7 +667,7 @@ lua_src_install() {
# done
# fi
done;
- README_DOCS+=(${READMES[@]})
+ README_DOCS+=(${DOCS_FORCE[@]})
if [[ -n "${HTML_DOCS}" ]] && ! use doc; then
unset HTML_DOCS
@@ -670,7 +675,7 @@ lua_src_install() {
if [[ -n "${README_DOCS}" ]]; then
export DOCS=(${README_DOCS[@]});
- _PHASE="install readmes" _lua_invoke_environment all _lua_src_install_docs
+ _PHASE="install readmes and forced docs" _lua_invoke_environment all _lua_src_install_docs
unset DOCS;
fi
@@ -894,8 +899,6 @@ lua_get_implementation() {
esac
}
-
-
_lua_default_all_prepare() {
local prepargs=();
prepargs+=(
diff --git a/net-im/clix/clix-9999.ebuild b/net-im/clix/clix-9999.ebuild
index 7079604..969c90f 100644
--- a/net-im/clix/clix-9999.ebuild
+++ b/net-im/clix/clix-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
inherit mercurial eutils
@@ -24,8 +24,10 @@ DEPEND="${RDEPEND}"
src_prepare() {
use luajit && sed -r \
- -e 's:(env lua):\1jit:' \
+ -e '1s:(env lua):\1jit:' \
-i clix.lua
+
+ default
}
src_compile() {
diff --git a/net-im/prosody-modules/metadata.xml b/net-im/prosody-modules/metadata.xml
index 799213a..22925c8 100644
--- a/net-im/prosody-modules/metadata.xml
+++ b/net-im/prosody-modules/metadata.xml
@@ -74,8 +74,9 @@
<flag name='disable_tls'>This module can be used to prevent Prosody from offering TLS on client ports that you specify. This can be useful to work around buggy clients when transport security is not required. (info: https://modules.prosody.im/mod_disable_tls)</flag>
<flag name='discoitems'>This Prosody plugin lets you manually override the service discovery items for a host. (info: https://modules.prosody.im/mod_discoitems)</flag>
<flag name='dwd'>This module implements an optimization of the Dialback protocol, by skipping the dialback step for servers presenting a valid certificate. (info: https://modules.prosody.im/mod_dwd)</flag>
+ <flag name='e2e_policy'>This module was written to encourage usage of End-to-end encryption for chat and MUC messages. It can be configured to warn the sender after every plaintext/unencrypted message or to block all plaintext/unencrypted messages. It also supports MUC and JID whitelisting, so administrators can for example whitelist public support MUCs ;-) (info: https://modules.prosody.im/mod_e2e_policy)</flag>
<flag name='email_pass'>This module aims to help in the procedure of user password restoration. To start the restoration, the user must go to an URL provided by this module, fill the JID and email and submit the request. (info: https://modules.prosody.im/mod_email_pass)</flag>
- <flag name='extdisco'>This module adds support for <a href="http://xmpp.org/extensions/xep-0215.html">XEP-0215: External Service Discovery</a>, which lets Prosody advertise non-XMPP services. (info: https://modules.prosody.im/mod_extdisco)</flag>
+ <flag name='extdisco'>This module adds support for <a href="https://xmpp.org/extensions/xep-0215.html">XEP-0215: External Service Discovery</a>, which lets Prosody advertise non-XMPP services. (info: https://modules.prosody.im/mod_extdisco)</flag>
<flag name='fallback_vcard'>No documentation yet :( (info: https://modules.prosody.im/mod_fallback_vcard)</flag>
<flag name='filter_chatstates'>Some mobile XMPP client developers consider <a href="http://xmpp.org/extensions/xep-0085.html">Chat State Notifications</a> to be a waste of power and bandwidth, especially when the user is not actively looking at their device. This module will filter them out while the session is considered inactive. It depends on <a href="/mod_csi.html">mod_csi</a> for deciding when to begin and end filtering. (info: https://modules.prosody.im/mod_filter_chatstates)</flag>
<flag name='firewall'><strong>Note:</strong> mod_firewall is in its very early stages. This documentation is liable to change, and some described functionality may be missing, incomplete or contain bugs. Feedback is welcome in the comments section at the bottom of this page. (info: https://modules.prosody.im/mod_firewall)</flag>
@@ -84,14 +85,17 @@
<flag name='group_bookmarks'><a href="http://prosody.im/doc/modules/mod_groups">mod_groups</a> allows you to insert contacts into users' contact lists. Well mod_group_bookmarks allows you to insert chatrooms into the user's bookmarks. These are fetched by their client and automatically joined when the log in. (info: https://modules.prosody.im/mod_group_bookmarks)</flag>
<flag name='host_blacklist'>No documentation yet :( (info: https://modules.prosody.im/mod_host_blacklist)</flag>
<flag name='host_guard'>As often it's undesiderable to employ only whitelisting logics in public environments, this module let's you more selectively restrict access to your hosts (component or server host) either disallowing access completely (with optional exceptions) or blacklisting certain sources. (info: https://modules.prosody.im/mod_host_guard)</flag>
+ <flag name='host_status_check'>This module allows you to monitor the state of hosts and components in your Prosody server. For example, it will track whether components are connected and (if the component supports it) listen for heartbeats sent by the component to indicate that it is functioning. (info: https://modules.prosody.im/mod_host_status_check)</flag>
+ <flag name='host_status_heartbeat'>This module integrates with <a href="/mod_host_status_check.html">mod_host_status_check</a> to provide heartbeats at regular intervals. (info: https://modules.prosody.im/mod_host_status_heartbeat)</flag>
<flag name='http_altconnect'>No documentation yet :( (info: https://modules.prosody.im/mod_http_altconnect)</flag>
<flag name='http_dir_listing'>This module generates directory listings when invoked by <code>mod_http_files</code>. See <a href="http://prosody.im/doc/modules/mod_http_files">documentation on <code>mod_http_files</code></a>. (info: https://modules.prosody.im/mod_http_dir_listing)</flag>
<flag name='http_favicon'>This simple module serves a <code>favicon.ico</code> from prosodys HTTP server and nothing else. (info: https://modules.prosody.im/mod_http_favicon)</flag>
+ <flag name='http_host_status_check'>This module exposes serves over HTTP the information collected by <a href="/mod_host_status_check.html">mod_host_status_check</a> and <a href="/mod_host_status_heartbeat.html">mod_host_status_heartbeat</a> in a convenient format for automated monitoring tools. (info: https://modules.prosody.im/mod_http_host_status_check)</flag>
<flag name='http_index'>This module produces a list of enabled HTTP &quot;apps&quot; exposed from Prosody at <code>http://example.org:5280/</code>, e.g. mod_http_muc_log, mod_http_files or mod_admin_web. If you think Prosodys default &quot;root&quot; web page (a 404 error usually) is boring, this might be the module for you! :) (info: https://modules.prosody.im/mod_http_index)</flag>
<flag name='http_logging'>No documentation yet :( (info: https://modules.prosody.im/mod_http_logging)</flag>
<flag name='http_muc_log'>This module provides a built-in web interface to view chatroom logs stored by <a href="/mod_mam_muc.html">mod_mam_muc</a>. (info: https://modules.prosody.im/mod_http_muc_log)</flag>
- <flag name='http_roster_admin'>Normally the XMPP server will store and maintain the users' contact rosters. This module lets you delegate roster management to an external service. (info: https://modules.prosody.im/mod_http_roster_admin)</flag>
- <flag name='http_upload'>This module implements <a href="http://xmpp.org/extensions/xep-0363.html">XEP-0363</a>, which lets clients upload files over HTTP. (info: https://modules.prosody.im/mod_http_upload)</flag>
+ <flag name='http_roster_admin'>No documentation yet :( (info: https://modules.prosody.im/mod_http_roster_admin)</flag>
+ <flag name='http_upload'>This module implements <a href="https://xmpp.org/extensions/xep-0363.html">XEP-0363</a>, which lets clients upload files over HTTP. (info: https://modules.prosody.im/mod_http_upload)</flag>
<flag name='http_user_count'>No documentation yet :( (info: https://modules.prosody.im/mod_http_user_count)</flag>
<flag name='idlecompat'>This module adds <a href="http://xmpp.org/extensions/xep-0319.html">XEP-0319</a> idle tags to presence stanzas containing <a href="http://xmpp.org/extensions/xep-0012.html">XEP-0012: Last Activity</a> tags for idle indication (e.g. supported by libpurple clients). It works on outgoing and incoming presence stanzas. (info: https://modules.prosody.im/mod_idlecompat)</flag>
<flag name='incidents_handling'>This module implements <a href="http://xmpp.org/extensions/xep-0268.html">XEP-268</a>. (info: https://modules.prosody.im/mod_incidents_handling)</flag>
@@ -106,7 +110,7 @@
<flag name='lib_ldap'>This module is used by other modules to access an LDAP server. It's pretty useless on its own; you should use it if you want to write your own LDAP-related module, or if you want to use one of mine (<a href="https://modules.prosody.im/mod_auth_ldap2.html">mod_auth_ldap2</a>, <a href="https://modules.prosody.im/mod_storage_ldap.html">mod_storage_ldap</a>). (info: https://modules.prosody.im/mod_lib_ldap)</flag>
<flag name='limit_auth'>This module lets you put a per-IP limit on the number of failed authentication attempts. (info: https://modules.prosody.im/mod_limit_auth)</flag>
<flag name='limits'>On some servers, especially public ones, it is desired to make sure that everyone gets their fair share of system resources (and no more). (info: https://modules.prosody.im/mod_limits)</flag>
- <flag name='list_inactive'>No documentation yet :( (info: https://modules.prosody.im/mod_list_inactive)</flag>
+ <flag name='list_inactive'>This module lists those users, who haven't used their account in a defined time-frame. (info: https://modules.prosody.im/mod_list_inactive)</flag>
<flag name='listusers'>No documentation yet :( (info: https://modules.prosody.im/mod_listusers)</flag>
<flag name='log_auth'>Prosody doesn't write IP addresses to its log file by default for privacy reasons (unless debug logging is enabled). (info: https://modules.prosody.im/mod_log_auth)</flag>
<flag name='log_events'>No documentation yet :( (info: https://modules.prosody.im/mod_log_events)</flag>
@@ -115,10 +119,10 @@
<flag name='log_rate'>If you ever wanted to collect statistics on the number of log messages, this is the module for you! (info: https://modules.prosody.im/mod_log_rate)</flag>
<flag name='log_sasl_mech'>No documentation yet :( (info: https://modules.prosody.im/mod_log_sasl_mech)</flag>
<flag name='log_slow_events'>No documentation yet :( (info: https://modules.prosody.im/mod_log_slow_events)</flag>
- <flag name='mam'>Implementation of <a href="http://xmpp.org/extensions/xep-0313.html">XEP-0313: Message Archive Management</a>. (info: https://modules.prosody.im/mod_mam)</flag>
+ <flag name='mam'>Implementation of <a href="https://xmpp.org/extensions/xep-0313.html">XEP-0313: Message Archive Management</a>. (info: https://modules.prosody.im/mod_mam)</flag>
<flag name='mam_adhoc'>This module complements mod_mam by allowing clients to change archiving preferences through an Ad-hoc command. (info: https://modules.prosody.im/mod_mam_adhoc)</flag>
<flag name='mam_archive'>Implementation of <a href="http://xmpp.org/extensions/xep-0136.html">XEP-0136: Message Archiving</a> for <a href="https://modules.prosody.im/mod_mam.html">mod_mam</a>. (info: https://modules.prosody.im/mod_mam_archive)</flag>
- <flag name='mam_muc'>This module logs the conversation of chatrooms running on the server to Prosody's archive storage. To access them you will need a client with support for <a href="http://xmpp.org/extensions/xep-0313.html">XEP-0313: Message Archive Management</a> or a module such as <a href="/mod_http_muc_log.html">mod_http_muc_log</a>. (info: https://modules.prosody.im/mod_mam_muc)</flag>
+ <flag name='mam_muc'>This module logs the conversation of chatrooms running on the server to Prosody's archive storage. To access them you will need a client with support for <a href="https://xmpp.org/extensions/xep-0313.html">XEP-0313: Message Archive Management</a> or a module such as <a href="/mod_http_muc_log.html">mod_http_muc_log</a>. (info: https://modules.prosody.im/mod_mam_muc)</flag>
<flag name='mamsub'>No documentation yet :( (info: https://modules.prosody.im/mod_mamsub)</flag>
<flag name='manifesto'>This module informs users about the XMPP Test day and whether their contacts are affected. For mor info about the test day, see <a href="https://stpeter.im/journal/1496.html" class="uri">https://stpeter.im/journal/1496.html</a> (info: https://modules.prosody.im/mod_manifesto)</flag>
<flag name='measure_cpu'>This module measures CPU usage and reports using Prosody 0.10 APIs (info: https://modules.prosody.im/mod_measure_cpu)</flag>
@@ -143,6 +147,7 @@
<flag name='password_policy'>No documentation yet :( (info: https://modules.prosody.im/mod_password_policy)</flag>
<flag name='pastebin'>Pastebins are used very often in IM, especially in chat rooms. You have a long log or command output which you need to send to someone over IM, and don't want to fill their message window with it. Put it on a pastebin site, and give them the URL instead, simple. (info: https://modules.prosody.im/mod_pastebin)</flag>
<flag name='pep_vcard_avatar'>This module pushes the users nickname and avatar from vCards into PEP, or into vCards from PEP. This allows interop between older clients that use <a href="http://xmpp.org/extensions/xep-0153.html">XEP-0153: vCard-Based Avatars</a> to see the avatars of clients that use <a href="http://xmpp.org/extensions/xep-0084.html">XEP-0084: User Avatar</a> and vice versa. (info: https://modules.prosody.im/mod_pep_vcard_avatar)</flag>
+ <flag name='pep_vcard_png_avatar'>Conversations (an XMPP client for Android) is publishing PEP avatars in the webp file format. However Pidgin and other XMPP desktop clients can only show vcard avatars, that are in the PNG file format. This module is the <a href="https://modules.prosody.im/mod_pep_vcard_avatar.html">mod_pep_vcard_avatar</a> module extended to also change the avatar file format to PNG. (info: https://modules.prosody.im/mod_pep_vcard_png_avatar)</flag>
<flag name='pinger'>No documentation yet :( (info: https://modules.prosody.im/mod_pinger)</flag>
<flag name='poke_strangers'>In order to build heuristics for which messages are spam, it is necessary to log as many details as possible about the spammers. This module sends a version and disco query whenever a message is received from a JID to a user it is not subscribed to. The results are printed to Prosody's log file at the 'info' level. Queried full JIDs are not queried again until Prosody restarts. (info: https://modules.prosody.im/mod_poke_strangers)</flag>
<flag name='post_msg'>Sometimes it's useful to have different interfaces to access XMPP. (info: https://modules.prosody.im/mod_post_msg)</flag>
@@ -170,7 +175,7 @@
<flag name='register_redirect'>Registration Redirect as explained in the <a href="http://xmpp.org/extensions/xep-0077.html#redirect">IBR XEP</a>. (info: https://modules.prosody.im/mod_register_redirect)</flag>
<flag name='register_web'>There are various reasons to prefer web registration instead of &quot;in-band&quot; account registration over XMPP. For example the lack of CAPTCHA support in clients and servers. (info: https://modules.prosody.im/mod_register_web)</flag>
<flag name='reload_modules'>By default Prosody does not reload modules at runtime unless instructed to via one of its admin interfaces. However sometimes you want to easily reload a module to apply new settings when the config changes. (info: https://modules.prosody.im/mod_reload_modules)</flag>
- <flag name='remote_roster'>This module adds support for <a href="http://xmpp.org/extensions/xep-0321.html">XEP-0321: Remote Roster Management</a> which is commonly used to allow components such as transports to modify the rosters of local users. (info: https://modules.prosody.im/mod_remote_roster)</flag>
+ <flag name='remote_roster'>This module adds support for <a href="https://xmpp.org/extensions/xep-0321.html">XEP-0321: Remote Roster Management</a> which is commonly used to allow components such as transports to modify the rosters of local users. (info: https://modules.prosody.im/mod_remote_roster)</flag>
<flag name='require_otr'><a href="https://otr.cypherpunks.ca/">OTR, &quot;Off The Record&quot;</a>, encryption allows clients to encrypt messages such that the server cannot read/modify them. (info: https://modules.prosody.im/mod_require_otr)</flag>
<flag name='roster_allinall'>This module is similar in purpouse to mod_groups, for when you want all users on the server to be in each others roster. (info: https://modules.prosody.im/mod_roster_allinall)</flag>
<flag name='roster_command'>This module allows you to perform various actions on user rosters via prosodyctl. (info: https://modules.prosody.im/mod_roster_command)</flag>
@@ -178,9 +183,10 @@
<flag name='s2s_auth_dane'>This module implements DANE as described in <a href="http://tools.ietf.org/html/draft-miller-xmpp-dnssec-prooftype">Using DNS Security Extensions (DNSSEC) and DNS-based Authentication of Named Entities (DANE) as a Prooftype for XMPP Domain Name Associations</a>. (info: https://modules.prosody.im/mod_s2s_auth_dane)</flag>
<flag name='s2s_auth_fingerprint'>This module allows you to manually pin certificate fingerprints of remote servers. (info: https://modules.prosody.im/mod_s2s_auth_fingerprint)</flag>
<flag name='s2s_auth_monkeysphere'><a href="http://web.monkeysphere.info/">Monkeysphere</a> is a project aiming to introduce PGP's web of trust to protocols such as SSH and TLS (which XMPP uses). (info: https://modules.prosody.im/mod_s2s_auth_monkeysphere)</flag>
+ <flag name='s2s_auth_samecert'>No documentation yet :( (info: https://modules.prosody.im/mod_s2s_auth_samecert)</flag>
<flag name='s2s_blacklist'>No documentation yet :( (info: https://modules.prosody.im/mod_s2s_blacklist)</flag>
<flag name='s2s_idle_timeout'>Some people find it preferable to close server-to-server connections after they have been silent for a while. (info: https://modules.prosody.im/mod_s2s_idle_timeout)</flag>
- <flag name='s2s_keepalive'>This module periodically sends <a href="http://xmpp.org/extensions/xep-0199.html">XEP-0199</a> ping requests to remote servers to keep your connection alive. (info: https://modules.prosody.im/mod_s2s_keepalive)</flag>
+ <flag name='s2s_keepalive'>This module periodically sends <a href="https://xmpp.org/extensions/xep-0199.html">XEP-0199</a> ping requests to remote servers to keep your connection alive. (info: https://modules.prosody.im/mod_s2s_keepalive)</flag>
<flag name='s2s_keysize_policy'>This module sets the security status of s2s connections to invalid if their key is too small and their certificate was issued after 2014, per CA/B Forum guidelines. (info: https://modules.prosody.im/mod_s2s_keysize_policy)</flag>
<flag name='s2s_log_certs'>This module produces info level log messages with the certificate status and fingerprint every time an s2s connection is established. It can also optionally store this in persistant storage. (info: https://modules.prosody.im/mod_s2s_log_certs)</flag>
<flag name='s2s_never_encrypt_blacklist'>Let's you stop Prosody from sending &lt;starttls xmlns='urn:ietf:params:xml:ns:xmpp-tls'&gt; feature to choppy/buggy servers which therefore would fail to re-negotiate and use a secure stream. (e.g. <a href="http://issues.igniterealtime.org/browse/OF-405">OpenFire 3.7.0</a>) (info: https://modules.prosody.im/mod_s2s_never_encrypt_blacklist)</flag>
@@ -194,7 +200,7 @@
<flag name='server_contact_info'>This module implements <a href="http://xmpp.org/extensions/xep-0157.html">XEP-0157: Contact Addresses for XMPP Services</a>. (info: https://modules.prosody.im/mod_server_contact_info)</flag>
<flag name='server_status'>This module fetches the current status of configured hosts and/or stanza statistics from <a href="http://code.google.com/p/prosody-modules/wiki/mod_stanza_counter#">mod_stanza_counter</a>. And outputs it in either XML or JSON format. (info: https://modules.prosody.im/mod_server_status)</flag>
<flag name='service_directories'>No documentation yet :( (info: https://modules.prosody.im/mod_service_directories)</flag>
- <flag name='sift'><a href="http://xmpp.org/extensions/xep-0273.html">SIFT</a> is a technology to allow clients to filter incoming traffic on the server. This helps save bandwidth, etc. (info: https://modules.prosody.im/mod_sift)</flag>
+ <flag name='sift'><a href="https://xmpp.org/extensions/xep-0273.html">SIFT</a> is a technology to allow clients to filter incoming traffic on the server. This helps save bandwidth, etc. (info: https://modules.prosody.im/mod_sift)</flag>
<flag name='smacks'>By default XMPP is as reliable as your network is. Unfortunately in some cases that is not very reliable - in some network conditions disconnects can be frequent and message loss can occur. (info: https://modules.prosody.im/mod_smacks)</flag>
<flag name='smacks_offline'>No documentation yet :( (info: https://modules.prosody.im/mod_smacks_offline)</flag>
<flag name='sms_clickatell'>This module provides and SMS gateway component which uses the Clickatell HTTP API to deliver text messages. See clickatell.com for details on their services. Note that at present, this is entirely one way: replies will either go nowhere or as sms to the source number you specify. (info: https://modules.prosody.im/mod_sms_clickatell)</flag>
@@ -208,12 +214,14 @@
<flag name='statistics_statsd'>No documentation yet :( (info: https://modules.prosody.im/mod_statistics_statsd)</flag>
<flag name='statsd'>No documentation yet :( (info: https://modules.prosody.im/mod_statsd)</flag>
<flag name='storage_appendmap'>This is an experimental storage driver where changed data is appended. Data is simply written as <code>key = value</code> pairs to the end of the file. This allows changes to individual keys to be written without needing to write out the entire object again, but reads would grow gradually larger as it still needs to read old overwritten keys. This may be suitable for eg rosters where individual contacts are changed at a time. In theory, this could also allow rolling back changes. (info: https://modules.prosody.im/mod_storage_appendmap)</flag>
+ <flag name='storage_ejabberdsql_readonly'>This is a storage backend using Ejabberd’s SQL backend. It depends on <a href="https://prosody.im/doc/depends#luadbi">LuaDBI</a> (info: https://modules.prosody.im/mod_storage_ejabberdsql_readonly)</flag>
<flag name='storage_gdbm'>This is a storage module using GNU DBM as backend. It supports archives. (info: https://modules.prosody.im/mod_storage_gdbm)</flag>
<flag name='storage_ldap'>See <a href="https://modules.prosody.im/mod_lib_ldap.html">mod_lib_ldap</a> for more information. (info: https://modules.prosody.im/mod_storage_ldap)</flag>
<flag name='storage_lmdb'>This is a storage module using OpenLDAP Lightning Memory-Mapped Database as backend. (info: https://modules.prosody.im/mod_storage_lmdb)</flag>
<flag name='storage_memory'>This module acts as a normal storage module for Prosody, but saves all data in memory only. All data is lost when the server stops. This makes it useful for testing, or certain specialized applications. (info: https://modules.prosody.im/mod_storage_memory)</flag>
<flag name='storage_mongodb'>This is a storage backend that uses MongoDB. Depends on <a href="https://github.com/mwild1/luamongo">luamongo bindings</a> (info: https://modules.prosody.im/mod_storage_mongodb)</flag>
<flag name='storage_muc_log'><a href="https://modules.prosody.im/mod_muc_log.html">mod_muc_log</a> provided logging of chatrooms running on the server to Prosody's data store. This module gives access to this data using the 0.10+ stanza archive API, allowing legacy log data to be used with <a href="https://modules.prosody.im/mod_mam_muc.html">mod_mam_muc</a> and <a href="https://modules.prosody.im/mod_http_muc_log.html">mod_http_muc_log</a>. (info: https://modules.prosody.im/mod_storage_muc_log)</flag>
+ <flag name='storage_muconference_readonly'>This is a storage backend using MU-Conference’s SQL storage. It depends on <a href="https://prosody.im/doc/depends#luadbi">LuaDBI</a> (info: https://modules.prosody.im/mod_storage_muconference_readonly)</flag>
<flag name='storage_multi'>This module attemtps to provide a storage driver that is really multiple storage drivers. This could be used for storage error tolerance or caching of data in a faster storage driver. (info: https://modules.prosody.im/mod_storage_multi)</flag>
<flag name='storage_xmlarchive'>This module implements stanza archives using files, similar to the default &quot;internal&quot; storage. (info: https://modules.prosody.im/mod_storage_xmlarchive)</flag>
<flag name='streamstats'>No documentation yet :( (info: https://modules.prosody.im/mod_streamstats)</flag>
@@ -229,7 +237,7 @@
<flag name='turncredentials'>No documentation yet :( (info: https://modules.prosody.im/mod_turncredentials)</flag>
<flag name='twitter'>Twitter has simple API to use, so I tried to deal with it via Prosody. I didn't manage to finish this module, but it is nice example of component that accepts registrations, unregistrations, does HTTP polling and so on. Maybe someone will finnish this idea. (info: https://modules.prosody.im/mod_twitter)</flag>
<flag name='uptime_presence'>This module simply responds to a presence probe sent to the server with a presence staza containing a timestamp from when the server started. (info: https://modules.prosody.im/mod_uptime_presence)</flag>
- <flag name='vjud'>Basic implementation of <a href="http://xmpp.org/extensions/xep-0055.html">XEP-0055: Jabber Search</a>. (info: https://modules.prosody.im/mod_vjud)</flag>
+ <flag name='vjud'>Basic implementation of <a href="https://xmpp.org/extensions/xep-0055.html">XEP-0055: Jabber Search</a>. (info: https://modules.prosody.im/mod_vjud)</flag>
<flag name='watchuntrusted'>Similar to mod_watchregistrations, this module warns admins when an s2s connection fails due for encryption or trust reasons. (info: https://modules.prosody.im/mod_watchuntrusted)</flag>
<flag name='webpresence'>Quite often you may want to publish your Jabber status to your blog or website. mod_webpresence allows you to do exactly this. (info: https://modules.prosody.im/mod_webpresence)</flag>
diff --git a/net-im/prosody-modules/prosody-modules-9999.ebuild b/net-im/prosody-modules/prosody-modules-9999.ebuild
index b071e47..676002e 100644
--- a/net-im/prosody-modules/prosody-modules-9999.ebuild
+++ b/net-im/prosody-modules/prosody-modules-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
inherit eutils multilib mercurial
@@ -30,10 +30,11 @@ PROSODY_MODULES="
compat_vcard component_client component_roundrobin
conformance_restricted couchdb csi csi_compat data_access
default_bookmarks default_vcard delegation disable_tls discoitems dwd
- email_pass extdisco fallback_vcard filter_chatstates firewall
+ e2e_policy email_pass extdisco fallback_vcard filter_chatstates firewall
flash_policy graceful_shutdown group_bookmarks host_blacklist host_guard
- http_altconnect http_dir_listing http_favicon http_index http_logging
- http_muc_log http_roster_admin http_upload http_user_count idlecompat
+ host_status_check host_status_heartbeat http_altconnect http_dir_listing
+ http_favicon http_host_status_check http_index http_logging http_muc_log
+ http_roster_admin http_upload http_user_count idlecompat
incidents_handling inotify_reload invite ipcheck isolate_host jid_prep
json_streams lastlog latex lib_ldap limit_auth limits list_inactive
listusers log_auth log_events log_mark log_messages_sql log_rate
@@ -42,26 +43,28 @@ PROSODY_MODULES="
motd_sequential muc_access_control muc_ban_ip muc_config_restrict
muc_intercom muc_limits muc_log muc_log_http muc_restrict_rooms munin
net_dovecotauth offline_email onhold onions openid password_policy
- pastebin pep_vcard_avatar pinger poke_strangers post_msg presence_cache
- presence_dedup privacy_lists private_adhoc privilege proctitle profile
- proxy65_whitelist pubsub_eventsource pubsub_feeds pubsub_github
- pubsub_hub pubsub_mqtt pubsub_pivotaltracker pubsub_post pubsub_twitter
- query_client_ver rawdebug readonly register_dnsbl register_json
- register_redirect register_web reload_modules remote_roster require_otr
- roster_allinall roster_command s2s_auth_compat s2s_auth_dane
- s2s_auth_fingerprint s2s_auth_monkeysphere s2s_blacklist
- s2s_idle_timeout s2s_keepalive s2s_keysize_policy s2s_log_certs
- s2s_never_encrypt_blacklist s2s_reload_newcomponent s2s_whitelist
- s2soutinjection saslauth_muc saslname seclabels secure_interfaces
- server_contact_info server_status service_directories sift smacks
- smacks_offline sms_clickatell srvinjection sslv3_warn stanza_counter
- statistics statistics_auth statistics_cputotal statistics_mem
- statistics_statsd statsd storage_appendmap storage_gdbm storage_ldap
+ pastebin pep_vcard_avatar pep_vcard_png_avatar pinger poke_strangers
+ post_msg presence_cache presence_dedup privacy_lists private_adhoc
+ privilege proctitle profile proxy65_whitelist pubsub_eventsource
+ pubsub_feeds pubsub_github pubsub_hub pubsub_mqtt pubsub_pivotaltracker
+ pubsub_post pubsub_twitter query_client_ver rawdebug readonly
+ register_dnsbl register_json register_redirect register_web
+ reload_modules remote_roster require_otr roster_allinall roster_command
+ s2s_auth_compat s2s_auth_dane s2s_auth_fingerprint s2s_auth_monkeysphere
+ s2s_auth_samecert s2s_blacklist s2s_idle_timeout s2s_keepalive
+ s2s_keysize_policy s2s_log_certs s2s_never_encrypt_blacklist
+ s2s_reload_newcomponent s2s_whitelist s2soutinjection saslauth_muc
+ saslname seclabels secure_interfaces server_contact_info server_status
+ service_directories sift smacks smacks_offline sms_clickatell
+ srvinjection sslv3_warn stanza_counter statistics statistics_auth
+ statistics_cputotal statistics_mem statistics_statsd statsd
+ storage_appendmap storage_ejabberdsql_readonly storage_gdbm storage_ldap
storage_lmdb storage_memory storage_mongodb storage_muc_log
- storage_multi storage_xmlarchive streamstats strict_https
- support_contact swedishchef tcpproxy telnet_tlsinfo throttle_presence
- throttle_unsolicited tls_policy track_muc_joins turncredentials twitter
- uptime_presence vjud watchuntrusted webpresence
+ storage_muconference_readonly storage_multi storage_xmlarchive
+ streamstats strict_https support_contact swedishchef tcpproxy
+ telnet_tlsinfo throttle_presence throttle_unsolicited tls_policy
+ track_muc_joins turncredentials twitter uptime_presence vjud
+ watchuntrusted webpresence
"
diff --git a/net-im/prosody/files/prosody.initd b/net-im/prosody/files/prosody.initd
index aa422f6..43e6150 100644
--- a/net-im/prosody/files/prosody.initd
+++ b/net-im/prosody/files/prosody.initd
@@ -1,4 +1,4 @@
-#!/sbin/runscript
+#!/sbin/openrc-run
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
diff --git a/net-im/prosody/prosody-0.9.8.ebuild b/net-im/prosody/prosody-0.9.8.ebuild
deleted file mode 100644
index 58fbe7d..0000000
--- a/net-im/prosody/prosody-0.9.8.ebuild
+++ /dev/null
@@ -1,131 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils multilib toolchain-funcs versionator
-
-DESCRIPTION="Prosody is a flexible communications server for Jabber/XMPP written in Lua."
-HOMEPAGE="http://prosody.im/"
-
-SRC_URI="https://prosody.im/downloads/source/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="x86 amd64 mips arm sparc"
-IUSE="doc +libevent mysql postgres sqlite +ssl +zlib luajit ipv6 migration"
-
-DEPEND="
- net-im/jabber-base
- virtual/lua[luajit=]
- >=net-dns/libidn-1.1
- >=dev-libs/openssl-0.9.8
-"
-
-RDEPEND="
- ${DEPEND}
- dev-lua/luasocket
- ipv6? ( =dev-lua/luasocket-9999 )
- ssl? ( =dev-lua/luasec-9999 )
- dev-lua/luaexpat
- dev-lua/luafilesystem
- mysql? ( >=dev-lua/luadbi-0.5[mysql] )
- postgres? ( >=dev-lua/luadbi-0.5[postgres] )
- sqlite? ( >=dev-lua/luadbi-0.5[sqlite] )
- libevent? ( dev-lua/luaevent )
- zlib? ( dev-lua/lua-zlib )
-"
-
-S="${WORKDIR}/${P}"
-
-JABBER_ETC="/etc/jabber"
-JABBER_SPOOL="/var/spool/jabber"
-
-
-DOCS=( -r doc/ HACKERS AUTHORS )
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-0.8.0-cfg.lua.patch"
- sed -e "s!MODULES = \$(DESTDIR)\$(PREFIX)/lib/!MODULES = \$(DESTDIR)\$(PREFIX)/$(get_libdir)/!" -i Makefile
- sed -e "s!SOURCE = \$(DESTDIR)\$(PREFIX)/lib/!SOURCE = \$(DESTDIR)\$(PREFIX)/$(get_libdir)/!" -i Makefile
- sed -e "s!INSTALLEDSOURCE = \$(PREFIX)/lib/!INSTALLEDSOURCE = \$(PREFIX)/$(get_libdir)/!" -i Makefile
- sed -e "s!INSTALLEDMODULES = \$(PREFIX)/lib/!INSTALLEDMODULES = \$(PREFIX)/$(get_libdir)/!" -i Makefile
- sed -e 's!\(os.execute(\)\(CFG_SOURCEDIR.."/../../bin/prosody"\)\();\)!\1"/usr/bin/prosody"\3!' -i util/prosodyctl.lua
- sed -e 's!\(desired_user = .* or "\)\(prosody\)\(";\)!\1jabber\3!' -i prosodyctl
-
- use luajit && {
- find . -type f -name "*.lua" -print0 | xargs -0 sed -re "1s%#!.*%#!/usr/bin/env luajit%" -i
- }
-}
-
-src_configure() {
- local lua=lua;
-
- use luajit && {
- myconf="--lua-suffix=jit"
- lua=luajit;
- }
-
- # the configure script is handcrafted (and yells at unknown options)
- # hence do not use 'econf'
- ./configure --prefix="/usr" \
- --ostype=linux \
- --sysconfdir="${JABBER_ETC}" \
- --datadir="${JABBER_SPOOL}" \
- --with-lua-lib=/usr/$(get_libdir) \
- --c-compiler="$(tc-getCC)" --linker="$(tc-getCC)" \
- --cflags="${CFLAGS} -Wall -fPIC -D_GNU_SOURCE" \
- --ldflags="${LDFLAGS} -shared" \
- --runwith="${lua}" \
- --with-lua-include="$($(tc-getPKG_CONFIG) --variable includedir ${lua})" \
- --require-config "${myconf}" || die "configure failed"
-}
-
-src_compile() {
- default
- use migration && (
- cd "${S}/tools/migration"
- emake || die "emake migrator fails"
- )
-}
-
-src_install() {
- local lua=lua
- use luajit && lua=luajit
- default
-# DESTDIR="${D}" emake install || die "make failed"
- newinitd "${FILESDIR}/${PN}".initd "${PN}"
- insinto /etc/logrotate.d
- newins "${FILESDIR}/${PN}".logrotate "${PN}"
-
- use migration && (
- cd "${S}/tools/migration"
- DESTDIR="${D}" emake install || die "migrator install failed"
- cd "${S}"
- rm -rf tools/migration
- insinto $($(tc-getPKG_CONFIG) ${lua} --variable INSTALL_LMOD)
- doins tools/erlparse.lua
- rm tools/erlparse.lua
- fowners "jabber:jabber" -R "/usr/$(get_libdir)/${PN}"
- fperms "775" -R "/usr/$(get_libdir)/${PN}"
- insinto "/usr/$(get_libdir)/${PN}"
- doins -r tools
- )
-}
-
-src_test() {
- cd tests
- ./run_tests.sh
-}
-
-pkg_postinst() {
- use migration && (
- einfo 'You have enabled "migration" USE-flag.'
- einfo "If you want to migrate data from Ejabberd server, then"
- einfo "take a look at /usr/$(get_libdir)/${PN}/*{2,to}prosody.lua"
- einfo "migration scripts."
- einfo 'Also, you can find "prosody-migrator" binary as usefull'
- einfo "to migrate data from jabberd14, or between prosody files"
- einfo "storage and SQLite3."
- )
-}
diff --git a/net-im/prosody/prosody-9999.ebuild b/net-im/prosody/prosody-9999.ebuild
index d0dc0f1..1799682 100644
--- a/net-im/prosody/prosody-9999.ebuild
+++ b/net-im/prosody/prosody-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
inherit eutils multilib toolchain-funcs versionator mercurial
@@ -38,13 +38,11 @@ RDEPEND="
zlib? ( dev-lua/lua-zlib )
"
-S="${WORKDIR}/${P}"
-
JABBER_ETC="/etc/jabber"
JABBER_SPOOL="/var/spool/jabber"
-DOCS=( -r doc/ HACKERS AUTHORS )
+DOCS=( doc/ HACKERS AUTHORS )
src_prepare() {
epatch "${FILESDIR}/${PN}-0.8.0-cfg.lua.patch"
@@ -58,6 +56,8 @@ src_prepare() {
use luajit && {
find . -type f -name "*.lua" -print0 | xargs -0 sed -re "1s%#!.*%#!/usr/bin/env luajit%" -i
}
+
+ default
}
src_configure() {