summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-lua/alt-getopt/Manifest1
-rw-r--r--dev-lua/alt-getopt/alt-getopt-0.7.0.ebuild45
-rw-r--r--dev-lua/alt-getopt/metadata.xml14
-rw-r--r--dev-lua/ansicolors/ansicolors-9999.ebuild39
-rw-r--r--dev-lua/ansicolors/metadata.xml14
-rw-r--r--dev-lua/lapis/lapis-9999.ebuild57
-rw-r--r--dev-lua/lapis/metadata.xml14
-rw-r--r--dev-lua/moonscript/metadata.xml14
-rw-r--r--dev-lua/moonscript/moonscript-9999.ebuild49
-rw-r--r--profiles/thirdpartymirrors1
10 files changed, 248 insertions, 0 deletions
diff --git a/dev-lua/alt-getopt/Manifest b/dev-lua/alt-getopt/Manifest
new file mode 100644
index 0000000..033029a
--- /dev/null
+++ b/dev-lua/alt-getopt/Manifest
@@ -0,0 +1 @@
+DIST lua-alt-getopt-0.7.0.tar.gz 4720 SHA256 c0d5fdb6f056bf03b743950acda6a1f37b20006d683637e6317270ff3387104e SHA512 379db696180e2bbb6e472ebe56e921c9736ee89ad673b296d0e580f100617a10dd5b44fdd665298ac87a44bbf8b5c330696653ec6d62ccaebc22120debf3c91f WHIRLPOOL 3ac4834eb85cff8ce2584d62a0811d341164414fbd0e33d7b4c703ec3f91f2649d3d24b4e89e8c694e90ec43e3c1ae3ffa9a931a2d267ebf7d6d1504073dbea1
diff --git a/dev-lua/alt-getopt/alt-getopt-0.7.0.ebuild b/dev-lua/alt-getopt/alt-getopt-0.7.0.ebuild
new file mode 100644
index 0000000..56d55ff
--- /dev/null
+++ b/dev-lua/alt-getopt/alt-getopt-0.7.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: This ebuild is from Lua overlay; Bumped by mva; $
+
+EAPI="5"
+
+inherit base toolchain-funcs
+
+DESCRIPTION="Lua bindings to getopt_long"
+HOMEPAGE="http://luaforge.net/projects/alt-getopt"
+SRC_URI="mirror://luaforge/${PN}/${PN}/${PN}-${PV}/lua-${PN}-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="x86 amd64"
+IUSE="luajit"
+
+RDEPEND="
+ !luajit? ( >=dev-lang/lua-5.1 )
+ luajit? ( dev-lang/luajit:2 )
+"
+DEPEND="
+ ${RDEPEND}
+ dev-util/pkgconfig
+"
+
+DOCS=( "README" )
+
+S="${WORKDIR}/lua-${P}"
+
+src_compile() {
+ :
+}
+
+src_install() {
+ local lua=lua;
+ use luajit && lua=luajit;
+
+ insinto "$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD ${lua})"
+ doins alt_getopt.lua
+
+ dobin alt_getopt
+
+ base_src_install_docs
+} \ No newline at end of file
diff --git a/dev-lua/alt-getopt/metadata.xml b/dev-lua/alt-getopt/metadata.xml
new file mode 100644
index 0000000..23da526
--- /dev/null
+++ b/dev-lua/alt-getopt/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>mva@mva.name</email>
+ <description>
+ If you have any issues, please contact me, or try to find me in IRC on Freenode, OFTC or RusNet.
+ </description>
+ <name>Vadim A. Misbakh-Soloviov</name>
+</maintainer>
+<longdescription>FIXME</longdescription>
+<use>
+</use>
+</pkgmetadata>
diff --git a/dev-lua/ansicolors/ansicolors-9999.ebuild b/dev-lua/ansicolors/ansicolors-9999.ebuild
new file mode 100644
index 0000000..6f2982c
--- /dev/null
+++ b/dev-lua/ansicolors/ansicolors-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: This ebuild is from Lua overlay; Bumped by mva; $
+
+EAPI="5"
+
+inherit base toolchain-funcs git-r3
+
+DESCRIPTION="A simple Lua function for printing to the console in color."
+HOMEPAGE="https://github.com/kikito/ansicolors.lua"
+SRC_URI=""
+
+EGIT_REPO_URI="https://github.com/kikito/ansicolors.lua"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+IUSE="luajit"
+
+RDEPEND="
+ !luajit? ( >=dev-lang/lua-5.1 )
+ luajit? ( dev-lang/luajit:2 )
+"
+DEPEND="
+ ${RDEPEND}
+ dev-util/pkgconfig
+"
+
+HTML_DOCS=( "README.textile" )
+
+src_install() {
+ local lua=lua;
+ use luajit && lua=luajit;
+
+ insinto "$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD ${lua})"
+ doins -r ansicolors.lua
+
+ base_src_install_docs
+} \ No newline at end of file
diff --git a/dev-lua/ansicolors/metadata.xml b/dev-lua/ansicolors/metadata.xml
new file mode 100644
index 0000000..23da526
--- /dev/null
+++ b/dev-lua/ansicolors/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>mva@mva.name</email>
+ <description>
+ If you have any issues, please contact me, or try to find me in IRC on Freenode, OFTC or RusNet.
+ </description>
+ <name>Vadim A. Misbakh-Soloviov</name>
+</maintainer>
+<longdescription>FIXME</longdescription>
+<use>
+</use>
+</pkgmetadata>
diff --git a/dev-lua/lapis/lapis-9999.ebuild b/dev-lua/lapis/lapis-9999.ebuild
new file mode 100644
index 0000000..c959d04
--- /dev/null
+++ b/dev-lua/lapis/lapis-9999.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: This ebuild is from Lua overlay; Bumped by mva; $
+
+EAPI="5"
+
+inherit base toolchain-funcs git-r3
+
+DESCRIPTION="A web framework for Lua/MoonScript."
+HOMEPAGE="https://github.com/leafo/lapis"
+SRC_URI=""
+
+EGIT_REPO_URI="https://github.com/leafo/lapis"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+IUSE="luajit moonscript"
+
+RDEPEND="
+ !luajit? ( >=dev-lang/lua-5.1 )
+ luajit? ( dev-lang/luajit:2 )
+ moonscript? ( dev-lua/moonscript )
+ dev-lua/ansicolors
+ dev-lua/luasocket
+ dev-lua/luacrypto
+ dev-lua/lua-cjson
+ dev-lua/lpeg
+ dev-lua/rds-parser
+ dev-lua/resty-upload
+"
+DEPEND="
+ ${RDEPEND}
+ dev-util/pkgconfig
+"
+
+HTML_DOCS=( "docs/" "README.md" )
+
+src_compile() {
+ emake build
+}
+
+src_install() {
+ local lua=lua;
+ use luajit && lua=luajit;
+
+ use moonscript || find "${S}" -type -name '*.moon' -delete
+
+ insinto "$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD ${lua})"
+ doins -r lapis
+
+ dobin bin/lapis
+
+ use moonscript && doins lapis.moon
+
+ base_src_install_docs
+} \ No newline at end of file
diff --git a/dev-lua/lapis/metadata.xml b/dev-lua/lapis/metadata.xml
new file mode 100644
index 0000000..23da526
--- /dev/null
+++ b/dev-lua/lapis/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>mva@mva.name</email>
+ <description>
+ If you have any issues, please contact me, or try to find me in IRC on Freenode, OFTC or RusNet.
+ </description>
+ <name>Vadim A. Misbakh-Soloviov</name>
+</maintainer>
+<longdescription>FIXME</longdescription>
+<use>
+</use>
+</pkgmetadata>
diff --git a/dev-lua/moonscript/metadata.xml b/dev-lua/moonscript/metadata.xml
new file mode 100644
index 0000000..23da526
--- /dev/null
+++ b/dev-lua/moonscript/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>mva@mva.name</email>
+ <description>
+ If you have any issues, please contact me, or try to find me in IRC on Freenode, OFTC or RusNet.
+ </description>
+ <name>Vadim A. Misbakh-Soloviov</name>
+</maintainer>
+<longdescription>FIXME</longdescription>
+<use>
+</use>
+</pkgmetadata>
diff --git a/dev-lua/moonscript/moonscript-9999.ebuild b/dev-lua/moonscript/moonscript-9999.ebuild
new file mode 100644
index 0000000..57e2e70
--- /dev/null
+++ b/dev-lua/moonscript/moonscript-9999.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: This ebuild is from Lua overlay; Bumped by mva; $
+
+EAPI="5"
+
+inherit base toolchain-funcs git-r3
+
+DESCRIPTION="A programmer friendly language that compiles into Lua."
+HOMEPAGE="https://github.com/leafo/moonscript"
+SRC_URI=""
+
+EGIT_REPO_URI="https://github.com/leafo/moonscript"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+IUSE="luajit +inotify"
+
+RDEPEND="
+ !luajit? ( >=dev-lang/lua-5.1 )
+ luajit? ( dev-lang/luajit:2 )
+ dev-lua/lpeg
+ dev-lua/luafilesystem
+ dev-lua/alt-getopt
+ inotify? ( dev-lua/linotify )
+"
+DEPEND="
+ ${RDEPEND}
+ dev-util/pkgconfig
+"
+
+HTML_DOCS=( "docs/" "README.md" )
+
+src_compile() {
+ emake compile
+}
+
+src_install() {
+ local lua=lua;
+ use luajit && lua=luajit;
+
+ insinto "$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD ${lua})"
+ doins -r moon.lua moonscript.lua moon moonscript
+
+ dobin bin/moon bin/moonc
+
+ base_src_install_docs
+} \ No newline at end of file
diff --git a/profiles/thirdpartymirrors b/profiles/thirdpartymirrors
new file mode 100644
index 0000000..1f22a9d
--- /dev/null
+++ b/profiles/thirdpartymirrors
@@ -0,0 +1 @@
+luaforge http://files.luaforge.net/releases/ \ No newline at end of file