summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lua/lua-std-debug/lua-std-debug-9999.ebuild')
-rw-r--r--dev-lua/lua-std-debug/lua-std-debug-9999.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-lua/lua-std-debug/lua-std-debug-9999.ebuild b/dev-lua/lua-std-debug/lua-std-debug-9999.ebuild
new file mode 100644
index 0000000..a2f520f
--- /dev/null
+++ b/dev-lua/lua-std-debug/lua-std-debug-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+VCS="git"
+GITHUB_A="lua-stdlib"
+GITHUB_PN="_${PN#lua-std-}"
+
+inherit lua
+
+DESCRIPTION="Debug Hints Library"
+HOMEPAGE="https://github.com/lua-stdlib/_debug"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+IUSE="doc"
+
+lua_add_bdepend "doc? ( dev-lua/ldoc )"
+
+HTML_DOCS=(doc/.)
+DOCS=(README.md NEWS.md)
+
+all_lua_prepare() {
+ lua_default
+}
+
+each_lua_compile() {
+ if [[ "${PV}" == "9999" ]]; then
+ ver="git:$(git rev-parse --short @):${LUA_IMPL}"
+ fi
+ lua_default
+}
+
+each_lua_install() {
+ dolua lib/std
+}