summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-engines/love/love-0.9.2.ebuild')
-rw-r--r--games-engines/love/love-0.9.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/games-engines/love/love-0.9.2.ebuild b/games-engines/love/love-0.9.2.ebuild
new file mode 100644
index 0000000..2b5b855
--- /dev/null
+++ b/games-engines/love/love-0.9.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: This ebuild is from Lua overlay; Bumped by mva; $
+
+EAPI="5"
+
+inherit games
+
+DESCRIPTION="An *awesome* framework you can use to make 2D games in Lua."
+HOMEPAGE="http://love2d.org/"
+SRC_URI="http://bitbucket.org/rude/love/downloads/${P}-linux-src.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="luajit"
+
+RDEPEND="
+ dev-games/physfs
+ virtual/lua[luajit=]
+ media-libs/devil[mng,tiff]
+ media-libs/freetype
+ media-libs/libmodplug
+ media-libs/libsdl[joystick,opengl]
+ media-libs/libvorbis
+ media-libs/openal
+ media-sound/mpg123
+ virtual/opengl
+"
+DEPEND="
+ ${RDEPEND}
+ media-libs/libmng
+ media-libs/tiff
+"
+
+S=${WORKDIR}/${PN}-HEAD
+
+DOCS=( "readme.txt" "changes.txt" )