aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Lezcano <daniel.lezcano@free.fr>2010-05-12 23:44:28 +0200
committerDaniel Lezcano <dlezcano@fr.ibm.com>2010-05-12 23:44:28 +0200
commit196db713a9ab0479d1e695aa428577abedcbfa58 (patch)
treea6c66d48062d8fe89654d14a83ad935a86247cbd /configure.ac
parentwhitespace cleanup in configure.ac (diff)
downloadlxc-196db713a9ab0479d1e695aa428577abedcbfa58.tar.gz
lxc-196db713a9ab0479d1e695aa428577abedcbfa58.tar.bz2
lxc-196db713a9ab0479d1e695aa428577abedcbfa58.zip
add a configure option to set a rootfs mount point
Add a configure option to set a mount point path when using a rootfs, that will replace the actual behavior which creates uneeded /tmp/lxc** directories. Signed-off-by: Daniel Lezcano <dlezcano@fr.ibm.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c6cac11..46e8ff7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -47,12 +47,21 @@ AC_ARG_WITH([config-path],
[lxc configuration repository path]
)], [], [with_config_path="${localstatedir}/lib/lxc"])
+AC_ARG_WITH([rootfs-path],
+ [AC_HELP_STRING(
+ [--with-rootfs-path=dir],
+ [lxc rootfs mount point]
+ )], [], [with_rootfs_path="${libdir}/lxc"])
+
AS_AC_EXPAND(LXC_GENERATE_DATE, "$(date)")
AS_AC_EXPAND(LXCPATH, "${with_config_path}")
+AS_AC_EXPAND(LXCROOTFSMOUNT, "${with_rootfs_path}")
AH_TEMPLATE([LXCPATH], [lxc configuration repository])
AH_TEMPLATE([LXCLIBEXECDIR], [lxc executable library path])
+AH_TEMPLATE([LXCROOTFSMOUNT], [lxc default rootfs mount point])
AC_DEFINE_UNQUOTED(LXCPATH, "$LXCPATH")
AC_DEFINE_UNQUOTED(LXCLIBEXECDIR, "$LIBEXECDIR")
+AC_DEFINE_UNQUOTED(LXCROOTFSMOUNT, "$LXCROOTFSMOUNT")
AC_CHECK_HEADERS([linux/netlink.h linux/genetlink.h],
[],