aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-31 01:31:20 +0100
committerSam James <sam@gentoo.org>2023-05-31 01:31:23 +0100
commit07e8f090c6b07aee3c4853c27694d18a198d46d7 (patch)
treee1898366b1fb0697f39fb4ede5c307225fdbb711
parentapp-emulation/libvirt: treeclean (diff)
downloadmusl-07e8f090c6b07aee3c4853c27694d18a198d46d7.tar.gz
musl-07e8f090c6b07aee3c4853c27694d18a198d46d7.tar.bz2
musl-07e8f090c6b07aee3c4853c27694d18a198d46d7.zip
sys-devel/gdb: treeclean
::gentoo works fine. Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-devel/gdb/Manifest1
-rw-r--r--sys-devel/gdb/files/gdb-8.3.1-verbose-build.patch13
-rw-r--r--sys-devel/gdb/files/musl-signals.patch16
-rw-r--r--sys-devel/gdb/files/ppc-musl.patch93
-rw-r--r--sys-devel/gdb/files/ppc-ptregs.patch10
-rw-r--r--sys-devel/gdb/gdb-10.1.ebuild261
-rw-r--r--sys-devel/gdb/metadata.xml21
7 files changed, 0 insertions, 415 deletions
diff --git a/sys-devel/gdb/Manifest b/sys-devel/gdb/Manifest
deleted file mode 100644
index 8fa3bb78..00000000
--- a/sys-devel/gdb/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST gdb-10.1.tar.xz 21507112 BLAKE2B 69d79cd667ecb6e936b41a03817ade5dd9b761f97bc123d668b5f968d123c37d048fc8ec1289151e989f01bb01a43cc3d8b5b54f1807f1e3eb5f43e6bf0aa55b SHA512 0dc54380435c6853db60f1e388b94836d294dfa9ad7f518385a27db4edd03cb970f8717d5f1e9c9a0d4a33d7fcf91bc2e5d6c9cf9e4b561dcc74e65b806c1537
diff --git a/sys-devel/gdb/files/gdb-8.3.1-verbose-build.patch b/sys-devel/gdb/files/gdb-8.3.1-verbose-build.patch
deleted file mode 100644
index 06aa6084..00000000
--- a/sys-devel/gdb/files/gdb-8.3.1-verbose-build.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Enable verbose build. By default gdb ignores even --disable-silent-rules.
-Override verbosity back to non-silent.
-
-https://bugs.gentoo.org/695936
---- a/gdb/silent-rules.mk
-+++ b/gdb/silent-rules.mk
-@@ -1,5 +1,4 @@
--# If V is undefined or V=0 is specified, use the silent/verbose/compact mode.
--V ?= 0
-+V ?= 1
- ifeq ($(V),0)
- ECHO_CXX = @echo " CXX $@";
- ECHO_CXXLD = @echo " CXXLD $@";
diff --git a/sys-devel/gdb/files/musl-signals.patch b/sys-devel/gdb/files/musl-signals.patch
deleted file mode 100644
index e04ed0a1..00000000
--- a/sys-devel/gdb/files/musl-signals.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- a/gdbsupport/signals.cc 2020-02-08 12:50:14.000000000 +0000
-+++ b/gdbsupport/signals.cc 2020-02-11 13:08:56.482694697 +0000
-@@ -31,6 +31,13 @@
- _available_ realtime signal, not the lowest supported; glibc takes
- several for its own use. */
-
-+#ifndef __SIGRTMIN
-+# define __SIGRTMIN 32
-+#endif
-+#ifndef __SIGRTMAX
-+# define __SIGRTMAX _NSIG
-+#endif
-+
- #ifndef REALTIME_LO
- # if defined(__SIGRTMIN)
- # define REALTIME_LO __SIGRTMIN
diff --git a/sys-devel/gdb/files/ppc-musl.patch b/sys-devel/gdb/files/ppc-musl.patch
deleted file mode 100644
index 70cfa18e..00000000
--- a/sys-devel/gdb/files/ppc-musl.patch
+++ /dev/null
@@ -1,93 +0,0 @@
---- a/gdb/nat/ppc-linux.h
-+++ b/gdb/nat/ppc-linux.h
-@@ -18,7 +18,90 @@
- #ifndef PPC_LINUX_H
- #define PPC_LINUX_H 1
-
-+#if defined(__GLIBC__) || defined(__UCLIBC__)
- #include <asm/ptrace.h>
-+#else // Musl
-+// Do not include ptrace.h from Linux headers and since
-+// Musl does not define PT_*, define them:
-+
-+#define PT_R0 0
-+#define PT_R1 1
-+#define PT_R2 2
-+#define PT_R3 3
-+#define PT_R4 4
-+#define PT_R5 5
-+#define PT_R6 6
-+#define PT_R7 7
-+#define PT_R8 8
-+#define PT_R9 9
-+#define PT_R10 10
-+#define PT_R11 11
-+#define PT_R12 12
-+#define PT_R13 13
-+#define PT_R14 14
-+#define PT_R15 15
-+#define PT_R16 16
-+#define PT_R17 17
-+#define PT_R18 18
-+#define PT_R19 19
-+#define PT_R20 20
-+#define PT_R21 21
-+#define PT_R22 22
-+#define PT_R23 23
-+#define PT_R24 24
-+#define PT_R25 25
-+#define PT_R26 26
-+#define PT_R27 27
-+#define PT_R28 28
-+#define PT_R29 29
-+#define PT_R30 30
-+#define PT_R31 31
-+
-+#define PT_NIP 32
-+#define PT_MSR 33
-+#define PT_ORIG_R3 34
-+#define PT_CTR 35
-+#define PT_LNK 36
-+#define PT_XER 37
-+#define PT_CCR 38
-+#ifndef __powerpc64__
-+#define PT_MQ 39
-+#else
-+#define PT_SOFTE 39
-+#endif
-+#define PT_TRAP 40
-+#define PT_DAR 41
-+#define PT_DSISR 42
-+#define PT_RESULT 43
-+#define PT_DSCR 44
-+#define PT_REGS_COUNT 44
-+
-+#define PT_FPR0 48 /* each FP reg occupies 2 slots in this space */
-+
-+#ifndef __powerpc64__
-+
-+#define PT_FPR31 (PT_FPR0 + 2*31)
-+#define PT_FPSCR (PT_FPR0 + 2*32 + 1)
-+
-+#else /* __powerpc64__ */
-+
-+#define PT_FPSCR (PT_FPR0 + 32) /* each FP reg occupies 1 slot in 64-bit space */
-+
-+
-+#define PT_VR0 82 /* each Vector reg occupies 2 slots in 64-bit */
-+#define PT_VSCR (PT_VR0 + 32*2 + 1)
-+#define PT_VRSAVE (PT_VR0 + 33*2)
-+
-+
-+/*
-+ * Only store first 32 VSRs here. The second 32 VSRs in VR0-31
-+ */
-+#define PT_VSR0 150 /* each VSR reg occupies 2 slots in 64-bit */
-+#define PT_VSR31 (PT_VSR0 + 2*31)
-+#endif /* __powerpc64__ */
-+
-+#endif // Libc
-+
- #include <asm/cputable.h>
-
- /* This sometimes isn't defined. */
diff --git a/sys-devel/gdb/files/ppc-ptregs.patch b/sys-devel/gdb/files/ppc-ptregs.patch
deleted file mode 100644
index da131ab4..00000000
--- a/sys-devel/gdb/files/ppc-ptregs.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/gdbserver/linux-ppc-low.cc
-+++ b/gdbserver/linux-ppc-low.cc
-@@ -21,7 +21,6 @@
- #include "linux-low.h"
-
- #include <elf.h>
--#include <asm/ptrace.h>
-
- #include "nat/ppc-linux.h"
- #include "linux-ppc-tdesc.h"
diff --git a/sys-devel/gdb/gdb-10.1.ebuild b/sys-devel/gdb/gdb-10.1.ebuild
deleted file mode 100644
index 44ac1261..00000000
--- a/sys-devel/gdb/gdb-10.1.ebuild
+++ /dev/null
@@ -1,261 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
-
-inherit eutils flag-o-matic python-single-r1 toolchain-funcs
-
-export CTARGET=${CTARGET:-${CHOST}}
-if [[ ${CTARGET} == ${CHOST} ]] ; then
- if [[ ${CATEGORY} == cross-* ]] ; then
- export CTARGET=${CATEGORY#cross-}
- fi
-fi
-is_cross() { [[ ${CHOST} != ${CTARGET} ]] ; }
-
-case ${PV} in
-9999*)
- # live git tree
- EGIT_REPO_URI="https://sourceware.org/git/binutils-gdb.git"
- inherit git-r3
- SRC_URI=""
- ;;
-*.*.50.2???????)
- # weekly snapshots
- SRC_URI="ftp://sourceware.org/pub/gdb/snapshots/current/gdb-weekly-${PV}.tar.xz"
- ;;
-*)
- # Normal upstream release
- SRC_URI="mirror://gnu/gdb/${P}.tar.xz
- ftp://sourceware.org/pub/gdb/releases/${P}.tar.xz"
- ;;
-esac
-
-PATCH_VER=""
-PATCH_DEV=""
-DESCRIPTION="GNU debugger"
-HOMEPAGE="https://sourceware.org/gdb/"
-SRC_URI="${SRC_URI}
- ${PATCH_DEV:+https://dev.gentoo.org/~${PATCH_DEV}/distfiles/${P}-patches-${PATCH_VER}.tar.xz}
- ${PATCH_VER:+mirror://gentoo/${P}-patches-${PATCH_VER}.tar.xz}
-"
-
-LICENSE="GPL-2 LGPL-2"
-SLOT="0"
-if [[ ${PV} != 9999* ]] ; then
- KEYWORDS="amd64 arm arm64 ~mips ppc ppc64 x86"
-fi
-IUSE="cet lzma multitarget nls +python +server source-highlight test vanilla xml xxhash"
-REQUIRED_USE="
- python? ( ${PYTHON_REQUIRED_USE} )
-"
-
-# ia64 kernel crashes when gdb testsuite is running
-RESTRICT="
- ia64? ( test )
-
- !test? ( test )
-"
-
-RDEPEND="
- dev-libs/mpfr:0=
- >=sys-libs/ncurses-5.2-r2:0=
- >=sys-libs/readline-7:0=
- sys-libs/zlib
- lzma? ( app-arch/xz-utils )
- python? ( ${PYTHON_DEPS} )
- xml? ( dev-libs/expat )
- source-highlight? (
- dev-util/source-highlight
- )
- xxhash? (
- dev-libs/xxhash
- )
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- app-arch/xz-utils
- sys-apps/texinfo
- app-alternatives/yacc
- nls? ( sys-devel/gettext )
- test? ( dev-util/dejagnu )
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-8.3.1-verbose-build.patch
- "${FILESDIR}"/musl-signals.patch
- "${FILESDIR}"/ppc-musl.patch
- "${FILESDIR}"/ppc-ptregs.patch
-
-)
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- default
-
- strip-linguas -u bfd/po opcodes/po
- export CC_FOR_BUILD=$(tc-getBUILD_CC)
-
- # avoid using ancient termcap from host on Prefix systems
- sed -i -e 's/termcap tinfow/tinfow/g' \
- gdb/configure{.ac,} || die
-}
-
-gdb_branding() {
- printf "Gentoo ${PV} "
- if ! use vanilla && [[ -n ${PATCH_VER} ]] ; then
- printf "p${PATCH_VER}"
- else
- printf "vanilla"
- fi
- [[ -n ${EGIT_COMMIT} ]] && printf " ${EGIT_COMMIT}"
-}
-
-src_configure() {
- strip-unsupported-flags
-
- local myconf=(
- # portage's econf() does not detect presence of --d-d-t
- # because it greps only top-level ./configure. But not
- # gnulib's or gdb's configure.
- --disable-dependency-tracking
-
- --with-pkgversion="$(gdb_branding)"
- --with-bugurl='https://bugs.gentoo.org/'
- --disable-werror
- # Disable modules that are in a combined binutils/gdb tree. #490566
- --disable-{binutils,etc,gas,gold,gprof,ld}
-
- # avoid automagic dependency on (currently prefix) systems
- # systems with debuginfod library, bug #754753
- --without-debuginfod
-
- # Allow user to opt into CET for host libraries.
- # Ideally we would like automagic-or-disabled here.
- # But the check does not quite work on i686: bug #760926.
- $(use_enable cet)
- )
- local sysroot="${EPREFIX}/usr/${CTARGET}"
- is_cross && myconf+=(
- --with-sysroot="${sysroot}"
- --includedir="${sysroot}/usr/include"
- --with-gdb-datadir="\${datadir}/gdb/${CTARGET}"
- )
-
- # gdbserver only works for native targets (CHOST==CTARGET).
- # it also doesn't support all targets, so rather than duplicate
- # the target list (which changes between versions), use the
- # "auto" value when things are turned on, which is triggered
- # whenever no --enable or --disable is given
- if is_cross || use !server ; then
- myconf+=( --disable-gdbserver )
- fi
-
- myconf+=(
- --enable-64-bit-bfd
- --disable-install-libbfd
- --disable-install-libiberty
- # Disable guile for now as it requires guile-2.x #562902
- --without-guile
- --enable-obsolete
- # This only disables building in the readline subdir.
- # For gdb itself, it'll use the system version.
- --disable-readline
- --with-system-readline
- # This only disables building in the zlib subdir.
- # For gdb itself, it'll use the system version.
- --without-zlib
- --with-system-zlib
- --with-separate-debug-dir="${EPREFIX}"/usr/lib/debug
- $(use_with xml expat)
- $(use_with lzma)
- $(use_enable nls)
- $(use_enable source-highlight)
- $(use multitarget && echo --enable-targets=all)
- $(use_with python python "${EPYTHON}")
- $(use_with xxhash)
- )
- if use sparc-solaris || use x86-solaris ; then
- # disable largefile support
- # https://sourceware.org/ml/gdb-patches/2014-12/msg00058.html
- myconf+=( --disable-largefile )
- fi
-
- # source-highlight is detected with pkg-config: bug #716558
- export ac_cv_path_pkg_config_prog_path="$(tc-getPKG_CONFIG)"
-
- econf "${myconf[@]}"
-}
-
-src_install() {
- default
- find "${ED}"/usr -name libiberty.a -delete || die
-
- # Delete translations that conflict with binutils-libs. #528088
- # Note: Should figure out how to store these in an internal gdb dir.
- if use nls ; then
- find "${ED}" \
- -regextype posix-extended -regex '.*/(bfd|opcodes)[.]g?mo$' \
- -delete || die
- fi
-
- # Don't install docs when building a cross-gdb
- if [[ ${CTARGET} != ${CHOST} ]] ; then
- rm -rf "${ED}"/usr/share/{doc,info,locale} || die
- local f
- for f in "${ED}"/usr/share/man/*/* ; do
- if [[ ${f##*/} != ${CTARGET}-* ]] ; then
- mv "${f}" "${f%/*}/${CTARGET}-${f##*/}" || die
- fi
- done
- return 0
- fi
- # Install it by hand for now:
- # https://sourceware.org/ml/gdb-patches/2011-12/msg00915.html
- # Only install if it exists due to the twisted behavior (see
- # notes in src_configure above).
- [[ -e gdbserver/gdbreplay ]] && dobin gdbserver/gdbreplay
-
- docinto gdb
- dodoc gdb/CONTRIBUTE gdb/README gdb/MAINTAINERS \
- gdb/NEWS gdb/ChangeLog gdb/PROBLEMS
- docinto sim
- dodoc sim/{ChangeLog,MAINTAINERS,README-HACKING}
- if use server ; then
- docinto gdbserver
- dodoc gdbserver/{ChangeLog,README}
- fi
-
- if [[ -n ${PATCH_VER} ]] ; then
- dodoc "${WORKDIR}"/extra/gdbinit.sample
- fi
-
- # Remove shared info pages
- rm -f "${ED}"/usr/share/info/{annotate,bfd,configure,standards}.info*
-
- # gcore is part of ubin on freebsd
- if [[ ${CHOST} == *-freebsd* ]]; then
- rm "${ED}"/usr/bin/gcore || die
- fi
-
- if use python; then
- python_optimize "${ED}"/usr/share/gdb/python/gdb
- fi
-}
-
-pkg_postinst() {
- # portage sucks and doesnt unmerge files in /etc
- rm -vf "${EROOT}"/etc/skel/.gdbinit
-
- if use prefix && [[ ${CHOST} == *-darwin* ]] ; then
- ewarn "gdb is unable to get a mach task port when installed by Prefix"
- ewarn "Portage, unprivileged. To make gdb fully functional you'll"
- ewarn "have to perform the following steps:"
- ewarn " % sudo chgrp procmod ${EPREFIX}/usr/bin/gdb"
- ewarn " % sudo chmod g+s ${EPREFIX}/usr/bin/gdb"
- fi
-}
diff --git a/sys-devel/gdb/metadata.xml b/sys-devel/gdb/metadata.xml
deleted file mode 100644
index bcceccef..00000000
--- a/sys-devel/gdb/metadata.xml
+++ /dev/null
@@ -1,21 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
- <email>toolchain@gentoo.org</email>
- <name>Gentoo Toolchain Project</name>
-</maintainer>
-<use>
- <flag name="cet">Enable Intel Control-flow Enforcement Technology.</flag>
- <flag name="lzma">Support lzma compression in ELF debug info</flag>
- <flag name="multitarget">Support all known targets in one gdb binary</flag>
- <flag name="python">Enable support for the new internal scripting language, as well as extended pretty printers</flag>
- <flag name="server">Install the "gdbserver" program (useful for embedded/remote targets)</flag>
- <flag name="source-highlight">Enable listing highlighting via <pkg>dev-util/source-highlight</pkg></flag>
- <flag name="xml">Support parsing XML data files needed (at least) for cpu features, memory maps, and syscall tracing</flag>
- <flag name="xxhash">Use <pkg>dev-libs/xxhash</pkg> to speed up internal hashing.</flag>
-</use>
-<upstream>
- <remote-id type="cpe">cpe:/a:gnu:gdb</remote-id>
-</upstream>
-</pkgmetadata>