aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-31 01:41:26 +0100
committerSam James <sam@gentoo.org>2023-05-31 01:41:26 +0100
commit54bb5c1226c0574b2a8b446052165b41e1aaeeed (patch)
tree2bdcf35283e973bd680a6ecab0b86f063f9cd08d
parentx11-libs/libva-vdpau-driver: treeclean (diff)
downloadmusl-54bb5c1226c0574b2a8b446052165b41e1aaeeed.tar.gz
musl-54bb5c1226c0574b2a8b446052165b41e1aaeeed.tar.bz2
musl-54bb5c1226c0574b2a8b446052165b41e1aaeeed.zip
sys-libs/efivar: drop 30, 31, 32
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-libs/efivar/Manifest2
-rw-r--r--sys-libs/efivar/efivar-30.ebuild54
-rw-r--r--sys-libs/efivar/efivar-31.ebuild42
-rw-r--r--sys-libs/efivar/efivar-32.ebuild43
4 files changed, 0 insertions, 141 deletions
diff --git a/sys-libs/efivar/Manifest b/sys-libs/efivar/Manifest
index 610b2f2d..9116eb42 100644
--- a/sys-libs/efivar/Manifest
+++ b/sys-libs/efivar/Manifest
@@ -1,3 +1 @@
-DIST efivar-30.tar.bz2 73202 BLAKE2B 6b146cb6d664e3419361e72ab6fd1578522e7fc219613ae21566cb40a700fe70f18750cc753338faca2ad078e2bc933fb33a3a4cdfb148eabb0fc71b1319fb71 SHA512 0a6d7175762011c3fc67b531d3d19a45e82195c729b9ff498be02b3a6a73f6c3c4f9e14a27470c6744b741d7d54db9ef24c7882639af25fca1034b7b9f641b39
-DIST efivar-31.tar.bz2 82404 BLAKE2B d339aa8ab7dcd6a60cb067fccfbc2c42407fba211ca96eb39f227d57e9403462505940f427651dfaffa8272c9edfe70898f181b9f6ecddbae4745eb3262de949 SHA512 5055f690fd99cf59895dcf3d11103494d917d4923567626f0bee816ea5e4dd56cec23627ede5f21bdc57b7306522471ad19cc8ab22ae94591dbd1925c084f163
DIST efivar-32.tar.gz 108102 BLAKE2B 7f9d27433b40ec6c044ab34ccc697001ad23e39a46862d2e04db0f9a3dfc26ae53b46a3c3a8c957bf76df0969710f78249f72f7bf38e67c0aa902034a07acf8f SHA512 e73eae182fd645183dfe587591a286670ee1123a113e3e19e4070fb910ab7794e320defdc0597540df7664947f2a0497abbb763a19b4dfa40511a512c7f3e490
diff --git a/sys-libs/efivar/efivar-30.ebuild b/sys-libs/efivar/efivar-30.ebuild
deleted file mode 100644
index 0cb3fd08..00000000
--- a/sys-libs/efivar/efivar-30.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit flag-o-matic toolchain-funcs
-
-DESCRIPTION="Tools and library to manipulate EFI variables"
-HOMEPAGE="https://github.com/rhinstaller/efivar"
-SRC_URI="https://github.com/rhinstaller/efivar/releases/download/${PV}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0/1"
-KEYWORDS="amd64 x86"
-
-RDEPEND="dev-libs/popt"
-DEPEND="${RDEPEND}
- >=sys-kernel/linux-headers-3.18
- virtual/pkgconfig
-"
-
-PATCHES=(
- "${FILESDIR}/0.23-musl.patch"
- "${FILESDIR}/27-strndupa.patch"
-)
-
-src_prepare() {
- default
- sed -i -e s/-Werror// gcc.specs || die
-}
-
-src_configure() {
- tc-export CC
-
- # https://github.com/rhinstaller/efivar/issues/64
- append-cflags -flto
-
- tc-ld-disable-gold
- export libdir="/usr/$(get_libdir)"
- unset LIBS # Bug 562004
-}
-
-src_compile() {
- # Avoid building static binary/libs
- opts=(
- BINTARGETS=efivar
- STATICLIBTARGETS=
- )
- emake "${opts[@]}"
-}
-
-src_install() {
- emake "${opts[@]}" DESTDIR="${D}" install
-}
diff --git a/sys-libs/efivar/efivar-31.ebuild b/sys-libs/efivar/efivar-31.ebuild
deleted file mode 100644
index 32e8bd8a..00000000
--- a/sys-libs/efivar/efivar-31.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit flag-o-matic toolchain-funcs
-
-DESCRIPTION="Tools and library to manipulate EFI variables"
-HOMEPAGE="https://github.com/rhinstaller/efivar"
-SRC_URI="https://github.com/rhinstaller/efivar/releases/download/${PV}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0/1"
-KEYWORDS="amd64 x86"
-
-RDEPEND="dev-libs/popt"
-DEPEND="${RDEPEND}
- >=sys-kernel/linux-headers-3.18
- virtual/pkgconfig
-"
-
-PATCHES=(
- "${FILESDIR}/0.23-musl.patch"
- "${FILESDIR}/27-strndupa.patch"
-)
-
-src_prepare() {
- default
- sed -i -e s/-Werror// gcc.specs || die
-}
-
-src_configure() {
- tc-export CC
- tc-ld-disable-gold
- export libdir="/usr/$(get_libdir)"
- unset LIBS # Bug 562004
-
- if [[ -n ${GCC_SPECS} ]]; then
- # The environment overrides the command line.
- GCC_SPECS+=":${S}/gcc.specs"
- fi
-}
diff --git a/sys-libs/efivar/efivar-32.ebuild b/sys-libs/efivar/efivar-32.ebuild
deleted file mode 100644
index 577eed75..00000000
--- a/sys-libs/efivar/efivar-32.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit flag-o-matic toolchain-funcs
-
-DESCRIPTION="Tools and library to manipulate EFI variables"
-HOMEPAGE="https://github.com/rhinstaller/efivar"
-#SRC_URI="https://github.com/rhinstaller/efivar/releases/download/${PV}/${P}.tar.bz2"
-SRC_URI="https://github.com/rhinstaller/efivar/archive/${PV}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0/1"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="dev-libs/popt"
-DEPEND="${RDEPEND}
- >=sys-kernel/linux-headers-3.18
- virtual/pkgconfig
-"
-
-PATCHES=(
- "${FILESDIR}/0.23-musl.patch"
- "${FILESDIR}/27-strndupa.patch"
-)
-
-src_prepare() {
- default
- sed -i -e s/-Werror// gcc.specs || die
-}
-
-src_configure() {
- tc-export CC
- tc-ld-disable-gold
- export libdir="/usr/$(get_libdir)"
- unset LIBS # Bug 562004
-
- if [[ -n ${GCC_SPECS} ]]; then
- # The environment overrides the command line.
- GCC_SPECS+=":${S}/gcc.specs"
- fi
-}