aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-31 01:44:05 +0100
committerSam James <sam@gentoo.org>2023-05-31 01:44:05 +0100
commit6c7026e235cb252fa3c75521b664dab35c544d03 (patch)
tree91b06ab64150fba15a1b9ca4c92a50626fd04f51
parentsys-apps/watchdog: drop 5.14 (diff)
downloadmusl-6c7026e235cb252fa3c75521b664dab35c544d03.tar.gz
musl-6c7026e235cb252fa3c75521b664dab35c544d03.tar.bz2
musl-6c7026e235cb252fa3c75521b664dab35c544d03.zip
sys-auth/elogind: treeclean
::gentoo works. Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-auth/elogind/Manifest2
-rw-r--r--sys-auth/elogind/elogind-246.10.ebuild153
-rw-r--r--sys-auth/elogind/elogind-246.9.2.ebuild153
-rw-r--r--sys-auth/elogind/files/0001-musl-mallinfo.patch36
-rw-r--r--sys-auth/elogind/files/elogind-241.4-broken-test.patch15
-rw-r--r--sys-auth/elogind/files/elogind-243.7-nodocs.patch29
-rw-r--r--sys-auth/elogind/files/elogind.conf.in7
-rw-r--r--sys-auth/elogind/files/elogind.init25
-rw-r--r--sys-auth/elogind/files/elogind.init-r127
-rw-r--r--sys-auth/elogind/metadata.xml17
10 files changed, 0 insertions, 464 deletions
diff --git a/sys-auth/elogind/Manifest b/sys-auth/elogind/Manifest
deleted file mode 100644
index 4eb0c703..00000000
--- a/sys-auth/elogind/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST elogind-246.10.tar.gz 1559256 BLAKE2B 17a8146ee08c8ccf167f25d89b1d4525050ed0b0baaad0d36924ad3c40ffc820ef1528b33557cf285ad06c9ac9c440137428c5a235a2acf563e56f2f8f07e208 SHA512 9db0f068ed94ec07bab4d764ccb38840af3d05a4b7c9c539721906f5381b509cb9a3cbfb0453a978210d306136368de6162578c600d522416ef2a7ac1b9f348b
-DIST elogind-246.9.2.tar.gz 1534982 BLAKE2B 428def0f577cb92c8167f4400a59093ebf738d14b449e0dc59f1aa59da2c0f781db62bffc4bea2649edbfcc06ff5799ab24243dfb580eaa12c5cf0c41be8fc17 SHA512 b50d319793307a425d7542626e8cf27e56fb5e5c75cca9519cd3f5a1e7c387c4179310b95fa083f8bd8172384f16c0e45e7000b313d2bcf84ed8aba98dc775c1
diff --git a/sys-auth/elogind/elogind-246.10.ebuild b/sys-auth/elogind/elogind-246.10.ebuild
deleted file mode 100644
index eeda3cb3..00000000
--- a/sys-auth/elogind/elogind-246.10.ebuild
+++ /dev/null
@@ -1,153 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-if [[ ${PV} = *9999* ]]; then
- EGIT_BRANCH="v241-stable"
- EGIT_REPO_URI="https://github.com/elogind/elogind.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
-fi
-
-inherit linux-info meson pam udev xdg-utils
-
-DESCRIPTION="The systemd project's logind, extracted to a standalone package"
-HOMEPAGE="https://github.com/elogind/elogind"
-
-LICENSE="CC0-1.0 LGPL-2.1+ public-domain"
-SLOT="0"
-IUSE="+acl audit debug doc +pam +policykit selinux"
-
-BDEPEND="
- app-text/docbook-xml-dtd:4.2
- app-text/docbook-xml-dtd:4.5
- app-text/docbook-xsl-stylesheets
- dev-util/gperf
- dev-util/intltool
- virtual/pkgconfig
-"
-DEPEND="
- audit? ( sys-process/audit )
- sys-apps/util-linux
- sys-libs/libcap
- virtual/libudev:=
- acl? ( sys-apps/acl )
- pam? ( sys-libs/pam )
- selinux? ( sys-libs/libselinux )
-"
-RDEPEND="${DEPEND}
- !sys-apps/systemd
-"
-PDEPEND="
- sys-apps/dbus
- policykit? ( sys-auth/polkit )
-"
-
-DOCS=( README.md src/libelogind/sd-bus/GVARIANT-SERIALIZATION )
-
-PATCHES=(
- "${FILESDIR}/${PN}-243.7-nodocs.patch"
- "${FILESDIR}/${PN}-241.4-broken-test.patch" # bug 699116
-)
-
-pkg_setup() {
- local CONFIG_CHECK="~CGROUPS ~EPOLL ~INOTIFY_USER ~SIGNALFD ~TIMERFD"
-
- use kernel_linux && linux-info_pkg_setup
-}
-
-src_prepare() {
- default
-
- if use elibc_musl ; then
- eapply "${FILESDIR}"/0001-musl-mallinfo.patch
- fi
-
- xdg_environment_reset
-}
-
-src_configure() {
- local rccgroupmode="$(grep rc_cgroup_mode ${EPREFIX}/etc/rc.conf | cut -d '"' -f 2)"
- local cgroupmode="legacy"
-
- if [[ "xhybrid" = "x${rccgroupmode}" ]] ; then
- cgroupmode="hybrid"
- elif [[ "xunified" = "x${rccgroupmode}" ]] ; then
- cgroupmode="unified"
- fi
-
- local emesonargs=(
- -Ddocdir="${EPREFIX}/usr/share/doc/${PF}"
- -Dhtmldir="${EPREFIX}/usr/share/doc/${PF}/html"
- -Dpamlibdir=$(getpam_mod_dir)
- -Dudevrulesdir="${EPREFIX}$(get_udevdir)"/rules.d
- --libdir="${EPREFIX}"/usr/$(get_libdir)
- -Drootlibdir="${EPREFIX}"/$(get_libdir)
- -Drootlibexecdir="${EPREFIX}"/$(get_libdir)/elogind
- -Drootprefix="${EPREFIX}/"
- -Dbashcompletiondir="${EPREFIX}/usr/share/bash-completion/completions"
- -Dman=auto
- -Dsmack=true
- -Dcgroup-controller=openrc
- -Ddefault-hierarchy=${cgroupmode}
- -Ddefault-kill-user-processes=false
- -Dacl=$(usex acl true false)
- -Daudit=$(usex audit true false)
- --buildtype $(usex debug debug release)
- -Dhtml=$(usex doc auto false)
- -Dpam=$(usex pam true false)
- -Dselinux=$(usex selinux true false)
- -Dutmp=$(usex elibc_musl false true)
- )
-
- meson_src_configure
-}
-
-src_install() {
- DOCS+=( src/libelogind/sd-bus/GVARIANT-SERIALIZATION )
-
- meson_src_install
-
- newinitd "${FILESDIR}"/${PN}.init-r1 ${PN}
-
- sed -e "s/@libdir@/$(get_libdir)/" "${FILESDIR}"/${PN}.conf.in > ${PN}.conf || die
- newconfd ${PN}.conf ${PN}
-}
-
-pkg_postinst() {
- if ! use pam; then
- ewarn "${PN} will not be managing user logins/seats without USE=\"pam\"!"
- ewarn "In other words, it will be useless for most applications."
- ewarn
- fi
- if ! use policykit; then
- ewarn "loginctl will not be able to perform privileged operations without"
- ewarn "USE=\"policykit\"! That means e.g. no suspend or hibernate."
- ewarn
- fi
- if [[ "$(rc-config list boot | grep elogind)" != "" ]]; then
- elog "elogind is currently started from boot runlevel."
- elif [[ "$(rc-config list default | grep elogind)" != "" ]]; then
- ewarn "elogind is currently started from default runlevel."
- ewarn "Please remove elogind from the default runlevel and"
- ewarn "add it to the boot runlevel by:"
- ewarn "# rc-update del elogind default"
- ewarn "# rc-update add elogind boot"
- else
- elog "elogind is currently not started from any runlevel."
- elog "You may add it to the boot runlevel by:"
- elog "# rc-update add elogind boot"
- elog
- elog "Alternatively, you can leave elogind out of any"
- elog "runlevel. It will then be started automatically"
- if use pam; then
- elog "when the first service calls it via dbus, or"
- elog "the first user logs into the system."
- else
- elog "when the first service calls it via dbus."
- fi
- fi
-}
diff --git a/sys-auth/elogind/elogind-246.9.2.ebuild b/sys-auth/elogind/elogind-246.9.2.ebuild
deleted file mode 100644
index c29a9403..00000000
--- a/sys-auth/elogind/elogind-246.9.2.ebuild
+++ /dev/null
@@ -1,153 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-if [[ ${PV} = *9999* ]]; then
- EGIT_BRANCH="v241-stable"
- EGIT_REPO_URI="https://github.com/elogind/elogind.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86"
-fi
-
-inherit linux-info meson pam udev xdg-utils
-
-DESCRIPTION="The systemd project's logind, extracted to a standalone package"
-HOMEPAGE="https://github.com/elogind/elogind"
-
-LICENSE="CC0-1.0 LGPL-2.1+ public-domain"
-SLOT="0"
-IUSE="+acl audit debug doc +pam +policykit selinux"
-
-BDEPEND="
- app-text/docbook-xml-dtd:4.2
- app-text/docbook-xml-dtd:4.5
- app-text/docbook-xsl-stylesheets
- dev-util/gperf
- dev-util/intltool
- virtual/pkgconfig
-"
-DEPEND="
- audit? ( sys-process/audit )
- sys-apps/util-linux
- sys-libs/libcap
- virtual/libudev:=
- acl? ( sys-apps/acl )
- pam? ( sys-libs/pam )
- selinux? ( sys-libs/libselinux )
-"
-RDEPEND="${DEPEND}
- !sys-apps/systemd
-"
-PDEPEND="
- sys-apps/dbus
- policykit? ( sys-auth/polkit )
-"
-
-DOCS=( README.md src/libelogind/sd-bus/GVARIANT-SERIALIZATION )
-
-PATCHES=(
- "${FILESDIR}/${PN}-243.7-nodocs.patch"
- "${FILESDIR}/${PN}-241.4-broken-test.patch" # bug 699116
-)
-
-pkg_setup() {
- local CONFIG_CHECK="~CGROUPS ~EPOLL ~INOTIFY_USER ~SIGNALFD ~TIMERFD"
-
- use kernel_linux && linux-info_pkg_setup
-}
-
-src_prepare() {
- default
-
- if use elibc_musl ; then
- eapply "${FILESDIR}"/0001-musl-mallinfo.patch
- fi
-
- xdg_environment_reset
-}
-
-src_configure() {
- local rccgroupmode="$(grep rc_cgroup_mode ${EPREFIX}/etc/rc.conf | cut -d '"' -f 2)"
- local cgroupmode="legacy"
-
- if [[ "xhybrid" = "x${rccgroupmode}" ]] ; then
- cgroupmode="hybrid"
- elif [[ "xunified" = "x${rccgroupmode}" ]] ; then
- cgroupmode="unified"
- fi
-
- local emesonargs=(
- -Ddocdir="${EPREFIX}/usr/share/doc/${PF}"
- -Dhtmldir="${EPREFIX}/usr/share/doc/${PF}/html"
- -Dpamlibdir=$(getpam_mod_dir)
- -Dudevrulesdir="${EPREFIX}$(get_udevdir)"/rules.d
- --libdir="${EPREFIX}"/usr/$(get_libdir)
- -Drootlibdir="${EPREFIX}"/$(get_libdir)
- -Drootlibexecdir="${EPREFIX}"/$(get_libdir)/elogind
- -Drootprefix="${EPREFIX}/"
- -Dbashcompletiondir="${EPREFIX}/usr/share/bash-completion/completions"
- -Dman=auto
- -Dsmack=true
- -Dcgroup-controller=openrc
- -Ddefault-hierarchy=${cgroupmode}
- -Ddefault-kill-user-processes=false
- -Dacl=$(usex acl true false)
- -Daudit=$(usex audit true false)
- --buildtype $(usex debug debug release)
- -Dhtml=$(usex doc auto false)
- -Dpam=$(usex pam true false)
- -Dselinux=$(usex selinux true false)
- -Dutmp=$(usex elibc_musl false true)
- )
-
- meson_src_configure
-}
-
-src_install() {
- DOCS+=( src/libelogind/sd-bus/GVARIANT-SERIALIZATION )
-
- meson_src_install
-
- newinitd "${FILESDIR}"/${PN}.init-r1 ${PN}
-
- sed -e "s/@libdir@/$(get_libdir)/" "${FILESDIR}"/${PN}.conf.in > ${PN}.conf || die
- newconfd ${PN}.conf ${PN}
-}
-
-pkg_postinst() {
- if ! use pam; then
- ewarn "${PN} will not be managing user logins/seats without USE=\"pam\"!"
- ewarn "In other words, it will be useless for most applications."
- ewarn
- fi
- if ! use policykit; then
- ewarn "loginctl will not be able to perform privileged operations without"
- ewarn "USE=\"policykit\"! That means e.g. no suspend or hibernate."
- ewarn
- fi
- if [[ "$(rc-config list boot | grep elogind)" != "" ]]; then
- elog "elogind is currently started from boot runlevel."
- elif [[ "$(rc-config list default | grep elogind)" != "" ]]; then
- ewarn "elogind is currently started from default runlevel."
- ewarn "Please remove elogind from the default runlevel and"
- ewarn "add it to the boot runlevel by:"
- ewarn "# rc-update del elogind default"
- ewarn "# rc-update add elogind boot"
- else
- elog "elogind is currently not started from any runlevel."
- elog "You may add it to the boot runlevel by:"
- elog "# rc-update add elogind boot"
- elog
- elog "Alternatively, you can leave elogind out of any"
- elog "runlevel. It will then be started automatically"
- if use pam; then
- elog "when the first service calls it via dbus, or"
- elog "the first user logs into the system."
- else
- elog "when the first service calls it via dbus."
- fi
- fi
-}
diff --git a/sys-auth/elogind/files/0001-musl-mallinfo.patch b/sys-auth/elogind/files/0001-musl-mallinfo.patch
deleted file mode 100644
index 41a85750..00000000
--- a/sys-auth/elogind/files/0001-musl-mallinfo.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-diff -Naur a/src/basic/selinux-util.c b/src/basic/selinux-util.c
---- a/src/basic/selinux-util.c 2021-03-13 17:08:40.496016258 -0500
-+++ b/src/basic/selinux-util.c 2021-03-13 17:10:54.928016323 -0500
-@@ -75,7 +75,6 @@
- int mac_selinux_init(void) {
- #if HAVE_SELINUX
- usec_t before_timestamp, after_timestamp;
-- struct mallinfo before_mallinfo, after_mallinfo;
- char timespan[FORMAT_TIMESPAN_MAX];
- int l;
-
-@@ -87,7 +86,6 @@
- if (!mac_selinux_use())
- return 0;
-
-- before_mallinfo = mallinfo();
- before_timestamp = now(CLOCK_MONOTONIC);
-
- label_hnd = selabel_open(SELABEL_CTX_FILE, NULL, 0);
-@@ -95,14 +93,9 @@
- return log_enforcing_errno(errno, "Failed to initialize SELinux labeling handle: %m");
-
- after_timestamp = now(CLOCK_MONOTONIC);
-- after_mallinfo = mallinfo();
--
-- l = after_mallinfo.uordblks > before_mallinfo.uordblks ? after_mallinfo.uordblks - before_mallinfo.uordblks : 0;
--
-- log_debug("Successfully loaded SELinux database in %s, size on heap is %iK.",
-- format_timespan(timespan, sizeof(timespan), after_timestamp - before_timestamp, 0),
-- (l+1023)/1024);
-
-+ log_debug("Successfully loaded SELinux database in %s",
-+ format_timespan(timespan, sizeof(timespan), after_timestamp - before_timestamp, 0));
- #endif
- return 0;
- }
diff --git a/sys-auth/elogind/files/elogind-241.4-broken-test.patch b/sys-auth/elogind/files/elogind-241.4-broken-test.patch
deleted file mode 100644
index d2735825..00000000
--- a/sys-auth/elogind/files/elogind-241.4-broken-test.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- a/src/test/meson.build 2019-11-15 08:59:47.000000000 +0100
-+++ b/src/test/meson.build 2019-11-30 13:04:45.051316140 +0100
-@@ -1014,9 +1014,9 @@
- # '', 'timeout=120'],
- #endif // 0
-
-- [['src/libelogind/sd-login/test-login.c'],
-- [],
-- []],
-+# [['src/libelogind/sd-login/test-login.c'],
-+# [],
-+# []],
-
- [['src/libelogind/sd-device/test-sd-device.c'],
- [],
diff --git a/sys-auth/elogind/files/elogind-243.7-nodocs.patch b/sys-auth/elogind/files/elogind-243.7-nodocs.patch
deleted file mode 100644
index 0ec0aa37..00000000
--- a/sys-auth/elogind/files/elogind-243.7-nodocs.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-We don't want the build system to install to docdir for us.
-
---- a/meson.build 2020-03-12 20:33:40.000000000 +0100
-+++ b/meson.build 2020-03-12 22:46:08.020716935 +0100
-@@ -3352,15 +3352,11 @@
- # install_data('modprobe.d/systemd.conf',
- # install_dir : modprobedir)
- #endif // 0
--install_data('LICENSE.GPL2',
-- 'LICENSE.LGPL2.1',
- #if 0 /// elogind has upgraded to markdown, and the NEWS file is useless
- # 'NEWS',
- # 'README',
- #else // 0
-- 'README.md',
- #endif // 0
-- 'docs/CODING_STYLE.md',
- #if 0 /// irrelevant for elogind
- # 'docs/DISTRO_PORTING.md',
- # 'docs/ENVIRONMENT.md',
-@@ -3369,8 +3365,6 @@
- # 'docs/TRANSLATORS.md',
- # 'docs/UIDS-GIDS.md',
- #endif // 0
-- 'src/libelogind/sd-bus/GVARIANT-SERIALIZATION',
-- install_dir : docdir)
-
- #if 0 /// UNNEEDED by elogind
- # meson.add_install_script('sh', '-c', mkdir_p.format(systemdstatedir))
diff --git a/sys-auth/elogind/files/elogind.conf.in b/sys-auth/elogind/files/elogind.conf.in
deleted file mode 100644
index 7b05b350..00000000
--- a/sys-auth/elogind/files/elogind.conf.in
+++ /dev/null
@@ -1,7 +0,0 @@
-# /etc/conf.d/elogind: config file for /etc/init.d/elogind
-
-# this is the elogind executable
-ELOGIND_EXEC="/@libdir@/elogind/elogind"
-
-# this is where elogind will store its pid file
-ELOGIND_PIDFILE="/run/elogind.pid"
diff --git a/sys-auth/elogind/files/elogind.init b/sys-auth/elogind/files/elogind.init
deleted file mode 100644
index 019c3afb..00000000
--- a/sys-auth/elogind/files/elogind.init
+++ /dev/null
@@ -1,25 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-depend() {
- need dbus
-
- # Make sure elogind is up before xdm starts any dm
- before xdm
-}
-
-start() {
- ebegin "Starting elogind"
-
- start-stop-daemon --start --quiet \
- --pidfile "${ELOGIND_PIDFILE}" \
- --exec "${ELOGIND_EXEC}" -- --daemon
- eend $?
-}
-
-stop() {
- ebegin "Stopping elogind"
- start-stop-daemon --stop --quiet --pidfile "${ELOGIND_PIDFILE}"
- eend $?
-}
diff --git a/sys-auth/elogind/files/elogind.init-r1 b/sys-auth/elogind/files/elogind.init-r1
deleted file mode 100644
index 56acb1c3..00000000
--- a/sys-auth/elogind/files/elogind.init-r1
+++ /dev/null
@@ -1,27 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-depend() {
- need dbus
-
- # Make sure elogind is up before xdm starts any dm
- before xdm
-
- use logger
-}
-
-start() {
- ebegin "Starting elogind"
-
- start-stop-daemon --start --quiet \
- --pidfile "${ELOGIND_PIDFILE}" \
- --exec "${ELOGIND_EXEC}" -- --daemon
- eend $?
-}
-
-stop() {
- ebegin "Stopping elogind"
- start-stop-daemon --stop --quiet --pidfile "${ELOGIND_PIDFILE}"
- eend $?
-}
diff --git a/sys-auth/elogind/metadata.xml b/sys-auth/elogind/metadata.xml
deleted file mode 100644
index 160c728b..00000000
--- a/sys-auth/elogind/metadata.xml
+++ /dev/null
@@ -1,17 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>asturm@gentoo.org</email>
- </maintainer>
- <maintainer type="person">
- <email>kensington@gentoo.org</email>
- </maintainer>
- <maintainer type="person">
- <email>slashbeast@gentoo.org</email>
- <name>Piotr Karbowski</name>
- </maintainer>
- <upstream>
- <remote-id type="github">elogind/elogind</remote-id>
- </upstream>
-</pkgmetadata>