aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory Pratt <anarchy@gentoo.org>2020-12-07 07:37:10 -0600
committerJory Pratt <anarchy@gentoo.org>2020-12-07 07:37:10 -0600
commitade05e39aa2e11763ca60caab593b846dd10e845 (patch)
treebf2d6ee41de1bc6fdaf2fc5e2f02fb98db0d007c /media-libs
parentnet-libs/webkit-gtk: remove useless blank line (diff)
downloadmusl-ade05e39aa2e11763ca60caab593b846dd10e845.tar.gz
musl-ade05e39aa2e11763ca60caab593b846dd10e845.tar.bz2
musl-ade05e39aa2e11763ca60caab593b846dd10e845.zip
media-libs/mesa: Version bump 20.2.4
Package-Manager: Portage-3.0.11, Repoman-3.0.2 Signed-off-by: Jory Pratt <anarchy@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/mesa/Manifest2
-rw-r--r--media-libs/mesa/mesa-20.2.4.ebuild (renamed from media-libs/mesa/mesa-20.2.0_rc4.ebuild)37
-rw-r--r--media-libs/mesa/metadata.xml1
3 files changed, 15 insertions, 25 deletions
diff --git a/media-libs/mesa/Manifest b/media-libs/mesa/Manifest
index e3b8a271..7fdc752e 100644
--- a/media-libs/mesa/Manifest
+++ b/media-libs/mesa/Manifest
@@ -1,2 +1,2 @@
DIST mesa-20.1.10.tar.xz 12918420 BLAKE2B 408f4bc6eb0dc11199cd161d6914b77cb57313bca94f26794cbfd05332922c45dc216a64e33df9fad64cd41e1ad8b2de6c2e5f99cad234870f7a5b970a62dcbd SHA512 0d4016abfcc733c853d7b6c3c997ddc554a44088c0a4d9a7edb51ab5ad7d9e1234728b61ffcb9c82a6c5fee1429091a1c31cbeabcb1b50411337b99ee550d28a
-DIST mesa-20.2.0-rc4.tar.xz 13569628 BLAKE2B 54068c298a57f2c19113828e2e9b94dd15070ecc0c899f7e3dc527b27579e4f8c3c84c7b841c8d0b8313556cca41bfefd3e08b360dd0e364cbc29e0609ff6f3d SHA512 1f718bfbadbc15b7216864226adb737f3a4a7801dc60ca9294effd4be5f260fffd31c988eed9550e8a7a7430acb05ba0c7d65693c1f375eab4b95d2d029755bb
+DIST mesa-20.2.4.tar.xz 13869928 BLAKE2B 078dc88be08d3b41d5144c4d72b0044512dc77c7afcbc6366dc7b9d435886afc65009277b215f6e2898cef98a7c52fb232d8b36bd6e6d1114326302d5acc9216 SHA512 e60decb867a3ca08b99e72aa62db8c5515696bf4a9e2642c1703479167a79b0828192f6dcca688263f5786cd524308a4410e47111fa7b97c091473e4ac4ee799
diff --git a/media-libs/mesa/mesa-20.2.0_rc4.ebuild b/media-libs/mesa/mesa-20.2.4.ebuild
index 7d2dc429..0f0e31fb 100644
--- a/media-libs/mesa/mesa-20.2.0_rc4.ebuild
+++ b/media-libs/mesa/mesa-20.2.4.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6,7,8,9} )
inherit llvm meson multilib-minimal python-any-r1 linux-info
@@ -19,7 +19,7 @@ if [[ ${PV} == 9999 ]]; then
inherit git-r3
else
SRC_URI="https://archive.mesa3d.org/${MY_P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
+ KEYWORDS="amd64 ~arm arm64 ~mips ~ppc ~ppc64 ~x86"
fi
LICENSE="MIT"
@@ -35,7 +35,7 @@ for card in ${VIDEO_CARDS}; do
done
IUSE="${IUSE_VIDEO_CARDS}
- +classic d3d9 debug +dri3 +egl +gallium +gbm gles1 +gles2 +libglvnd +llvm
+ +classic d3d9 debug +dri3 +egl +gallium +gbm gles1 +gles2 +llvm
lm-sensors opencl osmesa selinux test unwind vaapi valgrind vdpau vulkan
vulkan-overlay wayland +X xa xvmc zink +zstd"
@@ -74,16 +74,9 @@ REQUIRED_USE="
LIBDRM_DEPSTRING=">=x11-libs/libdrm-2.4.100"
RDEPEND="
- !app-eselect/eselect-mesa
>=dev-libs/expat-2.1.0-r3:=[${MULTILIB_USEDEP}]
+ >=media-libs/libglvnd-1.3.2[X?,${MULTILIB_USEDEP}]
>=sys-libs/zlib-1.2.8[${MULTILIB_USEDEP}]
- libglvnd? (
- >=media-libs/libglvnd-1.3.2[X?,${MULTILIB_USEDEP}]
- !app-eselect/eselect-opengl
- )
- !libglvnd? (
- >=app-eselect/eselect-opengl-1.3.0
- )
gallium? (
unwind? ( sys-libs/libunwind[${MULTILIB_USEDEP}] )
llvm? (
@@ -149,9 +142,10 @@ RDEPEND="${RDEPEND}
# 1. List all the working slots (with min versions) in ||, newest first.
# 2. Update the := to specify *max* version, e.g. < 10.
# 3. Specify LLVM_MAX_SLOT, e.g. 9.
-LLVM_MAX_SLOT="10"
+LLVM_MAX_SLOT="11"
LLVM_DEPSTR="
|| (
+ sys-devel/llvm:11[${MULTILIB_USEDEP}]
sys-devel/llvm:10[${MULTILIB_USEDEP}]
sys-devel/llvm:9[${MULTILIB_USEDEP}]
)
@@ -244,7 +238,7 @@ x86? (
usr/lib*/libGLESv2.so.2.0.0
usr/lib*/libGL.so.1.2.0
usr/lib*/libOSMesa.so.8.0.0
- libglvnd? ( usr/lib/libGLX_mesa.so.0.0.0 )
+ usr/lib/libGLX_mesa.so.0.0.0
)"
PATCHES=(
@@ -381,6 +375,12 @@ multilib_src_configure() {
use wayland && platforms+=",wayland"
[[ -n $platforms ]] && emesonargs+=(-Dplatforms=${platforms#,})
+ if use X || use egl; then
+ emesonargs+=(-Dglvnd=true)
+ else
+ emesonargs+=(-Dglvnd=false)
+ fi
+
if use gallium; then
emesonargs+=(
$(meson_feature llvm)
@@ -511,7 +511,6 @@ multilib_src_configure() {
$(meson_feature gbm)
$(meson_feature gles1)
$(meson_feature gles2)
- $(meson_use libglvnd glvnd)
$(meson_use selinux)
$(meson_feature zstd)
-Dvalgrind=$(usex valgrind auto false)
@@ -539,15 +538,7 @@ multilib_src_install_all() {
}
multilib_src_test() {
- meson test -v -C "${BUILD_DIR}" -t 100
-}
-
-pkg_postinst() {
- if ! use libglvnd; then
- # Switch to the xorg implementation.
- echo
- eselect opengl set --use-old ${OPENGL_DIR}
- fi
+ meson_src_test -t 100
}
# $1 - VIDEO_CARDS flag (check skipped for "--")
diff --git a/media-libs/mesa/metadata.xml b/media-libs/mesa/metadata.xml
index 8aecc5f6..a2a3def6 100644
--- a/media-libs/mesa/metadata.xml
+++ b/media-libs/mesa/metadata.xml
@@ -14,7 +14,6 @@
<flag name="gbm">Enable the Graphics Buffer Manager for EGL on KMS.</flag>
<flag name="gles1">Enable GLESv1 support.</flag>
<flag name="gles2">Enable GLESv2 support.</flag>
- <flag name="libglvnd">Use libglvnd for dispatch.</flag>
<flag name="llvm">Enable LLVM backend for Gallium3D.</flag>
<flag name="lm-sensors">Enable Gallium HUD lm-sensors support.</flag>
<flag name="opencl">Enable the Clover Gallium OpenCL state tracker.</flag>