aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorstefson <herrtimson@yahoo.de>2019-10-21 19:51:41 +0200
committerJory Pratt <anarchy@gentoo.org>2019-10-21 16:50:09 -0500
commit743e57d790ffd19d05fc8cc6d72516748e0aa2eb (patch)
tree1df2419075d63f7ccb41ec3dfd453a4458a45084 /net-libs
parentdev-qt/qtwebengine: add alpine patches for musl users (diff)
downloadmusl-743e57d790ffd19d05fc8cc6d72516748e0aa2eb.tar.gz
musl-743e57d790ffd19d05fc8cc6d72516748e0aa2eb.tar.bz2
musl-743e57d790ffd19d05fc8cc6d72516748e0aa2eb.zip
net-libs/webkit-gtk: drop old and sync keywords with tree
Signed-off-by: Steffen Kuhn <nielson2@yandex.com> Signed-off-by: Jory Pratt <anarchy@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/webkit-gtk/Manifest1
-rw-r--r--net-libs/webkit-gtk/files/webkit-gtk-2.22.2-musl.patch145
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-2.24.3.ebuild283
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-2.24.4.ebuild2
4 files changed, 1 insertions, 430 deletions
diff --git a/net-libs/webkit-gtk/Manifest b/net-libs/webkit-gtk/Manifest
index 38c6c238..99e63863 100644
--- a/net-libs/webkit-gtk/Manifest
+++ b/net-libs/webkit-gtk/Manifest
@@ -1,2 +1 @@
-DIST webkitgtk-2.24.3.tar.xz 17912032 BLAKE2B 9ac897f10ef25a25b70b73499fb79b72d469c0016231b94fb3376dc8876fd9ac2874bac38450ddf67c80dba8a66fa509c8cd42bc4ce5316d6e4a17fa1346803c SHA512 b358bb11f7df477e5b3d6a12e2e6b41cb4e6a7274e34ce6299bf0c56044ffc7db5a834e9abf5c71d992ef41d194d30171b8be406420ffc54fe766cc811afb79f
DIST webkitgtk-2.24.4.tar.xz 17575784 BLAKE2B c30683ea365a50d7def572305b49278343d67739f9bd3cfd78cb08b5cc87b5453504df9b09752f8d6483b18b9b812f3d3cddc084762cfa8990fcc651660b89c2 SHA512 1d713955a735ae2e2229beea7bda7f518a6247c6aa7f5753aeb5b5c6395339d451d0d146f7188e7ba65cb82ea5a74a5e73e956fe59d5f5f97659a44af33df112
diff --git a/net-libs/webkit-gtk/files/webkit-gtk-2.22.2-musl.patch b/net-libs/webkit-gtk/files/webkit-gtk-2.22.2-musl.patch
deleted file mode 100644
index b5fd0bbb..00000000
--- a/net-libs/webkit-gtk/files/webkit-gtk-2.22.2-musl.patch
+++ /dev/null
@@ -1,145 +0,0 @@
-diff --git a/Source/JavaScriptCore/runtime/MachineContext.h b/Source/JavaScriptCore/runtime/MachineContext.h
-index 836d755..4a0518a 100644
---- a/Source/JavaScriptCore/runtime/MachineContext.h
-+++ b/Source/JavaScriptCore/runtime/MachineContext.h
-@@ -188,7 +188,7 @@ static inline void*& stackPointerImpl(mcontext_t& machineContext)
- #error Unknown Architecture
- #endif
-
--#elif OS(FUCHSIA) || defined(__GLIBC__) || defined(__BIONIC__)
-+#elif OS(FUCHSIA) || defined(__linux__)
-
- #if CPU(X86)
- return reinterpret_cast<void*&>((uintptr_t&) machineContext.gregs[REG_ESP]);
-@@ -335,7 +335,7 @@ static inline void*& framePointerImpl(mcontext_t& machineContext)
- #error Unknown Architecture
- #endif
-
--#elif OS(FUCHSIA) || defined(__GLIBC__) || defined(__BIONIC__)
-+#elif OS(FUCHSIA) || defined(__linux__)
-
- // The following sequence depends on glibc's sys/ucontext.h.
- #if CPU(X86)
-@@ -482,7 +482,7 @@ static inline void*& instructionPointerImpl(mcontext_t& machineContext)
- #error Unknown Architecture
- #endif
-
--#elif OS(FUCHSIA) || defined(__GLIBC__) || defined(__BIONIC__)
-+#elif OS(FUCHSIA) || defined(__linux__)
-
- // The following sequence depends on glibc's sys/ucontext.h.
- #if CPU(X86)
-@@ -639,7 +639,7 @@ inline void*& argumentPointer<1>(mcontext_t& machineContext)
- #error Unknown Architecture
- #endif
-
--#elif OS(FUCHSIA) || defined(__GLIBC__) || defined(__BIONIC__)
-+#elif OS(FUCHSIA) || defined(__linux__)
-
- // The following sequence depends on glibc's sys/ucontext.h.
- #if CPU(X86)
-@@ -756,7 +756,7 @@ inline void*& llintInstructionPointer(mcontext_t& machineContext)
- #error Unknown Architecture
- #endif
-
--#elif OS(FUCHSIA) || defined(__GLIBC__) || defined(__BIONIC__)
-+#elif OS(FUCHSIA) || defined(__linux__)
-
- // The following sequence depends on glibc's sys/ucontext.h.
- #if CPU(X86)
-diff --git a/Source/JavaScriptCore/runtime/Options.h b/Source/JavaScriptCore/runtime/Options.h
-index 27396d2..23a7b9e 100644
---- a/Source/JavaScriptCore/runtime/Options.h
-+++ b/Source/JavaScriptCore/runtime/Options.h
-@@ -144,9 +144,9 @@ constexpr bool enableWebAssemblyStreamingApi = false;
- \
- v(bool, reportMustSucceedExecutableAllocations, false, Normal, nullptr) \
- \
-- v(unsigned, maxPerThreadStackUsage, 4 * MB, Normal, "Max allowed stack usage by the VM") \
-- v(unsigned, softReservedZoneSize, 128 * KB, Normal, "A buffer greater than reservedZoneSize that reserves space for stringifying exceptions.") \
-- v(unsigned, reservedZoneSize, 64 * KB, Normal, "The amount of stack space we guarantee to our clients (and to interal VM code that does not call out to clients).") \
-+ v(unsigned, maxPerThreadStackUsage, 80 * KB, Normal, "Max allowed stack usage by the VM") \
-+ v(unsigned, softReservedZoneSize, 32 * KB, Normal, "A buffer greater than reservedZoneSize that reserves space for stringifying exceptions.") \
-+ v(unsigned, reservedZoneSize, 16 * KB, Normal, "The amount of stack space we guarantee to our clients (and to interal VM code that does not call out to clients).") \
- \
- v(bool, crashIfCantAllocateJITMemory, false, Normal, nullptr) \
- v(unsigned, jitMemoryReservationSize, 0, Normal, "Set this number to change the executable allocation size in ExecutableAllocatorFixedVMPool. (In bytes.)") \
-diff --git a/Source/ThirdParty/ANGLE/src/compiler/preprocessor/ExpressionParser.cpp b/Source/ThirdParty/ANGLE/src/compiler/preprocessor/ExpressionParser.cpp
-index c0f8b9c..1074cce 100644
---- a/Source/ThirdParty/ANGLE/src/compiler/preprocessor/ExpressionParser.cpp
-+++ b/Source/ThirdParty/ANGLE/src/compiler/preprocessor/ExpressionParser.cpp
-@@ -836,7 +836,7 @@ int yydebug;
- #if YYERROR_VERBOSE
-
- # ifndef yystrlen
--# if defined __GLIBC__ && defined _STRING_H
-+# if defined __linux__ && defined _STRING_H
- # define yystrlen strlen
- # else
- /* Return the length of YYSTR. */
-@@ -852,7 +852,7 @@ yystrlen (const char *yystr)
- # endif
-
- # ifndef yystpcpy
--# if defined __GLIBC__ && defined _STRING_H && defined _GNU_SOURCE
-+# if defined __linux__ && defined _STRING_H && defined _GNU_SOURCE
- # define yystpcpy stpcpy
- # else
- /* Copy YYSRC to YYDEST, returning the address of the terminating '\0' in
-diff --git a/Source/ThirdParty/ANGLE/src/compiler/translator/glslang_tab.cpp b/Source/ThirdParty/ANGLE/src/compiler/translator/glslang_tab.cpp
-index 14cd536..6084d64 100644
---- a/Source/ThirdParty/ANGLE/src/compiler/translator/glslang_tab.cpp
-+++ b/Source/ThirdParty/ANGLE/src/compiler/translator/glslang_tab.cpp
-@@ -1975,7 +1975,7 @@ int yydebug;
- #if YYERROR_VERBOSE
-
- # ifndef yystrlen
--# if defined __GLIBC__ && defined _STRING_H
-+# if defined __linux__ && defined _STRING_H
- # define yystrlen strlen
- # else
- /* Return the length of YYSTR. */
-@@ -1991,7 +1991,7 @@ yystrlen (const char *yystr)
- # endif
-
- # ifndef yystpcpy
--# if defined __GLIBC__ && defined _STRING_H && defined _GNU_SOURCE
-+# if defined __linux__ && defined _STRING_H && defined _GNU_SOURCE
- # define yystpcpy stpcpy
- # else
- /* Copy YYSRC to YYDEST, returning the address of the terminating '\0' in
-diff --git a/Source/WTF/wtf/Platform.h b/Source/WTF/wtf/Platform.h
-index 67cfa93..341a9f5 100644
---- a/Source/WTF/wtf/Platform.h
-+++ b/Source/WTF/wtf/Platform.h
-@@ -697,7 +697,7 @@
- #define HAVE_CFNETWORK_STORAGE_PARTITIONING 1
- #endif
-
--#if OS(DARWIN) || OS(FUCHSIA) || ((OS(FREEBSD) || defined(__GLIBC__) || defined(__BIONIC__)) && (CPU(X86) || CPU(X86_64) || CPU(ARM) || CPU(ARM64) || CPU(MIPS)))
-+#if OS(DARWIN) || OS(FUCHSIA) || ((OS(FREEBSD) || defined(__linux__)) && (CPU(X86) || CPU(X86_64) || CPU(ARM) || CPU(ARM64) || CPU(MIPS)))
- #define HAVE_MACHINE_CONTEXT 1
- #endif
-
-diff --git a/Source/WebCore/xml/XPathGrammar.cpp b/Source/WebCore/xml/XPathGrammar.cpp
-index 31df1c0..bc569c1 100644
---- a/Source/WebCore/xml/XPathGrammar.cpp
-+++ b/Source/WebCore/xml/XPathGrammar.cpp
-@@ -966,7 +966,7 @@ int yydebug;
- #if YYERROR_VERBOSE
-
- # ifndef yystrlen
--# if defined __GLIBC__ && defined _STRING_H
-+# if defined __linux__ && defined _STRING_H
- # define yystrlen strlen
- # else
- /* Return the length of YYSTR. */
-@@ -989,7 +989,7 @@ yystrlen (yystr)
- # endif
-
- # ifndef yystpcpy
--# if defined __GLIBC__ && defined _STRING_H && defined _GNU_SOURCE
-+# if defined __linux__ && defined _STRING_H && defined _GNU_SOURCE
- # define yystpcpy stpcpy
- # else
- /* Copy YYSRC to YYDEST, returning the address of the terminating '\0' in
diff --git a/net-libs/webkit-gtk/webkit-gtk-2.24.3.ebuild b/net-libs/webkit-gtk/webkit-gtk-2.24.3.ebuild
deleted file mode 100644
index 796c0c9d..00000000
--- a/net-libs/webkit-gtk/webkit-gtk-2.24.3.ebuild
+++ /dev/null
@@ -1,283 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-CMAKE_MAKEFILE_GENERATOR="ninja"
-PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
-USE_RUBY="ruby24 ruby25 ruby26"
-
-inherit check-reqs cmake-utils flag-o-matic gnome2 pax-utils python-any-r1 ruby-single toolchain-funcs virtualx
-
-MY_P="webkitgtk-${PV}"
-DESCRIPTION="Open source web browser engine"
-HOMEPAGE="https://www.webkitgtk.org"
-SRC_URI="https://www.webkitgtk.org/releases/${MY_P}.tar.xz"
-
-LICENSE="LGPL-2+ BSD"
-SLOT="4/37" # soname version of libwebkit2gtk-4.0
-KEYWORDS="amd64 ~arm ~arm64 ~ppc x86"
-
-IUSE="aqua coverage doc +egl +geolocation gles2 gnome-keyring +gstreamer +introspection +jpeg2k libnotify nsplugin +opengl spell wayland +webgl +X"
-
-# webgl needs gstreamer, bug #560612
-# gstreamer with opengl/gles2 needs egl
-REQUIRED_USE="
- geolocation? ( introspection )
- gles2? ( egl !opengl )
- gstreamer? ( opengl? ( egl ) )
- nsplugin? ( X )
- webgl? ( gstreamer
- || ( gles2 opengl ) )
- wayland? ( egl )
- || ( aqua wayland X )
-"
-
-# Tests fail to link for inexplicable reasons
-# https://bugs.webkit.org/show_bug.cgi?id=148210
-RESTRICT="test"
-
-# Aqua support in gtk3 is untested
-# Dependencies found at Source/cmake/OptionsGTK.cmake
-# Various compile-time optionals for gtk+-3.22.0 - ensure it
-# Missing OpenWebRTC checks and conditionals, but ENABLE_MEDIA_STREAM/ENABLE_WEB_RTC is experimental upstream (PRIVATE OFF)
-# >=gst-plugins-opus-1.14.4-r1 for opusparse (required by MSE)
-RDEPEND="
- >=x11-libs/cairo-1.16.0:=[X?]
- >=media-libs/fontconfig-2.13.0:1.0
- >=media-libs/freetype-2.9.0:2
- >=dev-libs/libgcrypt-1.7.0:0=
- >=x11-libs/gtk+-3.22:3[aqua?,introspection?,wayland?,X?]
- >=media-libs/harfbuzz-1.4.2:=[icu(+)]
- >=dev-libs/icu-3.8.1-r1:=
- virtual/jpeg:0=
- >=net-libs/libsoup-2.48:2.4[introspection?]
- >=dev-libs/libxml2-2.8.0:2
- >=media-libs/libpng-1.4:0=
- dev-db/sqlite:3=
- sys-libs/zlib:0
- >=dev-libs/atk-2.8.0
- media-libs/libwebp:=
-
- >=dev-libs/glib-2.40:2
- >=dev-libs/libxslt-1.1.7
- media-libs/woff2
- gnome-keyring? ( app-crypt/libsecret )
- geolocation? ( >=app-misc/geoclue-2.1.5:2.0 )
- introspection? ( >=dev-libs/gobject-introspection-1.32.0:= )
- dev-libs/libtasn1:=
- nsplugin? ( >=x11-libs/gtk+-2.24.10:2 )
- spell? ( >=app-text/enchant-0.22:= )
- gstreamer? (
- >=media-libs/gstreamer-1.14:1.0
- >=media-libs/gst-plugins-base-1.14:1.0[egl?,gles2?,opengl?]
- >=media-plugins/gst-plugins-opus-1.14.4-r1:1.0
- >=media-libs/gst-plugins-bad-1.14:1.0 )
-
- X? (
- x11-libs/libX11
- x11-libs/libXcomposite
- x11-libs/libXdamage
- x11-libs/libXrender
- x11-libs/libXt )
-
- libnotify? ( x11-libs/libnotify )
- dev-libs/hyphen
- jpeg2k? ( >=media-libs/openjpeg-2.2.0:2= )
-
- egl? ( media-libs/mesa[egl] )
- gles2? ( media-libs/mesa[gles2] )
- opengl? ( virtual/opengl )
- webgl? (
- x11-libs/libXcomposite
- x11-libs/libXdamage )
-"
-
-# paxctl needed for bug #407085
-# Need real bison, not yacc
-DEPEND="${RDEPEND}
- ${PYTHON_DEPS}
- ${RUBY_DEPS}
- >=app-accessibility/at-spi2-core-2.5.3
- dev-util/glib-utils
- >=dev-util/gtk-doc-am-1.10
- >=dev-util/gperf-3.0.1
- >=sys-devel/bison-2.4.3
- || ( >=sys-devel/gcc-6.0 >=sys-devel/clang-3.3 )
- sys-devel/gettext
- virtual/pkgconfig
-
- >=dev-lang/perl-5.10
- virtual/perl-Data-Dumper
- virtual/perl-Carp
- virtual/perl-JSON-PP
-
- doc? ( >=dev-util/gtk-doc-1.10 )
- geolocation? ( dev-util/gdbus-codegen )
-"
-# test? (
-# dev-python/pygobject:3[python_targets_python2_7]
-# x11-themes/hicolor-icon-theme
-# jit? ( sys-apps/paxctl ) )
-
-S="${WORKDIR}/${MY_P}"
-
-CHECKREQS_DISK_BUILD="18G" # and even this might not be enough, bug #417307
-
-pkg_pretend() {
- if [[ ${MERGE_TYPE} != "binary" ]] ; then
- if is-flagq "-g*" && ! is-flagq "-g*0" ; then
- einfo "Checking for sufficient disk space to build ${PN} with debugging CFLAGS"
- check-reqs_pkg_pretend
- fi
-
- if ! test-flag-CXX -std=c++11 ; then
- die "You need at least GCC 4.9.x or Clang >= 3.3 for C++11-specific compiler flags"
- fi
-
- if tc-is-gcc && [[ $(gcc-version) < 4.9 ]] ; then
- die 'The active compiler needs to be gcc 4.9 (or newer)'
- fi
- fi
-
- if ! use opengl && ! use gles2; then
- ewarn
- ewarn "You are disabling OpenGL usage (USE=opengl or USE=gles) completely."
- ewarn "This is an unsupported configuration meant for very specific embedded"
- ewarn "use cases, where there truly is no GL possible (and even that use case"
- ewarn "is very unlikely to come by). If you have GL (even software-only), you"
- ewarn "really really should be enabling OpenGL!"
- ewarn
- fi
-}
-
-pkg_setup() {
- if [[ ${MERGE_TYPE} != "binary" ]] && is-flagq "-g*" && ! is-flagq "-g*0" ; then
- check-reqs_pkg_setup
- fi
-
- python-any-r1_pkg_setup
-}
-
-src_prepare() {
- # Taken from https://git.alpinelinux.org/aports/commit/community/webkit2gtk/musl-fixes.patch?id=609fbb0235cf6440f5d502885c4e0531c835aed7
- eapply "${FILESDIR}"/${PN}-2.22.2-musl.patch
- cmake-utils_src_prepare
- gnome2_src_prepare
-}
-
-src_configure() {
- # Respect CC, otherwise fails on prefix #395875
- tc-export CC
-
- # It does not compile on alpha without this in LDFLAGS
- # https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=648761
- use alpha && append-ldflags "-Wl,--no-relax"
-
- # ld segfaults on ia64 with LDFLAGS --as-needed, bug #555504
- use ia64 && append-ldflags "-Wl,--no-as-needed"
-
- # Sigbuses on SPARC with mcpu and co., bug #???
- use sparc && filter-flags "-mvis"
-
- # https://bugs.webkit.org/show_bug.cgi?id=42070 , #301634
- use ppc64 && append-flags "-mminimal-toc"
-
- # Try to use less memory, bug #469942 (see Fedora .spec for reference)
- # --no-keep-memory doesn't work on ia64, bug #502492
- if ! use ia64; then
- append-ldflags "-Wl,--no-keep-memory"
- fi
-
- # We try to use gold when possible for this package
-# if ! tc-ld-is-gold ; then
-# append-ldflags "-Wl,--reduce-memory-overheads"
-# fi
-
- # Multiple rendering bugs on youtube, github, etc without this, bug #547224
- append-flags $(test-flags -fno-strict-aliasing)
-
- # Ruby situation is a bit complicated. See bug 513888
- local rubyimpl
- local ruby_interpreter=""
- for rubyimpl in ${USE_RUBY}; do
- if has_version "virtual/rubygems[ruby_targets_${rubyimpl}]"; then
- ruby_interpreter="-DRUBY_EXECUTABLE=$(type -P ${rubyimpl})"
- fi
- done
- # This will rarely occur. Only a couple of corner cases could lead us to
- # that failure. See bug 513888
- [[ -z $ruby_interpreter ]] && die "No suitable ruby interpreter found"
-
- # TODO: Check Web Audio support
- # should somehow let user select between them?
- #
- # FTL_JIT requires llvm
- #
- # opengl needs to be explicetly handled, bug #576634
-
- local opengl_enabled
- if use opengl || use gles2; then
- opengl_enabled=ON
- else
- opengl_enabled=OFF
- fi
-
- local mycmakeargs=(
- #-DENABLE_UNIFIED_BUILDS=$(usex jumbo-build) # broken in 2.24.1
- -DENABLE_QUARTZ_TARGET=$(usex aqua)
- -DENABLE_API_TESTS=$(usex test)
- -DENABLE_GTKDOC=$(usex doc)
- -DENABLE_GEOLOCATION=$(usex geolocation)
- $(cmake-utils_use_find_package gles2 OpenGLES2)
- -DENABLE_GLES2=$(usex gles2)
- -DENABLE_VIDEO=$(usex gstreamer)
- -DENABLE_WEB_AUDIO=$(usex gstreamer)
- -DENABLE_INTROSPECTION=$(usex introspection)
- -DUSE_LIBNOTIFY=$(usex libnotify)
- -DUSE_LIBSECRET=$(usex gnome-keyring)
- -DUSE_OPENJPEG=$(usex jpeg2k)
- -DUSE_WOFF2=ON
- -DENABLE_PLUGIN_PROCESS_GTK2=$(usex nsplugin)
- -DENABLE_SPELLCHECK=$(usex spell)
- -DENABLE_WAYLAND_TARGET=$(usex wayland)
- -DENABLE_WEBGL=$(usex webgl)
- $(cmake-utils_use_find_package egl EGL)
- $(cmake-utils_use_find_package opengl OpenGL)
- -DENABLE_X11_TARGET=$(usex X)
- -DENABLE_OPENGL=${opengl_enabled}
- -DCMAKE_BUILD_TYPE=Release
- -DPORT=GTK
- ${ruby_interpreter}
- )
-
- # Allow it to use GOLD when possible as it has all the magic to
- # detect when to use it and using gold for this concrete package has
- # multiple advantages and is also the upstream default, bug #585788
-# if tc-ld-is-gold ; then
-# mycmakeargs+=( -DUSE_LD_GOLD=ON )
-# else
-# mycmakeargs+=( -DUSE_LD_GOLD=OFF )
-# fi
-
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile
-}
-
-src_test() {
- # Prevents test failures on PaX systems
- pax-mark m $(list-paxables Programs/*[Tt]ests/*) # Programs/unittests/.libs/test*
-
- cmake-utils_src_test
-}
-
-src_install() {
- cmake-utils_src_install
-
- # Prevents crashes on PaX systems, bug #522808
- pax-mark m "${ED}usr/libexec/webkit2gtk-4.0/jsc" "${ED}usr/libexec/webkit2gtk-4.0/WebKitWebProcess"
- pax-mark m "${ED}usr/libexec/webkit2gtk-4.0/WebKitPluginProcess"
- use nsplugin && pax-mark m "${ED}usr/libexec/webkit2gtk-4.0/WebKitPluginProcess"2
-}
diff --git a/net-libs/webkit-gtk/webkit-gtk-2.24.4.ebuild b/net-libs/webkit-gtk/webkit-gtk-2.24.4.ebuild
index 4edd6ac7..72ed98db 100644
--- a/net-libs/webkit-gtk/webkit-gtk-2.24.4.ebuild
+++ b/net-libs/webkit-gtk/webkit-gtk-2.24.4.ebuild
@@ -15,7 +15,7 @@ SRC_URI="https://www.webkitgtk.org/releases/${MY_P}.tar.xz"
LICENSE="LGPL-2+ BSD"
SLOT="4/37" # soname version of libwebkit2gtk-4.0
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+KEYWORDS="amd64 ~arm arm64 ~ppc x86"
IUSE="aqua coverage doc +egl +geolocation gles2 gnome-keyring +gstreamer +introspection +jpeg2k libnotify nsplugin +opengl spell wayland +webgl +X"