aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory Pratt <anarchy@gentoo.org>2021-06-21 08:11:16 -0500
committerJory Pratt <anarchy@gentoo.org>2021-06-21 08:11:16 -0500
commit0cb49d4eb812b0788fbd8197d4468574ac3137bf (patch)
tree4aa70cdf08a791528fa037d902eabf020ecfa81b /sys-apps
parentsys-libs/tevent: sync with ::gentoo (diff)
downloadmusl-0cb49d4eb812b0788fbd8197d4468574ac3137bf.tar.gz
musl-0cb49d4eb812b0788fbd8197d4468574ac3137bf.tar.bz2
musl-0cb49d4eb812b0788fbd8197d4468574ac3137bf.zip
sys-apps/{sandbox/attr}: ::gentoo fixed already
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Jory Pratt <anarchy@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/attr/Manifest1
-rw-r--r--sys-apps/attr/attr-2.4.47-r2.ebuild70
-rw-r--r--sys-apps/attr/files/attr-2.4.47-cdecls.patch27
-rw-r--r--sys-apps/attr/files/attr-2.4.47-fix-missing-sys_types_h.patch12
-rw-r--r--sys-apps/attr/metadata.xml8
-rw-r--r--sys-apps/sandbox/Manifest5
-rw-r--r--sys-apps/sandbox/files/09sandbox1
-rw-r--r--sys-apps/sandbox/files/sandbox-2.10-fix-visibility-musl.patch12
-rw-r--r--sys-apps/sandbox/files/sandbox-2.11-musl.patch48
-rw-r--r--sys-apps/sandbox/files/sandbox-2.14-musl.patch51
-rw-r--r--sys-apps/sandbox/metadata.xml8
-rw-r--r--sys-apps/sandbox/sandbox-2.12.ebuild82
-rw-r--r--sys-apps/sandbox/sandbox-2.13.ebuild82
-rw-r--r--sys-apps/sandbox/sandbox-2.14.ebuild82
-rw-r--r--sys-apps/sandbox/sandbox-2.15.ebuild82
-rw-r--r--sys-apps/sandbox/sandbox-2.17.ebuild78
16 files changed, 0 insertions, 649 deletions
diff --git a/sys-apps/attr/Manifest b/sys-apps/attr/Manifest
deleted file mode 100644
index 16cf20ce..00000000
--- a/sys-apps/attr/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST attr-2.4.47.src.tar.gz 343692 BLAKE2B af4d509f156cb2e693f0faebf1a6cfb4a27cbdd3fd7f8b436cc01419c905ff9ac36214ada2ca8269e49c2e276917b1178dcda97050cf25cecd65382f22bdf9bb SHA512 2a333f63655758298650cf8f89c175efdc0112dcc4013e8d023e2a9a69f177e4bcb1f1d10b6666d6f2027dca4dec0833d54749952ab153d28367e1a72e6e2831
diff --git a/sys-apps/attr/attr-2.4.47-r2.ebuild b/sys-apps/attr/attr-2.4.47-r2.ebuild
deleted file mode 100644
index 1c110c83..00000000
--- a/sys-apps/attr/attr-2.4.47-r2.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="4"
-
-inherit eutils libtool toolchain-funcs multilib-minimal usr-ldscript
-
-DESCRIPTION="Extended attributes tools"
-HOMEPAGE="https://savannah.nongnu.org/projects/attr"
-SRC_URI="mirror://nongnu/${PN}/${P}.src.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~mips ppc x86"
-IUSE="nls static-libs"
-
-DEPEND="nls? ( sys-devel/gettext )
- sys-devel/autoconf"
-RDEPEND=""
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-cdecls.patch
- epatch "${FILESDIR}"/${P}-fix-missing-sys_types_h.patch
-
- sed -i \
- -e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
- -e '/HAVE_ZIPPED_MANPAGES/s:=.*:=false:' \
- include/builddefs.in \
- || die
- strip-linguas -u po
- elibtoolize #580792
-
- multilib_copy_sources # https://savannah.nongnu.org/bugs/index.php?39736
-}
-
-multilib_src_configure() {
- unset PLATFORM #184564
- export OPTIMIZER=${CFLAGS}
- export DEBUG=-DNDEBUG
-
- econf \
- $(use_enable nls gettext) \
- --enable-shared $(use_enable static-libs static) \
- --libexecdir="${EPREFIX}"/usr/$(get_libdir) \
- --bindir="${EPREFIX}"/bin
-}
-
-multilib_src_compile() {
- emake $(multilib_is_native_abi || echo TOOL_SUBDIRS=)
-}
-
-multilib_src_install() {
- emake \
- $(multilib_is_native_abi || echo TOOL_SUBDIRS=) \
- DIST_ROOT="${D}" \
- install install-lib install-dev
-
- if multilib_is_native_abi; then
- # we install attr into /bin, so we need the shared lib with it
- gen_usr_ldscript -a attr
- # the man-pages packages provides the man2 files
- # note: man-pages are installed by TOOL_SUBDIRS
- rm -r "${ED}"/usr/share/man/man2 "${ED}"/usr/share/man/man5/attr.5 || die
- fi
-}
-
-multilib_src_install_all() {
- use static-libs || prune_libtool_files --all
- einstalldocs
-}
diff --git a/sys-apps/attr/files/attr-2.4.47-cdecls.patch b/sys-apps/attr/files/attr-2.4.47-cdecls.patch
deleted file mode 100644
index 85a146ff..00000000
--- a/sys-apps/attr/files/attr-2.4.47-cdecls.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-diff -Naurw attr-2.4.47.orig/include/xattr.h attr-2.4.47/include/xattr.h
---- attr-2.4.47.orig/include/xattr.h 2015-08-22 14:26:31.167584051 +0700
-+++ attr-2.4.47/include/xattr.h 2015-08-22 14:32:25.714261283 +0700
-@@ -31,7 +31,12 @@
- #define XATTR_REPLACE 0x2 /* set value, fail if attr does not exist */
-
-
--__BEGIN_DECLS
-+#ifdef __cplusplus
-+#define __THROW throw()
-+extern "C" {
-+#else
-+#define __THROW
-+#endif
-
- extern int setxattr (const char *__path, const char *__name,
- const void *__value, size_t __size, int __flags) __THROW;
-@@ -58,6 +63,8 @@
- extern int lremovexattr (const char *__path, const char *__name) __THROW;
- extern int fremovexattr (int __filedes, const char *__name) __THROW;
-
--__END_DECLS
-+#ifdef __cplusplus
-+}
-+#endif
-
- #endif /* __XATTR_H__ */
diff --git a/sys-apps/attr/files/attr-2.4.47-fix-missing-sys_types_h.patch b/sys-apps/attr/files/attr-2.4.47-fix-missing-sys_types_h.patch
deleted file mode 100644
index 463526d1..00000000
--- a/sys-apps/attr/files/attr-2.4.47-fix-missing-sys_types_h.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Naur attr-2.4.47.orig/include/attributes.h attr-2.4.47/include/attributes.h
---- attr-2.4.47.orig/include/attributes.h 2013-05-19 00:53:54.000000000 -0400
-+++ attr-2.4.47/include/attributes.h 2016-05-28 09:34:04.743603033 -0400
-@@ -22,6 +22,8 @@
- extern "C" {
- #endif
-
-+#include <sys/types.h>
-+
- /*
- * An almost-IRIX-compatible extended attributes API
- * (the IRIX attribute "list" operation is missing, added ATTR_SECURE).
diff --git a/sys-apps/attr/metadata.xml b/sys-apps/attr/metadata.xml
deleted file mode 100644
index 56c12441..00000000
--- a/sys-apps/attr/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
- <email>base-system@gentoo.org</email>
- <name>Gentoo Base System</name>
-</maintainer>
-</pkgmetadata>
diff --git a/sys-apps/sandbox/Manifest b/sys-apps/sandbox/Manifest
deleted file mode 100644
index 974844ca..00000000
--- a/sys-apps/sandbox/Manifest
+++ /dev/null
@@ -1,5 +0,0 @@
-DIST sandbox-2.12.tar.xz 424252 BLAKE2B 55eb06cbc15ad9ff8b0c272b8d071591ce3533a6ff807719df79131e6c966d60c3b37d9d8e4e1d466df0992836c4594bf6927b496ecb343a71d7b0656219a6d7 SHA512 98bd2ee8807d81e65ee0c9f11cfaf2b37da2ee4d8763c68d18c0ff6b14f3cc847ae2d3a0aa30cbe86063a2108ed4d4dcf7cc3fc4f37cb7549d266d4c1989c2a9
-DIST sandbox-2.13.tar.xz 424968 BLAKE2B efcbf527853e8cfe8b3fec026041f55f51cba78029f92195ec76a45e84cb2b6cc129267c6e50608584607de72a86b2e7836e77f20677de9b94bb5c40999e4712 SHA512 46ad79335e51a1ec0aaa34ab5eeabe9d007818c518682409c5aaf97d49ec23021ece8fa53264ce5332cdd04ef6b3fd9beff0dc0a3cb5dfe2f9b6a6e359f8c1cf
-DIST sandbox-2.14.tar.xz 426992 BLAKE2B a30984f613b773cb5e53b2b0297ada32d11797699418aebf3014e11f3ec2b69a1c4b4e22ce96c28b1df022617cab6787cfe61f84b37ed61e966ac425eae1c7eb SHA512 b84584cffc54678646798bc58d8b60cdc10a0a58c9f1a49276dcac205a06dd7a2e664d2a9c40c78b48eae8ac36e3ac498ba35674f10e6e06c3c2bab777e05ced
-DIST sandbox-2.15.tar.xz 426948 BLAKE2B e40bb728192ef3793a9129bc88a63878516b0977a19effd5b02ded644ec6fe1627fab34786b22024957d96725fc5c53f488f7b09119be7b7ca91692dcee985dc SHA512 7249b594864267311ce8e2c04275df49c6d8e8e811dde5780f7f676cb43928728b9abed77beb8f5ee32061efcdb03753cce44d5bf1827bd519d6be8fa54912e6
-DIST sandbox-2.17.tar.xz 431700 BLAKE2B 461404f5b98ac83d9e5bc63fc7251cdfbb04a0ccedb340a7a5b8595b68ab34034a56c0a0cfa8478961c9282f6450de89ef5b512b13d427a7f63c17a4141cbcbf SHA512 b5d7a76d894471f6610b41aa05f007d257c69ae5c90f8db455d626e0d1209b9d276678c36e90d2e4214d15074512be182b4f5f905ed2b7e236ff714cbf51958f
diff --git a/sys-apps/sandbox/files/09sandbox b/sys-apps/sandbox/files/09sandbox
deleted file mode 100644
index 9181eb06..00000000
--- a/sys-apps/sandbox/files/09sandbox
+++ /dev/null
@@ -1 +0,0 @@
-CONFIG_PROTECT_MASK="/etc/sandbox.d"
diff --git a/sys-apps/sandbox/files/sandbox-2.10-fix-visibility-musl.patch b/sys-apps/sandbox/files/sandbox-2.10-fix-visibility-musl.patch
deleted file mode 100644
index 799908fc..00000000
--- a/sys-apps/sandbox/files/sandbox-2.10-fix-visibility-musl.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Naur sandbox-2.10.orig/scripts/gen_symbol_version_map.awk sandbox-2.10/scripts/gen_symbol_version_map.awk
---- sandbox-2.10.orig/scripts/gen_symbol_version_map.awk 2009-08-26 01:59:48.000000000 -0400
-+++ sandbox-2.10/scripts/gen_symbol_version_map.awk 2016-01-22 23:32:41.602858004 -0500
-@@ -14,7 +14,7 @@
-
- # Only check FUNCtion symbols which are not LOCAL, or
- # do not have DEFAULT visibility
-- if ($4 != "FUNC" || $5 == "LOCAL" || $6 != "DEFAULT")
-+ if ($4 != "FUNC" || $5 == "LOCAL" || ($6 != "DEFAULT" && $6 != "PROTECTED"))
- next;
-
- for (x in SYMBOLS) {
diff --git a/sys-apps/sandbox/files/sandbox-2.11-musl.patch b/sys-apps/sandbox/files/sandbox-2.11-musl.patch
deleted file mode 100644
index a99dd9ad..00000000
--- a/sys-apps/sandbox/files/sandbox-2.11-musl.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-diff -Naur sandbox-2.11.orig/headers.h sandbox-2.11/headers.h
---- sandbox-2.11.orig/headers.h 2015-09-26 23:20:27.000000000 -0700
-+++ sandbox-2.11/headers.h 2016-03-29 10:35:14.716185990 -0700
-@@ -151,9 +151,11 @@
- #ifdef HAVE_ASM_PTRACE_H
- # include <asm/ptrace.h>
- #endif
-+/*
- #ifdef HAVE_LINUX_PTRACE_H
- # include <linux/ptrace.h>
- #endif
-+*/
- #undef FU_ia64_fpreg
- #undef FU_pt_all_user_regs
-
-diff -Naur sandbox-2.11.orig/libsandbox/trace.c sandbox-2.11/libsandbox/trace.c
---- sandbox-2.11.orig/libsandbox/trace.c 2016-03-29 03:01:35.000000000 -0700
-+++ sandbox-2.11/libsandbox/trace.c 2016-03-29 10:32:19.581906031 -0700
-@@ -10,7 +10,7 @@
- #include "sb_nr.h"
-
- static long do_peekdata(long offset);
--static long _do_ptrace(enum __ptrace_request request, const char *srequest, void *addr, void *data);
-+static long _do_ptrace(int request, const char *srequest, void *addr, void *data);
- #define do_ptrace(request, addr, data) _do_ptrace(request, #request, addr, data)
- #define _trace_possible(data) true
-
-@@ -44,7 +44,7 @@
- _exit(status);
- }
-
--static long _do_ptrace(enum __ptrace_request request, const char *srequest, void *addr, void *data)
-+static long _do_ptrace(int request, const char *srequest, void *addr, void *data)
- {
- long ret;
- try_again:
-diff -Naur sandbox-2.11.orig/scripts/gen_symbol_header.awk sandbox-2.11/scripts/gen_symbol_header.awk
---- sandbox-2.11.orig/scripts/gen_symbol_header.awk 2009-08-25 22:59:48.000000000 -0700
-+++ sandbox-2.11/scripts/gen_symbol_header.awk 2016-03-29 10:33:37.236471898 -0700
-@@ -161,7 +161,7 @@
- else
- printf("symbol_version(%s, %s, %s);\n",
- sym_real_name, sym_index, symbol_array[2]);
-- } else {
-+ } else if (!(sym_index ~ 64)) {
- # For non-versioned libc's we use strong aliases
- printf("strong_alias(%s, %s);\n", sym_real_name,
- sym_index);
diff --git a/sys-apps/sandbox/files/sandbox-2.14-musl.patch b/sys-apps/sandbox/files/sandbox-2.14-musl.patch
deleted file mode 100644
index bdc852db..00000000
--- a/sys-apps/sandbox/files/sandbox-2.14-musl.patch
+++ /dev/null
@@ -1,51 +0,0 @@
-diff -Naur sandbox-2.14.orig/headers.h sandbox-2.14/headers.h
---- sandbox-2.14.orig/headers.h 2018-02-19 15:48:16.000000000 +0000
-+++ sandbox-2.14/headers.h 2019-09-09 15:38:19.826000640 +0000
-@@ -148,12 +148,14 @@
- # define ia64_fpreg FU_ia64_fpreg
- # define pt_all_user_regs FU_pt_all_user_regs
- #endif
-+/*
- #ifdef HAVE_ASM_PTRACE_H
- # include <asm/ptrace.h>
- #endif
- #ifdef HAVE_LINUX_PTRACE_H
- # include <linux/ptrace.h>
- #endif
-+*/
- #undef FU_ia64_fpreg
- #undef FU_pt_all_user_regs
-
-diff -Naur sandbox-2.14.orig/libsandbox/trace.c sandbox-2.14/libsandbox/trace.c
---- sandbox-2.14.orig/libsandbox/trace.c 2018-02-19 15:48:16.000000000 +0000
-+++ sandbox-2.14/libsandbox/trace.c 2019-09-09 15:38:07.614344692 +0000
-@@ -10,7 +10,7 @@
- #include "sb_nr.h"
-
- static long do_peekdata(long offset);
--static long _do_ptrace(enum __ptrace_request request, const char *srequest, void *addr, void *data);
-+static long _do_ptrace(int request, const char *srequest, void *addr, void *data);
- #define do_ptrace(request, addr, data) _do_ptrace(request, #request, addr, data)
- #define _trace_possible(data) true
-
-@@ -44,7 +44,7 @@
- _exit(status);
- }
-
--static long _do_ptrace(enum __ptrace_request request, const char *srequest, void *addr, void *data)
-+static long _do_ptrace(int request, const char *srequest, void *addr, void *data)
- {
- long ret;
- try_again:
-diff -Naur sandbox-2.14.orig/scripts/gen_symbol_header.awk sandbox-2.14/scripts/gen_symbol_header.awk
---- sandbox-2.14.orig/scripts/gen_symbol_header.awk 2018-02-19 15:48:16.000000000 +0000
-+++ sandbox-2.14/scripts/gen_symbol_header.awk 2019-09-09 15:38:07.614344692 +0000
-@@ -161,7 +161,7 @@
- else
- printf("symbol_version(%s, %s, %s);\n",
- sym_real_name, sym_index, symbol_array[2]);
-- } else {
-+ } else if (!(sym_index ~ 64)) {
- # For non-versioned libc's we use strong aliases
- printf("strong_alias(%s, %s);\n", sym_real_name,
- sym_index);
diff --git a/sys-apps/sandbox/metadata.xml b/sys-apps/sandbox/metadata.xml
deleted file mode 100644
index 1cdc968e..00000000
--- a/sys-apps/sandbox/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
- <email>sandbox@gentoo.org</email>
- <name>Sandbox Maintainers</name>
-</maintainer>
-</pkgmetadata>
diff --git a/sys-apps/sandbox/sandbox-2.12.ebuild b/sys-apps/sandbox/sandbox-2.12.ebuild
deleted file mode 100644
index 8a4281d4..00000000
--- a/sys-apps/sandbox/sandbox-2.12.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-inherit eutils flag-o-matic multilib-minimal multiprocessing pax-utils
-
-DESCRIPTION="sandbox'd LD_PRELOAD hack"
-HOMEPAGE="https://www.gentoo.org/proj/en/portage/sandbox/"
-SRC_URI="https://dev.gentoo.org/~mgorny/dist/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~mips ppc ppc64 x86"
-IUSE=""
-
-DEPEND="app-arch/xz-utils
- >=app-misc/pax-utils-0.1.19" #265376
-RDEPEND=""
-
-has sandbox_death_notice ${EBUILD_DEATH_HOOKS} || EBUILD_DEATH_HOOKS="${EBUILD_DEATH_HOOKS} sandbox_death_notice"
-
-sandbox_death_notice() {
- ewarn "If configure failed with a 'cannot run C compiled programs' error, try this:"
- ewarn "FEATURES='-sandbox -usersandbox' emerge sandbox"
-}
-
-src_prepare() {
- eapply "${FILESDIR}"/${PN}-2.11-musl.patch
- eapply "${FILESDIR}"/${PN}-2.10-fix-visibility-musl.patch
- eapply_user
-}
-
-multilib_src_configure() {
- filter-lfs-flags #90228
-
- local myconf=()
- host-is-pax && myconf+=( --disable-pch ) #301299 #425524 #572092
-
- ECONF_SOURCE="${S}" \
- econf "${myconf[@]}"
-}
-
-multilib_src_test() {
- # Default sandbox build will run with --jobs set to # cpus.
- emake check TESTSUITEFLAGS="--jobs=$(makeopts_jobs)"
-}
-
-multilib_src_install_all() {
- doenvd "${FILESDIR}"/09sandbox
-
- keepdir /var/log/sandbox
- fowners root:portage /var/log/sandbox
- fperms 0770 /var/log/sandbox
-
- dodoc AUTHORS ChangeLog* NEWS README
-}
-
-pkg_preinst() {
- chown root:portage "${ED}"/var/log/sandbox
- chmod 0770 "${ED}"/var/log/sandbox
-
- local v
- for v in ${REPLACING_VERSIONS}; do
- if [[ ${v} == 1.* ]] ; then
- local old=$(find "${EROOT}"/lib* -maxdepth 1 -name 'libsandbox*')
- if [[ -n ${old} ]] ; then
- elog "Removing old sandbox libraries for you:"
- find "${EROOT}"/lib* -maxdepth 1 -name 'libsandbox*' -print -delete
- fi
- fi
- done
-}
-
-pkg_postinst() {
- local v
- for v in ${REPLACING_VERSIONS}; do
- if [[ ${v} == 1.* ]] ; then
- chmod 0755 "${EROOT}"/etc/sandbox.d #265376
- fi
- done
-}
diff --git a/sys-apps/sandbox/sandbox-2.13.ebuild b/sys-apps/sandbox/sandbox-2.13.ebuild
deleted file mode 100644
index 9564ec6d..00000000
--- a/sys-apps/sandbox/sandbox-2.13.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-inherit eutils flag-o-matic multilib-minimal multiprocessing pax-utils
-
-DESCRIPTION="sandbox'd LD_PRELOAD hack"
-HOMEPAGE="https://www.gentoo.org/proj/en/portage/sandbox/"
-SRC_URI="https://dev.gentoo.org/~mgorny/dist/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~mips ppc ppc64 x86"
-IUSE=""
-
-DEPEND="app-arch/xz-utils
- >=app-misc/pax-utils-0.1.19" #265376
-RDEPEND=""
-
-has sandbox_death_notice ${EBUILD_DEATH_HOOKS} || EBUILD_DEATH_HOOKS="${EBUILD_DEATH_HOOKS} sandbox_death_notice"
-
-sandbox_death_notice() {
- ewarn "If configure failed with a 'cannot run C compiled programs' error, try this:"
- ewarn "FEATURES='-sandbox -usersandbox' emerge sandbox"
-}
-
-src_prepare() {
- eapply "${FILESDIR}"/${PN}-2.11-musl.patch
- eapply "${FILESDIR}"/${PN}-2.10-fix-visibility-musl.patch
- eapply_user
-}
-
-multilib_src_configure() {
- filter-lfs-flags #90228
-
- local myconf=()
- host-is-pax && myconf+=( --disable-pch ) #301299 #425524 #572092
-
- ECONF_SOURCE="${S}" \
- econf "${myconf[@]}"
-}
-
-multilib_src_test() {
- # Default sandbox build will run with --jobs set to # cpus.
- emake check TESTSUITEFLAGS="--jobs=$(makeopts_jobs)"
-}
-
-multilib_src_install_all() {
- doenvd "${FILESDIR}"/09sandbox
-
- keepdir /var/log/sandbox
- fowners root:portage /var/log/sandbox
- fperms 0770 /var/log/sandbox
-
- dodoc AUTHORS ChangeLog* NEWS README
-}
-
-pkg_preinst() {
- chown root:portage "${ED}"/var/log/sandbox
- chmod 0770 "${ED}"/var/log/sandbox
-
- local v
- for v in ${REPLACING_VERSIONS}; do
- if [[ ${v} == 1.* ]] ; then
- local old=$(find "${EROOT}"/lib* -maxdepth 1 -name 'libsandbox*')
- if [[ -n ${old} ]] ; then
- elog "Removing old sandbox libraries for you:"
- find "${EROOT}"/lib* -maxdepth 1 -name 'libsandbox*' -print -delete
- fi
- fi
- done
-}
-
-pkg_postinst() {
- local v
- for v in ${REPLACING_VERSIONS}; do
- if [[ ${v} == 1.* ]] ; then
- chmod 0755 "${EROOT}"/etc/sandbox.d #265376
- fi
- done
-}
diff --git a/sys-apps/sandbox/sandbox-2.14.ebuild b/sys-apps/sandbox/sandbox-2.14.ebuild
deleted file mode 100644
index 7f67e7ce..00000000
--- a/sys-apps/sandbox/sandbox-2.14.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-inherit eutils flag-o-matic multilib-minimal multiprocessing pax-utils
-
-DESCRIPTION="sandbox'd LD_PRELOAD hack"
-HOMEPAGE="https://www.gentoo.org/proj/en/portage/sandbox/"
-SRC_URI="https://dev.gentoo.org/~mgorny/dist/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm arm64 ~mips ~ppc ~ppc64 ~x86"
-IUSE=""
-
-DEPEND="app-arch/xz-utils
- >=app-misc/pax-utils-0.1.19" #265376
-RDEPEND=""
-
-has sandbox_death_notice ${EBUILD_DEATH_HOOKS} || EBUILD_DEATH_HOOKS="${EBUILD_DEATH_HOOKS} sandbox_death_notice"
-
-sandbox_death_notice() {
- ewarn "If configure failed with a 'cannot run C compiled programs' error, try this:"
- ewarn "FEATURES='-sandbox -usersandbox' emerge sandbox"
-}
-
-src_prepare() {
- eapply "${FILESDIR}"/${PN}-2.14-musl.patch
- eapply "${FILESDIR}"/${PN}-2.10-fix-visibility-musl.patch
- eapply_user
-}
-
-multilib_src_configure() {
- filter-lfs-flags #90228
-
- local myconf=()
- host-is-pax && myconf+=( --disable-pch ) #301299 #425524 #572092
-
- ECONF_SOURCE="${S}" \
- econf "${myconf[@]}"
-}
-
-multilib_src_test() {
- # Default sandbox build will run with --jobs set to # cpus.
- emake check TESTSUITEFLAGS="--jobs=$(makeopts_jobs)"
-}
-
-multilib_src_install_all() {
- doenvd "${FILESDIR}"/09sandbox
-
- keepdir /var/log/sandbox
- fowners root:portage /var/log/sandbox
- fperms 0770 /var/log/sandbox
-
- dodoc AUTHORS ChangeLog* NEWS README
-}
-
-pkg_preinst() {
- chown root:portage "${ED}"/var/log/sandbox
- chmod 0770 "${ED}"/var/log/sandbox
-
- local v
- for v in ${REPLACING_VERSIONS}; do
- if [[ ${v} == 1.* ]] ; then
- local old=$(find "${EROOT}"/lib* -maxdepth 1 -name 'libsandbox*')
- if [[ -n ${old} ]] ; then
- elog "Removing old sandbox libraries for you:"
- find "${EROOT}"/lib* -maxdepth 1 -name 'libsandbox*' -print -delete
- fi
- fi
- done
-}
-
-pkg_postinst() {
- local v
- for v in ${REPLACING_VERSIONS}; do
- if [[ ${v} == 1.* ]] ; then
- chmod 0755 "${EROOT}"/etc/sandbox.d #265376
- fi
- done
-}
diff --git a/sys-apps/sandbox/sandbox-2.15.ebuild b/sys-apps/sandbox/sandbox-2.15.ebuild
deleted file mode 100644
index e239b90b..00000000
--- a/sys-apps/sandbox/sandbox-2.15.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-inherit eutils flag-o-matic multilib-minimal multiprocessing pax-utils
-
-DESCRIPTION="sandbox'd LD_PRELOAD hack"
-HOMEPAGE="https://www.gentoo.org/proj/en/portage/sandbox/"
-SRC_URI="https://dev.gentoo.org/~mgorny/dist/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~x86"
-IUSE=""
-
-DEPEND="app-arch/xz-utils
- >=app-misc/pax-utils-0.1.19" #265376
-RDEPEND=""
-
-has sandbox_death_notice ${EBUILD_DEATH_HOOKS} || EBUILD_DEATH_HOOKS="${EBUILD_DEATH_HOOKS} sandbox_death_notice"
-
-sandbox_death_notice() {
- ewarn "If configure failed with a 'cannot run C compiled programs' error, try this:"
- ewarn "FEATURES='-sandbox -usersandbox' emerge sandbox"
-}
-
-src_prepare() {
- eapply "${FILESDIR}"/${PN}-2.15-musl.patch
- eapply "${FILESDIR}"/${PN}-2.10-fix-visibility-musl.patch
- eapply_user
-}
-
-multilib_src_configure() {
- filter-lfs-flags #90228
-
- local myconf=()
- host-is-pax && myconf+=( --disable-pch ) #301299 #425524 #572092
-
- ECONF_SOURCE="${S}" \
- econf "${myconf[@]}"
-}
-
-multilib_src_test() {
- # Default sandbox build will run with --jobs set to # cpus.
- emake check TESTSUITEFLAGS="--jobs=$(makeopts_jobs)"
-}
-
-multilib_src_install_all() {
- doenvd "${FILESDIR}"/09sandbox
-
- keepdir /var/log/sandbox
- fowners root:portage /var/log/sandbox
- fperms 0770 /var/log/sandbox
-
- dodoc AUTHORS ChangeLog* NEWS README
-}
-
-pkg_preinst() {
- chown root:portage "${ED}"/var/log/sandbox
- chmod 0770 "${ED}"/var/log/sandbox
-
- local v
- for v in ${REPLACING_VERSIONS}; do
- if [[ ${v} == 1.* ]] ; then
- local old=$(find "${EROOT}"/lib* -maxdepth 1 -name 'libsandbox*')
- if [[ -n ${old} ]] ; then
- elog "Removing old sandbox libraries for you:"
- find "${EROOT}"/lib* -maxdepth 1 -name 'libsandbox*' -print -delete
- fi
- fi
- done
-}
-
-pkg_postinst() {
- local v
- for v in ${REPLACING_VERSIONS}; do
- if [[ ${v} == 1.* ]] ; then
- chmod 0755 "${EROOT}"/etc/sandbox.d #265376
- fi
- done
-}
diff --git a/sys-apps/sandbox/sandbox-2.17.ebuild b/sys-apps/sandbox/sandbox-2.17.ebuild
deleted file mode 100644
index 7b8649c8..00000000
--- a/sys-apps/sandbox/sandbox-2.17.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-inherit eutils flag-o-matic multilib-minimal multiprocessing pax-utils
-
-DESCRIPTION="sandbox'd LD_PRELOAD hack"
-HOMEPAGE="https://www.gentoo.org/proj/en/portage/sandbox/"
-SRC_URI="https://dev.gentoo.org/~dilfridge/distfiles/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~x86"
-IUSE=""
-
-DEPEND="app-arch/xz-utils
- >=app-misc/pax-utils-0.1.19" #265376
-RDEPEND=""
-
-has sandbox_death_notice ${EBUILD_DEATH_HOOKS} || EBUILD_DEATH_HOOKS="${EBUILD_DEATH_HOOKS} sandbox_death_notice"
-
-sandbox_death_notice() {
- ewarn "If configure failed with a 'cannot run C compiled programs' error, try this:"
- ewarn "FEATURES='-sandbox -usersandbox' emerge sandbox"
-}
-
-src_prepare() {
- eapply "${FILESDIR}"/${PN}-2.14-musl.patch
- eapply "${FILESDIR}"/${PN}-2.10-fix-visibility-musl.patch
- eapply_user
-}
-
-multilib_src_configure() {
- filter-lfs-flags #90228
-
- ECONF_SOURCE="${S}" econf
-}
-
-multilib_src_test() {
- # Default sandbox build will run with --jobs set to # cpus.
- emake check TESTSUITEFLAGS="--jobs=$(makeopts_jobs)"
-}
-
-multilib_src_install_all() {
- doenvd "${FILESDIR}"/09sandbox
-
- keepdir /var/log/sandbox
- fowners root:portage /var/log/sandbox
- fperms 0770 /var/log/sandbox
-
- dodoc AUTHORS ChangeLog* NEWS README
-}
-
-pkg_preinst() {
- chown root:portage "${ED}"/var/log/sandbox
- chmod 0770 "${ED}"/var/log/sandbox
-
- local v
- for v in ${REPLACING_VERSIONS}; do
- if [[ ${v} == 1.* ]] ; then
- local old=$(find "${EROOT}"/lib* -maxdepth 1 -name 'libsandbox*')
- if [[ -n ${old} ]] ; then
- elog "Removing old sandbox libraries for you:"
- find "${EROOT}"/lib* -maxdepth 1 -name 'libsandbox*' -print -delete
- fi
- fi
- done
-}
-
-pkg_postinst() {
- local v
- for v in ${REPLACING_VERSIONS}; do
- if [[ ${v} == 1.* ]] ; then
- chmod 0755 "${EROOT}"/etc/sandbox.d #265376
- fi
- done
-}