summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2009-07-06 01:10:00 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2009-07-06 01:11:45 -0700
commit89dbf609d084eb353c048afa499aba953949f102 (patch)
treee064822e109ee3a077a475a647900a09ce3aa5b3 /07140_all_no-atomic-configure.patch
parentFix bug #271475, #elif not valid without an argument. Use #else instead. (diff)
downloadmysql-extras-89dbf609d084eb353c048afa499aba953949f102.tar.gz
mysql-extras-89dbf609d084eb353c048afa499aba953949f102.tar.bz2
mysql-extras-89dbf609d084eb353c048afa499aba953949f102.zip
Need to use 5 digits of numbering now. LOTS of patches to track.
Diffstat (limited to '07140_all_no-atomic-configure.patch')
-rw-r--r--07140_all_no-atomic-configure.patch60
1 files changed, 60 insertions, 0 deletions
diff --git a/07140_all_no-atomic-configure.patch b/07140_all_no-atomic-configure.patch
new file mode 100644
index 0000000..df4167f
--- /dev/null
+++ b/07140_all_no-atomic-configure.patch
@@ -0,0 +1,60 @@
+Patch borrowed from CentOS mysql-no-atomic.patch
+
+The idea of userland using <asm/atomic.h> has our kernel hackers all bent
+out of shape, so don't do it. Suppressing this has another benefit too,
+which is we avoid the 4-vs-8-byte problem in BDB that formerly required
+mysql-threads.patch.
+
+
+diff -Naur mysql-5.0.28.orig/configure.in mysql-5.0.28/configure.in
+--- mysql-5.0.28.orig/configure.in 2006-10-24 17:03:51.000000000 -0400
++++ mysql-5.0.28/configure.in 2006-11-29 17:39:39.000000000 -0500
+@@ -814,48 +814,6 @@
+ AC_SUBST(WRAPLIBS)
+
+ if test "$TARGET_LINUX" = "true"; then
+- AC_MSG_CHECKING([for atomic operations])
+-
+- AC_LANG_SAVE
+- AC_LANG_CPLUSPLUS
+-
+- atom_ops=
+- AC_TRY_RUN([
+-#include <asm/atomic.h>
+-int main()
+-{
+- atomic_t v;
+-
+- atomic_set(&v, 23);
+- atomic_add(5, &v);
+- return atomic_read(&v) == 28 ? 0 : -1;
+-}
+- ],
+- [AC_DEFINE([HAVE_ATOMIC_ADD], [1],
+- [atomic_add() from <asm/atomic.h> (Linux only)])
+- atom_ops="${atom_ops}atomic_add "],
+- )
+- AC_TRY_RUN([
+-#include <asm/atomic.h>
+-int main()
+-{
+- atomic_t v;
+-
+- atomic_set(&v, 23);
+- atomic_sub(5, &v);
+- return atomic_read(&v) == 18 ? 0 : -1;
+-}
+- ],
+- [AC_DEFINE([HAVE_ATOMIC_SUB], [1],
+- [atomic_sub() from <asm/atomic.h> (Linux only)])
+- atom_ops="${atom_ops}atomic_sub "],
+- )
+-
+- if test -z "$atom_ops"; then atom_ops="no"; fi
+- AC_MSG_RESULT($atom_ops)
+-
+- AC_LANG_RESTORE
+-
+ AC_ARG_WITH(pstack,
+ [ --with-pstack Use the pstack backtrace library],
+ [ USE_PSTACK=$withval ],