summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-08-02 02:13:03 +0200
committerThomas Deutschmann <whissi@gentoo.org>2019-08-02 02:13:03 +0200
commit4945033d7f4438ec0baf76975ffd07208630d685 (patch)
tree6352a1adbeb1fa9a08a98a5c0db16049d88ffa84 /20001_all_fix-minimal-build-cmake-mysql-8.0.17.patch
parentFix custom plugin location for MariaDB >=10.4 (diff)
downloadmysql-extras-4945033d7f4438ec0baf76975ffd07208630d685.tar.gz
mysql-extras-4945033d7f4438ec0baf76975ffd07208630d685.tar.bz2
mysql-extras-4945033d7f4438ec0baf76975ffd07208630d685.zip
Add initial MySQL v8.0 patch setmysql-extras-20190802-0014Z
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to '20001_all_fix-minimal-build-cmake-mysql-8.0.17.patch')
-rw-r--r--20001_all_fix-minimal-build-cmake-mysql-8.0.17.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/20001_all_fix-minimal-build-cmake-mysql-8.0.17.patch b/20001_all_fix-minimal-build-cmake-mysql-8.0.17.patch
new file mode 100644
index 0000000..d79ffe2
--- /dev/null
+++ b/20001_all_fix-minimal-build-cmake-mysql-8.0.17.patch
@@ -0,0 +1,26 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -1117,7 +1117,9 @@ MYSQL_CHECK_SSL_DLLS()
+ # Add system/bundled editline.
+ MYSQL_CHECK_EDITLINE()
+ # Add libevent
+-MYSQL_CHECK_LIBEVENT()
++IF(NOT WITHOUT_SERVER)
++ MYSQL_CHECK_LIBEVENT()
++ENDIF()
+ # Add lz4 library
+ MYSQL_CHECK_LZ4()
+ # Add re2 library
+@@ -1261,11 +1263,11 @@ ENDIF()
+ # scripts/mysql_config depends on client and server targets loaded above.
+ # It is referenced by some of the directories below, so we insert it here.
+ ADD_SUBDIRECTORY(scripts)
++ADD_SUBDIRECTORY(support-files)
+
+ IF(NOT WITHOUT_SERVER)
+ ADD_SUBDIRECTORY(mysql-test)
+ ADD_SUBDIRECTORY(mysql-test/lib/My/SafeProcess)
+- ADD_SUBDIRECTORY(support-files)
+ IF(EXISTS ${CMAKE_SOURCE_DIR}/internal/CMakeLists.txt)
+ ADD_SUBDIRECTORY(internal)
+ ENDIF()