summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2017-01-28 20:25:51 -0500
committerBrian Evans <grknight@gentoo.org>2017-01-28 20:25:51 -0500
commit3e33db00d27d450361a6e443d9c555775572378e (patch)
tree4cdf041b1641c17da0a085d53149c1b03af0b01a /20022_all_mariadb-10.0.29-minizip.patch
parentRespin elib patch for percona 5.6.34 (diff)
downloadmysql-extras-3e33db00d27d450361a6e443d9c555775572378e.tar.gz
mysql-extras-3e33db00d27d450361a6e443d9c555775572378e.tar.bz2
mysql-extras-3e33db00d27d450361a6e443d9c555775572378e.zip
Fix support for minizip in Mariadb ConnectSE
Diffstat (limited to '20022_all_mariadb-10.0.29-minizip.patch')
-rw-r--r--20022_all_mariadb-10.0.29-minizip.patch57
1 files changed, 57 insertions, 0 deletions
diff --git a/20022_all_mariadb-10.0.29-minizip.patch b/20022_all_mariadb-10.0.29-minizip.patch
new file mode 100644
index 0000000..12859d3
--- /dev/null
+++ b/20022_all_mariadb-10.0.29-minizip.patch
@@ -0,0 +1,57 @@
+diff -aruN a/storage/connect/CMakeLists.txt b/storage/connect/CMakeLists.txt
+--- a/storage/connect/CMakeLists.txt 2017-01-11 20:45:20.000000000 -0500
++++ b/storage/connect/CMakeLists.txt 2017-01-22 21:11:15.000000000 -0500
+@@ -286,8 +286,13 @@
+ OPTION(CONNECT_WITH_ZIP "Compile CONNECT storage engine with ZIP support" ON)
+
+ IF(CONNECT_WITH_ZIP)
+- SET(CONNECT_SOURCES ${CONNECT_SOURCES} filamzip.cpp tabzip.cpp unzip.c ioapi.c zip.c
+- filamzip.h tabzip.h ioapi.h unzip.h zip.h)
++ SET(CONNECT_SOURCES ${CONNECT_SOURCES} filamzip.cpp tabzip.cpp filamzip.h tabzip.h)
++ pkg_check_modules(MINIZIP minizip)
++ if(MINIZIP_FOUND) # Use system version
++ add_definitions(-DMINIZIP_FOUND)
++ else()
++ SET(CONNECT_SOURCES ${CONNECT_SOURCES} unzip.c ioapi.c zip.c ioapi.h unzip.h zip.h)
++ endif(MINIZIP_FOUND)
+ add_definitions(-DZIP_SUPPORT -DNOCRYPT)
+ ENDIF(CONNECT_WITH_ZIP)
+
+@@ -311,5 +316,6 @@
+ COMPONENT connect-engine
+ RECOMPILE_FOR_EMBEDDED
+ LINK_LIBRARIES ${ZLIB_LIBRARY} ${XML_LIBRARY} ${ICONV_LIBRARY}
+- ${ODBC_LIBRARY} ${JDBC_LIBRARY} ${IPHLPAPI_LIBRARY})
++ ${ODBC_LIBRARY} ${JDBC_LIBRARY} ${IPHLPAPI_LIBRARY}
++ ${MINIZIP_LIBRARIES})
+
+diff -aruN a/storage/connect/filamzip.h b/storage/connect/filamzip.h
+--- a/storage/connect/filamzip.h 2017-01-11 20:45:20.000000000 -0500
++++ b/storage/connect/filamzip.h 2017-01-17 22:12:54.000000000 -0500
+@@ -10,7 +10,11 @@
+
+ #include "block.h"
+ #include "filamap.h"
++#ifdef MINIZIP_FOUND
++#include "minizip/unzip.h"
++#else
+ #include "unzip.h"
++#endif
+
+ #define DLLEXPORT extern "C"
+
+diff -aruN a/storage/connect/tabzip.h b/storage/connect/tabzip.h
+--- a/storage/connect/tabzip.h 2017-01-11 20:45:21.000000000 -0500
++++ b/storage/connect/tabzip.h 2017-01-17 22:13:18.000000000 -0500
+@@ -9,7 +9,11 @@
+ #include "block.h"
+ #include "colblk.h"
+ #include "xtable.h"
++#ifdef MINIZIP_FOUND
++#include "minizip/unzip.h"
++#else
+ #include "unzip.h"
++#endif
+
+ typedef class ZIPDEF *PZIPDEF;
+ typedef class TDBZIP *PTDBZIP;