summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2018-10-22 20:11:47 -0400
committerBrian Evans <grknight@gentoo.org>2018-10-22 20:11:47 -0400
commit27250c4031ebd8502062cea753ade01d155a486c (patch)
treec35876139fe09415a9417775b1682b5a23f03444
parentUpdate 20018_all_mysql-5.7.23-fix-libressl-support.patch (diff)
downloadmysql-extras-27250c4031ebd8502062cea753ade01d155a486c.tar.gz
mysql-extras-27250c4031ebd8502062cea753ade01d155a486c.tar.bz2
mysql-extras-27250c4031ebd8502062cea753ade01d155a486c.zip
Respin minimal build patch for bug 669236mysql-extras-20181023-0012Z
Signed-off-by: Brian Evans <grknight@gentoo.org>
-rw-r--r--20001_all_fix-minimal-build-cmake-mysql-5.7.23.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/20001_all_fix-minimal-build-cmake-mysql-5.7.23.patch b/20001_all_fix-minimal-build-cmake-mysql-5.7.23.patch
new file mode 100644
index 0000000..915ad1d
--- /dev/null
+++ b/20001_all_fix-minimal-build-cmake-mysql-5.7.23.patch
@@ -0,0 +1,26 @@
+diff -aurwN mysql.orig/CMakeLists.txt mysql/CMakeLists.txt
+--- a/CMakeLists.txt 2014-07-18 11:48:39.000000000 -0400
++++ b/CMakeLists.txt 2014-08-01 12:54:52.612732241 -0400
+@@ -531,7 +531,9 @@
+ # Add bundled yassl/taocrypt or system openssl.
+ MYSQL_CHECK_SSL()
+ # Add libevent
+-MYSQL_CHECK_LIBEVENT()
++IF(NOT WITHOUT_SERVER)
++ MYSQL_CHECK_LIBEVENT()
++ENDIF()
+ # Add lz4 library
+ MYSQL_CHECK_LZ4()
+ # Add protoc and libprotobuf
+@@ -626,10 +626,10 @@
+ # scripts/mysql_config depends on client and server targets loaded above.
+ # It is referenced by some of the directories below, so we insert it here.
+ ADD_SUBDIRECTORY(scripts)
++ADD_SUBDIRECTORY(support-files)
+
+ IF(NOT WITHOUT_SERVER)
+ ADD_SUBDIRECTORY(mysql-test)
+ ADD_SUBDIRECTORY(mysql-test/lib/My/SafeProcess)
+- ADD_SUBDIRECTORY(support-files)
+ IF(EXISTS ${CMAKE_SOURCE_DIR}/internal/CMakeLists.txt)
+ ADD_SUBDIRECTORY(internal)