aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac47
1 files changed, 47 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..5abb61c
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,47 @@
+AC_PREREQ([2.60])
+AC_INIT([openrc-settingsd], [0])
+AC_CONFIG_SRCDIR([src/main.c])
+AM_INIT_AUTOMAKE([check-news foreign 1.11 -Wall -Wno-portability silent-rules tar-pax no-dist-gzip dist-xz])
+AC_PROG_CC_STDC
+AC_USE_SYSTEM_EXTENSIONS
+AC_CONFIG_MACRO_DIR([m4])
+AM_SILENT_RULES([yes])
+LT_INIT([disable-static pic-only])
+AC_PREFIX_DEFAULT([/usr])
+
+AC_PROG_MKDIR_P
+PKG_CHECK_MODULES(OPENRC_SETTINGSD, [gio-unix-2.0 >= 2.30 gio-2.0 >= 2.30 glib-2.0 >= 2.30 dbus-1 polkit-gobject-1])
+AC_SUBST(OPENRC_SETTINGSD_CFLAGS)
+AC_SUBST(OPENRC_SETTINGSD_LIBS)
+
+AC_PATH_PROG(GDBUS_CODEGEN, gdbus-codegen)
+if test "x$GDBUS_CODEGEN" = x; then
+ AC_MSG_ERROR([Failed to find gdbus-codegen])
+fi
+
+AC_ARG_ENABLE([debug],
+ [AS_HELP_STRING([--enable-debug],
+ [enable extra debugging messages])],
+ [], [enable_debug=no])
+if test "x$enable_debug" = "xyes" ; then
+ AC_MSG_RESULT([enabling extra debugging messages])
+ AC_DEFINE(OPENRC_SETTINGSD_DEBUG,1,[Enable extra debugging messages.])
+fi
+
+AC_CONFIG_HEADERS([config.h])
+AC_CONFIG_FILES([
+ Makefile
+])
+
+AC_OUTPUT
+AC_MSG_RESULT([
+ $PACKAGE $VERSION
+ =====
+
+ prefix: ${prefix}
+ sysconfdir: ${sysconfdir}
+
+ compiler: ${CC}
+ cflags: ${CFLAGS}
+ ldflags: ${LDFLAGS}
+])