aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathias Krause <minipli@grsecurity.net>2024-01-23 12:17:18 +0100
committerMike Gilbert <floppym@gentoo.org>2024-07-22 17:06:05 -0400
commit66417851bbfc2266513774e59aa32b36469a756b (patch)
tree33ccfb713cec128f1987cc07e12bb34e9ffe1b04
parentseccomp: make socket() fail with -ENOSYS (diff)
downloadpax-utils-66417851bbfc2266513774e59aa32b36469a756b.tar.gz
pax-utils-66417851bbfc2266513774e59aa32b36469a756b.tar.bz2
pax-utils-66417851bbfc2266513774e59aa32b36469a756b.zip
tests: add basic pspax test
Add a basic test that simply makes sure pspax executes just fine, i.e. doesn't get killed by the seccomp policy. Signed-off-by: Mathias Krause <minipli@grsecurity.net> Signed-off-by: Mike Gilbert <floppym@gentoo.org>
-rw-r--r--meson.build1
-rwxr-xr-xtests/pspax/dotest12
-rw-r--r--tests/pspax/meson.build8
3 files changed, 21 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 319e3de..64fcc14 100644
--- a/meson.build
+++ b/meson.build
@@ -140,6 +140,7 @@ meson.add_dist_script('meson-build-dist-man.sh')
do_tests = get_option('tests')
if do_tests
subdir('tests/lddtree')
+ subdir('tests/pspax')
subdir('tests/scanelf')
subdir('tests/source')
endif
diff --git a/tests/pspax/dotest b/tests/pspax/dotest
new file mode 100755
index 0000000..f2ccc98
--- /dev/null
+++ b/tests/pspax/dotest
@@ -0,0 +1,12 @@
+#!/bin/bash
+
+. "${0%/*}"/../lib.sh
+
+#
+# simple pspax execution check
+#
+${MESON_EXE_WRAPPER} sh -c "${builddir}/pspax" >/dev/null \
+ 2> "${builddir}"/pspax.err
+testit pspax.err
+
+exit ${ret}
diff --git a/tests/pspax/meson.build b/tests/pspax/meson.build
new file mode 100644
index 0000000..a00a96d
--- /dev/null
+++ b/tests/pspax/meson.build
@@ -0,0 +1,8 @@
+test('pspax-test', files('dotest'),
+ workdir : meson.current_source_dir(),
+ env : {
+ 'builddir' : meson.project_build_root(),
+ 'srcdir' : meson.project_source_root(),
+ 'current_srcdir' : meson.current_source_dir(),
+ }
+)