aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Harring <ferringb@gmail.com>2024-01-26 14:56:10 -0800
committerArthur Zamarin <arthurzam@gentoo.org>2024-03-09 20:07:10 +0200
commitb691ba46eeaf9ddd767519d977869b561a643841 (patch)
tree10198e8c7eb1459b99066a73d3b2b1a37ca46ead
parentGH: use whatever black version is defined in pyproject.toml (diff)
downloadpkgcore-b691ba46eeaf9ddd767519d977869b561a643841.tar.gz
pkgcore-b691ba46eeaf9ddd767519d977869b561a643841.tar.bz2
pkgcore-b691ba46eeaf9ddd767519d977869b561a643841.zip
Add `make dev-environment` to simplify setup for devs.
Signed-off-by: Brian Harring <ferringb@gmail.com> Closes: https://github.com/pkgcore/pkgcore/pull/433 Signed-off-by: Sam James <sam@gentoo.org> Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--Makefile4
-rw-r--r--README.rst8
2 files changed, 12 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 84ed70add..1efb6afd1 100644
--- a/Makefile
+++ b/Makefile
@@ -17,3 +17,7 @@ clean:
.PHONY: format
format:
$(PYTHON) -m black .
+
+.PHONY: dev-environment
+dev-environment:
+ $(PYTHON) -m pip install -e .[test,doc,formatter]
diff --git a/README.rst b/README.rst
index 7b18f6802..e02156aa0 100644
--- a/README.rst
+++ b/README.rst
@@ -52,6 +52,14 @@ Installing from a tarball::
pip install .
+Developing
+==========
+
+Installing the dependencies for testing, formatting, and documentation building
+into an editable environment::
+
+ make dev-environment
+
Tests
=====