summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Leverton <levertond@googlemail.com>2008-06-14 14:20:29 +0100
committerCiaran McCreesh <ciaran.mccreesh@googlemail.com>2008-06-15 11:20:47 +0100
commit9c6e9c7ddcf4e63fb6fa32772a94289a7c6f400d (patch)
tree4b73cf480777a12cd72315bf75b32080191e4146 /Makefile
parentMake --libdir not be interpreted as an en-dash. (diff)
downloadpms-9c6e9c7ddcf4e63fb6fa32772a94289a7c6f400d.tar.gz
pms-9c6e9c7ddcf4e63fb6fa32772a94289a7c6f400d.tar.bz2
pms-9c6e9c7ddcf4e63fb6fa32772a94289a7c6f400d.zip
Support HTML generation via tex4ht.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile16
1 files changed, 15 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 29731ac..774fc39 100644
--- a/Makefile
+++ b/Makefile
@@ -1,8 +1,9 @@
all : pms.pdf
+html : pms.html
clean :
rm -f *~ *.pdf *.dvi *.log *.aux *.bbl *.blg *.toc *.lol *.loa *.lox \
- *.lot *.out || true
+ *.lot *.out *.html *.css *.png *.4ct *.4tc *.idv *.lg *.tmp *.xref || true
LATEXFILES = $(shell ls *.tex)
LISTINGFILES = $(shell ls *.listing)
@@ -13,6 +14,19 @@ pms.pdf: $(SOURCEFILES) pms.bbl
pdflatex pms
pdflatex pms
+pms.html: $(SOURCEFILES) pms.bbl
+ @# need to do it twice to make the big env var table work
+ xhlatex pms
+ xhlatex pms
+ @# work around irregularity in how links to longtables are
+ @# formatted in the List of Tables
+ sed -i -e '/<span class="lotToc" >&#x00A0;/{N;N;s/\(&#x00A0;<a \nhref="[^"]\+">\)\([0-9.]\+\)\n/\2\1/}' pms.html
+ @# indent algorithms properly, and avoid adding extra vertical
+ @# space in Konqueror
+ sed -i -e 's/span style="width:/span style="display:-moz-inline-box;display:inline-block;height:1px;width:/' pms.html
+ @# align algorithm line numbers properly
+ sed -i -e '/<span class="ALCitem">/{N;s/\n\(class="[^"]\+">\)\([0-9]:\)<\/span>/\1\&#x2007;\2/}' pms.html
+
pms.bbl: pms.bib pms.tex
latex pms
bibtex pms