summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-01-08 08:58:34 +0100
committerMichał Górny <mgorny@gentoo.org>2020-01-08 09:47:39 +0100
commit90b611f2fbb851c528610780a16805b6182e166e (patch)
treeddf70dc09700b93543a4cf6aee5f3c1ce778800c /Makefile
downloadpolicy-guide-90b611f2fbb851c528610780a16805b6182e166e.tar.gz
policy-guide-90b611f2fbb851c528610780a16805b6182e166e.tar.bz2
policy-guide-90b611f2fbb851c528610780a16805b6182e166e.zip
Initial version
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile19
1 files changed, 19 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..1c9d813
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,19 @@
+# Minimal makefile for Sphinx documentation
+#
+
+# You can set these variables from the command line.
+SPHINXOPTS =
+SPHINXBUILD = sphinx-build
+SPHINXPROJ = GentooPolicyGuide
+SOURCEDIR = .
+BUILDDIR = _build
+
+html:
+ @$(SPHINXBUILD) -M $@ "$(SOURCEDIR)" "$(BUILDDIR)" $(SPHINXOPTS) $(O)
+
+.PHONY: html Makefile
+
+# Catch-all target: route all unknown targets to Sphinx using the new
+# "make mode" option. $(O) is meant as a shortcut for $(SPHINXOPTS).
+%: Makefile
+ @$(SPHINXBUILD) -M $@ "$(SOURCEDIR)" "$(BUILDDIR)" $(SPHINXOPTS) $(O)