aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2019-07-14 15:07:42 +0200
committerFabian Groffen <grobian@gentoo.org>2019-07-14 15:07:42 +0200
commit6e0f64cb72a3e2948fdb8b6a59aac9bb57223dc2 (patch)
tree9a9e468e6101ee8eb5e4f454b8c13caf504b48a9 /Makefile.am
parentlibq/hash: ensure hash_compute_file operates on hashes requested (diff)
downloadportage-utils-6e0f64cb72a3e2948fdb8b6a59aac9bb57223dc2.tar.gz
portage-utils-6e0f64cb72a3e2948fdb8b6a59aac9bb57223dc2.tar.bz2
portage-utils-6e0f64cb72a3e2948fdb8b6a59aac9bb57223dc2.zip
qtegrity: use libq/hash iso shelling out to shaXsum
Use libq/hash functionality (as used by qmanifest) in qtegrity to obtain hashes for files. This adds a dep on openssl currently, so allow disabling this applet. Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index fc0619c..e8b11f8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -64,7 +64,6 @@ q_SOURCES = \
qsearch.c \
qsize.c \
qtbz2.c \
- qtegrity.c \
quse.c \
qxpak.c \
$(NULL)
@@ -95,6 +94,18 @@ q_LDADD += \
dist_man_MANS += man/qmanifest.1
APPLETS += qmanifest
endif
+if QTEGRITY_ENABLED
+q_SOURCES += qtegrity.c
+if !QMANIFEST_ENABLED
+q_CPPFLAGS += \
+ $(OPENMP_CFLAGS)
+q_LDADD += \
+ $(OPENMP_CFLAGS)
+endif
+dist_man_MANS += man/qtegrity.1
+APPLETS += qtegrity
+endif
+
install-exec-hook:
cd $(DESTDIR)$(bindir); \