aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2019-03-18 14:11:41 +0100
committerFabian Groffen <grobian@gentoo.org>2019-03-18 14:13:19 +0100
commita221d981b4349b07d8b3869cb8ad2bb06d353a7a (patch)
tree1b3d480c25302c9d49d85884e292c10434421a99 /Makefile.am
parentq.c: move run_applet_l to its only consumer qmerge.c (diff)
downloadportage-utils-a221d981b4349b07d8b3869cb8ad2bb06d353a7a.tar.gz
portage-utils-a221d981b4349b07d8b3869cb8ad2bb06d353a7a.tar.bz2
portage-utils-a221d981b4349b07d8b3869cb8ad2bb06d353a7a.zip
libq: standardise build
Compile each C-file by itself, producing an object which is linked into a convenience archive. The q program then links against that archive. Switch to autotools-based build for everyone. Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 8252f612..f7326262 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,6 +1,6 @@
ACLOCAL_AMFLAGS = -I autotools/m4
-SUBDIRS = autotools/gnulib
+SUBDIRS = autotools/gnulib libq
portagedir = $(sysconfdir)/portage
postsyncddir = $(portagedir)/repo.postsync.d
@@ -11,9 +11,11 @@ bin_PROGRAMS = q
q_SOURCES = main.c
q_CPPFLAGS = \
-I$(top_builddir)/autotools/gnulib \
- -I$(top_srcdir)/autotools/gnulib
+ -I$(top_srcdir)/autotools/gnulib \
+ -I$(top_srcdir)/libq
q_LDADD = \
$(top_builddir)/autotools/gnulib/libgnu.a \
+ $(top_builddir)/libq/libq.la \
-liniparser \
$(LIB_CLOCK_GETTIME) \
$(LIB_EACCESS)