aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2022-08-29 10:10:08 +0200
committerFabian Groffen <grobian@gentoo.org>2022-08-29 10:10:08 +0200
commitefff7e86cececb54493a2d5f9210ffa72651d8ce (patch)
tree92eaad75034424f86e155f19fa5f4d5b7c24ffa8 /configure.ac
parentbuild-sys: regenerate (diff)
downloadportage-utils-efff7e86cececb54493a2d5f9210ffa72651d8ce.tar.gz
portage-utils-efff7e86cececb54493a2d5f9210ffa72651d8ce.tar.bz2
portage-utils-efff7e86cececb54493a2d5f9210ffa72651d8ce.zip
configure.ac: set ENABLE_QTEGRITY/ENABLE_QMANIFEST again
regression introduced by b81049495052e953941fc21f6936fbb968a3462a Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9f892c64..c26848ab 100644
--- a/configure.ac
+++ b/configure.ac
@@ -118,6 +118,14 @@ AS_IF([test "x${enable_qmanifest}" != "xno"], [
AM_CONDITIONAL([QMANIFEST_ENABLED], [test "x$enable_qmanifest" != xno])
AM_CONDITIONAL([QTEGRITY_ENABLED], [test "x$enable_qtegrity" != xno])
+if test "x$enable_qmanifest" != xno ; then
+ AC_DEFINE([ENABLE_QMANIFEST], [1],
+ [Define if qmanifest should be compiled])
+fi
+if test "x$enable_qtegrity" != xno ; then
+ AC_DEFINE([ENABLE_QTEGRITY], [1],
+ [Define if qtegrity should be compiled])
+fi
AX_CFLAGS_WARN_ALL
AC_DEFUN([PT_CHECK_CFLAG],[AX_CHECK_COMPILER_FLAGS([$1],[CFLAGS="$CFLAGS $1"])])