aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Gladkov <legion@kernel.org>2024-06-04 17:31:06 +0200
committerZac Medico <zmedico@gentoo.org>2024-06-04 08:40:25 -0700
commit8bb7aecf7e5c922911192d0df63853c5c75d9f8a (patch)
treedecd0707eef1770ad61e23566617306e3cef39e1
parentNEWS, meson.build: prepare for portage-3.0.65 (diff)
downloadportage-8bb7aecf7e5c922911192d0df63853c5c75d9f8a.tar.gz
portage-8bb7aecf7e5c922911192d0df63853c5c75d9f8a.tar.bz2
portage-8bb7aecf7e5c922911192d0df63853c5c75d9f8a.zip
sync/zipfile: Install zipfile sync method
Add files that were accidentally forgotten when adding zipfile sync method. Fixes: 80445d9b0 ("sync: Add method to download zip archives") Signed-off-by: Alexey Gladkov <legion@kernel.org> Closes: https://github.com/gentoo/portage/pull/1340 Signed-off-by: Zac Medico <zmedico@gentoo.org>
-rw-r--r--lib/portage/sync/modules/meson.build1
-rw-r--r--lib/portage/sync/modules/zipfile/meson.build8
2 files changed, 9 insertions, 0 deletions
diff --git a/lib/portage/sync/modules/meson.build b/lib/portage/sync/modules/meson.build
index fab2878e9..ba0b6f278 100644
--- a/lib/portage/sync/modules/meson.build
+++ b/lib/portage/sync/modules/meson.build
@@ -12,3 +12,4 @@ subdir('mercurial')
subdir('rsync')
subdir('svn')
subdir('webrsync')
+subdir('zipfile')
diff --git a/lib/portage/sync/modules/zipfile/meson.build b/lib/portage/sync/modules/zipfile/meson.build
new file mode 100644
index 000000000..46006aea7
--- /dev/null
+++ b/lib/portage/sync/modules/zipfile/meson.build
@@ -0,0 +1,8 @@
+py.install_sources(
+ [
+ 'zipfile.py',
+ '__init__.py',
+ ],
+ subdir : 'portage/sync/modules/zipfile',
+ pure : not native_extensions
+)