summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/libpq/libpq-99.99.99.ebuild')
-rw-r--r--dev-db/libpq/libpq-99.99.99.ebuild20
1 files changed, 7 insertions, 13 deletions
diff --git a/dev-db/libpq/libpq-99.99.99.ebuild b/dev-db/libpq/libpq-99.99.99.ebuild
index abe458c..7bd55e8 100644
--- a/dev-db/libpq/libpq-99.99.99.ebuild
+++ b/dev-db/libpq/libpq-99.99.99.ebuild
@@ -1,18 +1,22 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
+EAPI="1"
+
inherit eutils
DESCRIPTION="Dummy ebuild provided to satisfy dependency"
HOMEPAGE="http://overlays.gentoo.org/proj/postgresql/"
LICENSE="POSTGRESQL"
-SLOT="0"
+SLOT="4"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
IUSE="fixme threads"
-RDEPEND="dev-db/postgresql-libs"
+DEPEND="!dev-db/libpq:3"
+RDEPEND="${DEPEND}"
+PDEPEND="dev-db/postgresql-base"
pkg_setup() {
if ! use fixme ; then
@@ -22,16 +26,6 @@ pkg_setup() {
ewarn "tree, isn't it?"
die "Fix me!"
fi
- if use threads && ! built_with_use dev-db/postgresql-libs threads ; then
- ewarn "If you want to use threads in libpq, you definitely"
- ewarn "should add the USE flg to postgresql-libs, not only libpq"
- die "Fix me!"
- fi
- if ! use threads && built_with_use dev-db/postgresql-libs threads ; then
- ewarn "If you don't want to enable threads in libpq, do it for"
- ewarn "dev-libs/postgresql-libs too"
- die "Fix me!"
- fi
}
pkg_postinst() {